3PAR Stor Snap and Hyper-V Proxy probl with 1 VM

Hyper-V specific discussions

3PAR Stor Snap and Hyper-V Proxy probl with 1 VM

Veeam Logoby StephanG » Thu Feb 02, 2017 6:50 am

Hey there,

i recently opened a case (02055598) for my problem.
I have added the 3PAR VSS Hardware Provider and HP 3PAR CLI for most of my blades and it is working. But on one Host which holds the Exchange 2013 VM (with 16 TB LUN) the backup fails with:
01.02.2017 20:32:24 :: Unable to allocate processing resources. Error: There is no hardware provider for off-host backup detected. Snapshot failover is disabled.

I forced the usage of the hardware VSS to avoid that the microsoft VSS is used. Problem with that: Backup takes for hours and the merge too.

I moved 2 other VMs on that host on another LUN to check if the "hardware provider" is working at all. Well it is and these VMs are just backuped fine.
Excerpt log:
01.02.2017 17:31:21 :: Creating snapshot HP 3PAR VSS Provider on Hyper-V Off-Host Backup Proxy (mode: Veeam application-aware processing)
01.02.2017 17:32:23 :: Importing snapshot on offhost proxy Hyper-V Off-Host Backup Proxy
01.02.2017 17:32:56 :: Using backup proxy Hyper-V Off-Host Backup Proxy for D:\Hyper-V\VIRT-WSUS02\Virtual Hard Disks\VIRT-WSUS02.vhdx

The VSS Hardware Provider also does not start writing a log. So i think it really stops before it tries to use the VSS provider.

Someone has these big LUNs presented and can backup with Storage Snapshots?
I use an old version of the CLI and the VSS provider because it was tested fine.
CLI is: 3.2.1.120-MU1
VSS Provider is: 2.4.0

Best regards
Stephan
StephanG
Influencer
 
Posts: 15
Liked: never
Joined: Sun Sep 07, 2014 11:15 am
Full Name: Stephan G

Re: 3PAR Stor Snap and Hyper-V Proxy probl with 1 VM

Veeam Logoby StephanG » Thu Feb 02, 2017 7:44 am

I now installed the newest VSS and CLI on the host of the VM. Still the same issue.
Other VMs still backup fine
StephanG
Influencer
 
Posts: 15
Liked: never
Joined: Sun Sep 07, 2014 11:15 am
Full Name: Stephan G

Re: 3PAR Stor Snap and Hyper-V Proxy probl with 1 VM

Veeam Logoby StephanG » Fri Feb 03, 2017 1:04 pm

The colleague who installed the machine put the configuration / snapshot / smart paging on drive C. Which is not on the 3PAR but direct attached.
So the 3PAR VSS agent CANNOT work.
This guy owns me some beers.
StephanG
Influencer
 
Posts: 15
Liked: never
Joined: Sun Sep 07, 2014 11:15 am
Full Name: Stephan G

Re: 3PAR Stor Snap and Hyper-V Proxy probl with 1 VM

Veeam Logoby StephanG » Fri Feb 03, 2017 1:34 pm

But it still does not work as expected. The snapshot on the drive should be merged right after the storage snapshot got mounted. But it does not.
It grows and is merged after the backup.
I thought this is one of the advantages using storage snapshots with Veeam
StephanG
Influencer
 
Posts: 15
Liked: never
Joined: Sun Sep 07, 2014 11:15 am
Full Name: Stephan G


Return to Microsoft Hyper-V



Who is online

Users browsing this forum: No registered users and 1 guest