Equallogic On Latest Firmware-Volume Snapshots Not Deleting

Hyper-V specific discussions

Equallogic On Latest Firmware-Volume Snapshots Not Deleting

Veeam Logoby stevedarl1 » Tue Jan 07, 2014 10:50 am

We have just upgraded to the latest Dell Equallogic firmware V7.0.1 on our iSCSI SANs and now when a backup runs it snapshots the volumes fine but does not remove them after completion. Anyone else had similar issues after upgrading the firmware? It means multiple snapshots are being created for VMs that are backing up from the same Volume. It is a manual process at the moment to remove the snapshots every day.

Environment:

Hyper-V 2012 and Hyper-V 2012 R2 cluster
Veeam V7 R2
Equallogic iSCSI SANs running V7.0.1
stevedarl1
Influencer
 
Posts: 14
Liked: never
Joined: Fri Apr 19, 2013 1:22 pm
Full Name: Steve Darlington

Re: Equallogic On Latest Firmware-Volume Snapshots Not Delet

Veeam Logoby v.Eremin » Tue Jan 07, 2014 11:10 am

Hi, Steve,

Have you already contacted support team with this issue? They will be able to determine whether this behaviour is caused by the latest firmware and not by other environmental factors/changes that passed unnoticed.

Thanks.
v.Eremin
Veeam Software
 
Posts: 13255
Liked: 966 times
Joined: Fri Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin

Re: Equallogic On Latest Firmware-Volume Snapshots Not Delet

Veeam Logoby stevedarl1 » Tue Jan 07, 2014 12:24 pm

Hi,

Yes I have, the Veeam logs show the commands being sent to create/delete the snapshot. I believe this to be an Equallogic issue, however I was just seeing if anyone else has had similar issues.
stevedarl1
Influencer
 
Posts: 14
Liked: never
Joined: Fri Apr 19, 2013 1:22 pm
Full Name: Steve Darlington

Re: Equallogic On Latest Firmware-Volume Snapshots Not Delet

Veeam Logoby foggy » Tue Jan 07, 2014 12:36 pm

I believe no one has reported similar issues here so far, so it is worth contacting Dell support for clarification. Thanks.
foggy
Veeam Software
 
Posts: 14712
Liked: 1075 times
Joined: Mon Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson

Re: Equallogic On Latest Firmware-Volume Snapshots Not Delet

Veeam Logoby stevedarl1 » Tue Jan 07, 2014 3:26 pm

Hi Foggy, do you know the command or syntax that is used to take/remove a snapshot? We use on host backups with Dell Auto Snapshot Manager to take Hardware VSS snapshots.

Thanks.
stevedarl1
Influencer
 
Posts: 14
Liked: never
Joined: Fri Apr 19, 2013 1:22 pm
Full Name: Steve Darlington

Re: Equallogic On Latest Firmware-Volume Snapshots Not Delet

Veeam Logoby foggy » Mon Jan 13, 2014 3:57 pm

Steve, the snapshot is created with the IVssBackupComponents::DoSnapshotSet method and should be automatically deleted on releasing the IVssBackupComponents object.
foggy
Veeam Software
 
Posts: 14712
Liked: 1075 times
Joined: Mon Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson

Re: Equallogic On Latest Firmware-Volume Snapshots Not Delet

Veeam Logoby matt306 » Thu Jan 23, 2014 10:19 pm 2 people like this post

I work with Steve and we've had a reply from Equallogic today. It transpires they have missed something in VSS support, hence why the snapshots aren't being deleted. They hinted that we were not the only customers affected and that a patch "may" be available soon, although it wasn't confirmed if this would be an official release or an early deployment/availability patch.
matt306
Influencer
 
Posts: 19
Liked: 11 times
Joined: Mon Jan 06, 2014 2:29 pm
Full Name: Matthew Brown

Re: Equallogic On Latest Firmware-Volume Snapshots Not Delet

Veeam Logoby foggy » Fri Jan 24, 2014 5:22 am

Thanks for these news, Matt! Much appreciated.
foggy
Veeam Software
 
Posts: 14712
Liked: 1075 times
Joined: Mon Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson

Re: Equallogic On Latest Firmware-Volume Snapshots Not Delet

Veeam Logoby Argos » Mon Feb 03, 2014 8:50 pm

I am seeing the same issue with firmware v7.01 on Equallogic. Snapshots not being automatically deleted.
Argos
Lurker
 
Posts: 1
Liked: never
Joined: Mon Feb 03, 2014 8:43 pm

Re: Equallogic On Latest Firmware-Volume Snapshots Not Delet

Veeam Logoby foggy » Tue Feb 04, 2014 5:32 am

I believe you could also contact Dell support to be notified once the above mentioned fix is available. Thanks.
foggy
Veeam Software
 
Posts: 14712
Liked: 1075 times
Joined: Mon Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson

Re: Equallogic On Latest Firmware-Volume Snapshots Not Delet

Veeam Logoby stevedarl1 » Tue Feb 04, 2014 9:45 am

Not only are the snapshots not deleting automatically still, but we are now seeing snapshots failing to online once created within Equallogic group manager. If anyone sees this issue in Veeam the job will just sit there until you manually online the snapshot within group manager, it then resumes the backup.

Dell are releasing the new V7.0.2 firmware within the next week or 2 and they have confirmed the code has returned. However HIT kit 4.7 will not be released until March sometime and apparently this issue is related to HIT kit 4.6 on the hosts which is where the VSS credentials are stored. The new HIT kit will also be 2012 R2 compatible however we ran V4.6 for 3 months on 2012 R2 hosts using the old Equallogic firmware without issues.
stevedarl1
Influencer
 
Posts: 14
Liked: never
Joined: Fri Apr 19, 2013 1:22 pm
Full Name: Steve Darlington

Re: Equallogic On Latest Firmware-Volume Snapshots Not Delet

Veeam Logoby bcscholl » Mon Feb 10, 2014 2:14 pm

Any updates on this?

I've set my Snapshot Reserve down to 10%, turned off borrowing. This seems to work, just deletes the oldest snapshot when it needs more space.
bcscholl
Influencer
 
Posts: 18
Liked: 2 times
Joined: Wed Dec 04, 2013 3:56 pm
Full Name: Brian Scholl

Re: Equallogic On Latest Firmware-Volume Snapshots Not Delet

Veeam Logoby matt306 » Mon Feb 10, 2014 10:04 pm

No news yet from Dell, still the same 7.0.2 is due in the next couple of weeks and HIT 4.7 by March.

Originally we did the same with limiting the snapshots, but had a couple of instances of losing iSCSI connections to volumes once the snapshot ran out of space. Since then we've sent a load of logs to Dell who found a controller panic on one of the SAN's so it's possible it was this not the snapshot that caused our issues.

As we can't be sure we're still deleting shortly after they're used, although recently we've got braver and allowed a whole job to complete before removing them.
matt306
Influencer
 
Posts: 19
Liked: 11 times
Joined: Mon Jan 06, 2014 2:29 pm
Full Name: Matthew Brown

Re: Equallogic On Latest Firmware-Volume Snapshots Not Delet

Veeam Logoby bcscholl » Wed Feb 12, 2014 12:34 am

I’ve seen a few MPIO and disk errors on one of my Hyper-V nodes as the snapshot is started. During that time I cannot browse to C:\ClusterVolumes folder. All the VMs stay running and still look to write data to the disk. No Cluster events are recorded, no CSV ownership is changed. My worry is that at some point it will break something. Holding my breath and hoping 4.7 HIT kit will fix the MPIO errors.
bcscholl
Influencer
 
Posts: 18
Liked: 2 times
Joined: Wed Dec 04, 2013 3:56 pm
Full Name: Brian Scholl

Re: Equallogic On Latest Firmware-Volume Snapshots Not Delet

Veeam Logoby matt306 » Thu Feb 13, 2014 11:34 pm

7.0.2 is now available, which allegedly adds the VSS commands back in (although nothing is mentioned in the release notes). However it will not fix the deleting snapshots until HIT 4.7 is released.
matt306
Influencer
 
Posts: 19
Liked: 11 times
Joined: Mon Jan 06, 2014 2:29 pm
Full Name: Matthew Brown

Next

Return to Microsoft Hyper-V



Who is online

Users browsing this forum: No registered users and 9 guests