Increasing memory Usage Over Time VEEAMSQL2012

Hyper-V specific discussions

Increasing memory Usage Over Time VEEAMSQL2012

Veeam Logoby NashBrydges » Tue Mar 31, 2015 5:34 pm

Hi All,

I've seen a strange issue with my setup that I can't seem to find documented on this forum.

I'm running Veeam B&R v8.0.0.917 on a MS Server 2012R2 single CPU Hyper-V host. The OS has all of the patches and updates installed. Veeam B&R has been updated with the Dec 2014 patch as well. The host has 32GB RAM and is running 7 VMs at the moment.

The issue I am seeing is that the RAM usage keeps increasing. Each day, it goes up a bit more. I'm now running 3.4GB assigned to this process while after a fresh reboot, it is around 340MB. After a reboot, and after each backup, I see the RAM usage going up. I've not opened a support case yet as I was hoping someone may have an idea as to whether this is normal behavior or not. If this sounds like it isn't normal, I'll open a support request.
NashBrydges
Enthusiast
 
Posts: 25
Liked: 1 time
Joined: Sun Jan 04, 2015 5:05 pm

Re: Increasing memory Usage Over Time VEEAMSQL2012

Veeam Logoby foggy » Tue Mar 31, 2015 9:02 pm

This is definitely not expected, please open a case and provide its ID here for future reference. Thanks!
foggy
Veeam Software
 
Posts: 14742
Liked: 1079 times
Joined: Mon Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson

Re: Increasing memory Usage Over Time VEEAMSQL2012

Veeam Logoby Vitaliy S. » Wed Apr 01, 2015 2:57 pm

NashBrydges wrote:The OS has all of the patches and updates installed.

Do see Veeam process or SQL Server process eating all the memory? Does SQL Server also has all updates installed?
Vitaliy S.
Veeam Software
 
Posts: 19558
Liked: 1102 times
Joined: Mon Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov

Re: Increasing memory Usage Over Time VEEAMSQL2012

Veeam Logoby NashBrydges » Sat Apr 04, 2015 1:11 pm

The only install of SQL Server is the one that Veeam installs itself and all updates have been applied.

Thanks for the responses, I'll open a case.
NashBrydges
Enthusiast
 
Posts: 25
Liked: 1 time
Joined: Sun Jan 04, 2015 5:05 pm

Re: Increasing memory Usage Over Time VEEAMSQL2012

Veeam Logoby NashBrydges » Sat Apr 11, 2015 6:31 pm 1 person likes this post

Thought I'd report back with an update.

I decided that I should uninstall and reinstall Veeam B&R first before opening a support ticket. I reinstalled Veeam as well as Patch 1 and Patch 2 (in order to test endpoint backup as well) and since the reinstallation, the RAM usage has returned to normal. It remains at around 250MB to 350MB no matter how often the backups have been run. Good news since it fixed the issue! No ticket needed.
NashBrydges
Enthusiast
 
Posts: 25
Liked: 1 time
Joined: Sun Jan 04, 2015 5:05 pm

Re: Increasing memory Usage Over Time VEEAMSQL2012

Veeam Logoby Vitaliy S. » Sun Apr 12, 2015 1:14 pm

Thanks for the update, glad that you've resolved, though it would still be helpful if you open a case for our team to review the possible cause of the issue.
Vitaliy S.
Veeam Software
 
Posts: 19558
Liked: 1102 times
Joined: Mon Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov


Return to Microsoft Hyper-V



Who is online

Users browsing this forum: No registered users and 4 guests