Off-host proxy not working - because of OS mismatch?

Hyper-V specific discussions

Off-host proxy not working - because of OS mismatch?

Veeam Logoby StephanF » Mon Jul 27, 2015 8:37 pm

Hi everybody,

After setting up a shiny new backup server I wanted to use it as a Hyper-V Offhost proxy but this does not work. Backup jobs are done onhost and if I force usage off the offhost proxy the job fails with "no suitable proxies for off-host backup available".

Backup Source is a 3 node Hyper-V cluster with Windows Server 2012 and Equallogic SAN. As far as I can tell everything is setup correctly. VSS Provider is installed on the backup server (=proxy), volume is visible to the server, etc.
I double checked everything I found in the online help and howtos.

The only think that is not setup "best practice" is the OS mismatch between cluster nodes and backup server. The cluster is Windows Server 2012 and the backup server is Windows Server 2012 R2.
So my question: Is this the source of the problem? Is the same OS version a hard requirement or just a best practice?
Should I open a support case and let the techguys take a look or is this nonsense because it can not work at the moment?

Greetings
Stephan
StephanF
Enthusiast
 
Posts: 30
Liked: 6 times
Joined: Thu Mar 26, 2015 1:15 pm

Re: Off-host proxy not working - because of OS mismatch?

Veeam Logoby alanbolte » Mon Jul 27, 2015 11:12 pm

OS version is a hard requirement, not a best practice.
alanbolte
Expert
 
Posts: 635
Liked: 170 times
Joined: Mon Jun 18, 2012 8:58 pm
Full Name: Alan Bolte

Re: Off-host proxy not working - because of OS mismatch?

Veeam Logoby v.Eremin » Tue Jul 28, 2015 7:52 am

It's a hard requirement, indeed, that is mentioned in our User Guide.

Versions of the Hyper-V host and off-host backup proxy must coincide.


Thanks.
v.Eremin
Veeam Software
 
Posts: 13291
Liked: 973 times
Joined: Fri Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin

Re: Off-host proxy not working - because of OS mismatch?

Veeam Logoby StephanF » Tue Jul 28, 2015 11:01 am

Ok. Thank you. This is clear. Don't know why I thought it would work this way,
Seems I have to do a cluster update soon.
StephanF
Enthusiast
 
Posts: 30
Liked: 6 times
Joined: Thu Mar 26, 2015 1:15 pm

Re: Off-host proxy not working - because of OS mismatch?

Veeam Logoby v.Eremin » Tue Jul 28, 2015 11:13 am

Makes sense. Just in case, backup VMs residing on that cluster prior to updating; should be helpful, if something goes wrong with updating process. Thanks.
v.Eremin
Veeam Software
 
Posts: 13291
Liked: 973 times
Joined: Fri Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin


Return to Microsoft Hyper-V



Who is online

Users browsing this forum: No registered users and 6 guests