Surebackup Results in "Missing VM's" in SCVMM

Hyper-V specific discussions

Surebackup Results in "Missing VM's" in SCVMM

Veeam Logoby Aurock » Wed Mar 19, 2014 11:29 am

This isn't necessarily a Veeam issue exactly, but being Veeam related I expect that others here have probably run into this and might be able to suggest a solution.

I have a SureBackup job set to test one VM out of our daily Veeam backup job. It spins it up on the backup repository, which is also Hyper-V host containing a couple of guests. We also have System Center 2012 in our environment, and VMM manages all of our hyperv hosts. When Veeam creates a 'new' VM each day for the SureBackup job, System Center notes the new guest and adds it in VMM. A short time later, Veeam verifies the restored VM and is running successfully, then deletes the new it. VMM still knows about the VM, but marks it as "missing" since it has been removed from the host. Every day, the process repeats, and another "missing" vm is added to the list. This ends up creating alerts in OpsMgr for each of the missing VM's as well. I go in periodically and delete a bunch of "missing" surebackup VM's, but it seems to me that there's probably something I can change in the configuration of either Veeam, VMM, or the Hyper-V host, that would stop this from happening.

Does anyone know how I can resolve this issue, rather than simply cleaning up symptoms after the fact?
Aurock
Influencer
 
Posts: 22
Liked: 5 times
Joined: Mon Jul 01, 2013 1:28 pm
Full Name: Steve Whitcher

Re: Surebackup Results in "Missing VM's" in SCVMM

Veeam Logoby foggy » Wed Mar 19, 2014 11:57 am

Steve, how have you added Hyper-V hosts to Veeam B&R console? If they are added as standalone hosts, the observed behavior is expected, since SCVMM is not notified by Veeam B&R about removed VMs. Try adding SCVMM to Veeam B&R directly instead.
foggy
Veeam Software
 
Posts: 14765
Liked: 1083 times
Joined: Mon Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson

Re: Surebackup Results in "Missing VM's" in SCVMM

Veeam Logoby Aurock » Wed Mar 19, 2014 1:27 pm

So if the VMM server were added instead of the standalone hosts, Veeam would notify VMM when the guests are removed?

I know I had added the VMM server originally and later switched to just the standalone host. I don't recall exactly why, other than that we only have 1 host licensed for veeam backup, and by adding VMM all of the servers showed up in the veeam console. I'll have to see if I can find notes on why I made that change, and might switch back if it wasn't anything major.
Aurock
Influencer
 
Posts: 22
Liked: 5 times
Joined: Mon Jul 01, 2013 1:28 pm
Full Name: Steve Whitcher

Re: Surebackup Results in "Missing VM's" in SCVMM

Veeam Logoby foggy » Wed Mar 19, 2014 1:28 pm

Aurock wrote:So if the VMM server were added instead of the standalone hosts, Veeam would notify VMM when the guests are removed?

Correct.
foggy
Veeam Software
 
Posts: 14765
Liked: 1083 times
Joined: Mon Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson


Return to Microsoft Hyper-V



Who is online

Users browsing this forum: Yahoo [Bot] and 7 guests