Discussions specific to the Microsoft Hyper-V hypervisor
mkaec
Expert
Posts: 322
Liked: 72 times
Joined: Jul 16, 2015 1:31 pm
Full Name: Marc K
Contact:

Re: v9 replication jobs getting stuck on 'Building VMs list'

Post by mkaec » May 02, 2016 4:41 pm

Hmm. Why didn't they reach out to me? I had opened a case about this back in Feb.

Vitaliy S.
Product Manager
Posts: 23001
Liked: 1557 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: v9 replication jobs getting stuck on 'Building VMs list'

Post by Vitaliy S. » May 02, 2016 4:53 pm

Is this ticket still open? If it is closed, then this explains why the didn't contact you with a solution. Also it is worth confirming that the issue discussed in this thread, applies to your situation too.

mkaec
Expert
Posts: 322
Liked: 72 times
Joined: Jul 16, 2015 1:31 pm
Full Name: Marc K
Contact:

Re: v9 replication jobs getting stuck on 'Building VMs list'

Post by mkaec » May 02, 2016 4:55 pm

It was closed because the issue was intermittent. Perhaps I should not have agreed to the closing of the case.

Vitaliy S.
Product Manager
Posts: 23001
Liked: 1557 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: v9 replication jobs getting stuck on 'Building VMs list'

Post by Vitaliy S. » May 02, 2016 5:07 pm

Yes, it's always better to investigate all issues further. Probably, there was not enough information in the log files to understand what's happening, thus the case was closed.

epcopdu
Lurker
Posts: 1
Liked: never
Joined: May 02, 2016 7:08 pm
Full Name: Chad Holm
Contact:

Re: v9 replication jobs getting stuck on 'Building VMs list'

Post by epcopdu » May 02, 2016 7:38 pm

I am having the same issue. 2x Hyper-V 2012 R2. One is a Hyper-V only install, the other is full Datacenter with the hyper-V role installed. Veeam is running on a dedicated VM on the full install version, which has a DAS target for backups.

I cannot kill the job when it sticks. I have to restart the Veeam server VM. I sometimes have to restart a few times before I can start the job manually. Endpoint backups never fail (for remaining physical servers), just the job configured for the host servers. If it passes the "Building VMs list" message (15 seconds or so when it works) it will complete. Veeam is currently working as scheduled less than half the time. Will start a new case but just wanted to add support to this one.

MCU_Networking
Influencer
Posts: 21
Liked: 5 times
Joined: May 02, 2016 10:21 pm
Full Name: Michael Taylor
Contact:

Re: v9 replication jobs getting stuck on 'Building VMs list'

Post by MCU_Networking » May 02, 2016 10:24 pm 2 people like this post

Call techsupport and ask for the hotfix for this issue. I had the same issue. It is a new .DLL file they give you. You will stop all services, replace .DLL and restart services. Issue will hopefully be resolved for you.

kamiwa
Novice
Posts: 3
Liked: 3 times
Joined: Apr 30, 2016 3:10 pm
Full Name: Kai Michael Wadsack
Contact:

Re: v9 replication jobs getting stuck on 'Building VMs list'

Post by kamiwa » May 08, 2016 7:51 am 1 person likes this post

Reported this issue last Saturday here on the forum and to Veeam Support.
Received a hotfix (most likely the same DLL as mentioned in above post) from Veeam the next day (Sunday).
Been testing the fix since then and all replication jobs have been running w/o any problems at all.
Can only confirm above post: If you're pestered by this problem, contact Veeam support.
They can and they will help.

jazzoberoi
Enthusiast
Posts: 79
Liked: 17 times
Joined: Oct 08, 2014 9:07 am
Full Name: Jazz Oberoi
Contact:

Re: v9 replication jobs getting stuck on 'Building VMs list'

Post by jazzoberoi » May 12, 2016 12:44 am

Hi Guys, any ideas whether this .DLL hotfix will make it as part of the next Veeam update ?

mkaec
Expert
Posts: 322
Liked: 72 times
Joined: Jul 16, 2015 1:31 pm
Full Name: Marc K
Contact:

Re: v9 replication jobs getting stuck on 'Building VMs list'

Post by mkaec » May 12, 2016 1:24 pm

I can't imagine that it wouldn't be included.

Vitaliy S.
Product Manager
Posts: 23001
Liked: 1557 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: v9 replication jobs getting stuck on 'Building VMs list'

Post by Vitaliy S. » May 12, 2016 3:34 pm

All private hot-fixes are included to our updates, as this is the main reason for the update - to consolidate all the fixes we have for the corresponding major version.

Eluminare
Influencer
Posts: 15
Liked: 6 times
Joined: Dec 10, 2015 2:26 pm
Full Name: René Keller
Contact:

Re: v9 replication jobs getting stuck on 'Building VMs list'

Post by Eluminare » May 13, 2016 7:24 am 1 person likes this post

We have the same issue in our environment. We got an hotfix and modified the registry to process wmi queries on the local servers instead from the veeam server.
Issues: 01768160, 01776380

We could reduce the time from over 3 hours to 20 - 70 minutes.

jazzoberoi
Enthusiast
Posts: 79
Liked: 17 times
Joined: Oct 08, 2014 9:07 am
Full Name: Jazz Oberoi
Contact:

Re: v9 replication jobs getting stuck on 'Building VMs list'

Post by jazzoberoi » May 15, 2016 11:25 pm

Excellent.. when contacting support, is there any reference number to this issue to obtain the hotfix ?

Also, any ideas as to when the next updated version of B&R is scheduled to release ?

foggy
Veeam Software
Posts: 18278
Liked: 1564 times
Joined: Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson
Contact:

Re: v9 replication jobs getting stuck on 'Building VMs list'

Post by foggy » May 16, 2016 11:46 am

You can reference the case numbers mentioned in the previous post.

nickpoore
Novice
Posts: 6
Liked: never
Joined: Jul 14, 2016 3:20 pm
Full Name: Nicholas Poore
Contact:

[MERGED] Backup Stuck - Building VMs list

Post by nickpoore » Aug 06, 2016 8:31 pm

Physical Server running 2012 R2 with HyperV.
B&R installed on physical server.

Backup has been running fine for about 3 weeks.
Last set of backups have failed.

Rebooted physical server.
All Veeam services are running.
Launch B&R.
Launch backup.
After 3 hours, I only have 2 actions in list.
1. Job started at x/x/x
2. Building VMs list.

All of the VM's show as Pending under the B&R console.
In the HyperV manager, non of the VM's show anything special under "status" - ie none of them are doing snapshots.

Any idea what's going on?

Nick.

veremin
Product Manager
Posts: 16901
Liked: 1439 times
Joined: Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin
Contact:

Re: v9 replication jobs getting stuck on 'Building VMs list'

Post by veremin » Aug 08, 2016 8:44 am

Hi, Nick,

Please, contact our support team. They should be able to pinpoint the root cause of the given problem.

Chances are, applying a hot fix will be required.

thanks.

mkaec
Expert
Posts: 322
Liked: 72 times
Joined: Jul 16, 2015 1:31 pm
Full Name: Marc K
Contact:

Re: v9 replication jobs getting stuck on 'Building VMs list'

Post by mkaec » Aug 08, 2016 1:38 pm 1 person likes this post

This problem has not recurred for us after installing the hotfix. It's been around 3 months of smooth sailing.

nmdange
Expert
Posts: 469
Liked: 113 times
Joined: Aug 20, 2015 9:30 pm
Contact:

Re: v9 replication jobs getting stuck on 'Building VMs list'

Post by nmdange » Aug 24, 2016 10:06 pm

Just wanted to note for anyone else that I ran into this issue (case #01880208) but in my case it was because one node in the cluster was down. It was the same issue with WMI queries, but bringing the node back online fixed the problem.

It would be nice if Veeam was better able to handle a Hyper-V cluster host being down, like if it checked the node's status before trying to talk to it. Consider this post a feature/enhancement request :)

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests