Veeam B&R 9 - Resource not ready: Snapshot

Hyper-V specific discussions

Veeam B&R 9 - Resource not ready: Snapshot

Veeam Logoby sgatke » Fri Mar 04, 2016 11:02 am

Veeam support case ID: 01717542

We recently upgraded Veeam B&R from v.8.x to v.9 at a client.
They run a single HyperV server with a few virtual servers.
Backup has been running flawlessly with Veeam 8.
Upgrade to v.9 completed with no errors and the (virtual) machine running Veeam has been restarted several times after the upgrade.

Unfortunately all jobs are now failing, or rather hanging at 0%.
Job logs from latest retry:
Job started at 04-03-2016 09:08:58
Building VMs list - 0:00:21
VM size: 2,0 GB (1,1 GB used)
Changed block tracking is enabled
Waiting for backup infrastructure resources availability - 2:47:24 (and still counting)

Status for the single VM in this particular job:
Queued for processing at 04-03-2016 09:09:30
Resource not ready: Snapshot

There are no other Veeam jobs running at the same time.
HyperV is running on a Windows Server 2008 R2 box.
Veeam is running on a virtual machine (Windows 7 Pro) on the same HyperV box.
Backups are sent to a local NAS.
Veeam Backup services has been restarted several times.

As mentioned above, this setup has worked flawlessly with Veeam 8 (and also Veeam 6 and Veeam 7).

Any ideas on how to fix this issue?
sgatke
Influencer
 
Posts: 21
Liked: 2 times
Joined: Thu Jul 05, 2012 11:23 am
Full Name: Simon Gatke

Re: Veeam B&R 9 - Resource not ready: Snapshot

Veeam Logoby Vitaliy S. » Fri Mar 04, 2016 2:35 pm

While you're waiting a response from your support engineer, can you please check if proxy servers require any update by any chance?
Vitaliy S.
Veeam Software
 
Posts: 19539
Liked: 1097 times
Joined: Mon Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov

Re: Veeam B&R 9 - Resource not ready: Snapshot SOLVED

Veeam Logoby sgatke » Fri Mar 04, 2016 3:03 pm 1 person likes this post

Vitaly, thank you for your reply.

I just got off the phone with Veeam Support.
We established a remote session and it took the engineer about 1 minute to solve the issue :-)

For anyone else running into a similar issue after upgrading to Veeam 9, go to Backup Infrastructure --> Managed Servers --> Standalone Hosts --> right-click on the host and select Manage Volumes.
In this case, 3 of the 4 connected volumes had a value of '0' Max concurrent snapshots. The 4th had a value of '4'.
After setting the value to '4' on all of them and restarting the backup jobs, it all seems to work again.

A big thank you to the Veeam support crew for helping me fix this.

Case is now marked as solved and closed.
sgatke
Influencer
 
Posts: 21
Liked: 2 times
Joined: Thu Jul 05, 2012 11:23 am
Full Name: Simon Gatke

Re: Veeam B&R 9 - Resource not ready: Snapshot

Veeam Logoby Vitaliy S. » Fri Mar 04, 2016 4:19 pm

Thanks for the update! I will ask our QA team to double-check the reason why concurrent snapshots tasks limit was set to 0 during the upgrade.
Vitaliy S.
Veeam Software
 
Posts: 19539
Liked: 1097 times
Joined: Mon Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov

Re: Veeam B&R 9 - Resource not ready: Snapshot

Veeam Logoby zag » Fri Mar 04, 2016 4:55 pm

Hi thank you so much for this, just spend the last 3hrs googling this on a Friday evening after all our backups failing last night after the Veeam 9 upgrade.

Indeed all our Standlone host maximum concurrent connections were reset to 0.

Veeam even showed an error saying this value is not possible.

Image

This is a very serious migration bug and should be fixed ASAP.

Glad I found this thread!
zag
Lurker
 
Posts: 1
Liked: never
Joined: Fri Mar 04, 2016 4:50 pm
Full Name: Zag

Re: Veeam B&R 9 - Resource not ready: Snapshot

Veeam Logoby sgatke » Mon Mar 07, 2016 2:10 pm

Hi Zag
I am glad that my post helped you and you got the problem fixed before the weekend.

Cheers
Simon
sgatke
Influencer
 
Posts: 21
Liked: 2 times
Joined: Thu Jul 05, 2012 11:23 am
Full Name: Simon Gatke

Re: Veeam B&R 9 - Resource not ready: Snapshot

Veeam Logoby brian.sargent » Wed Mar 23, 2016 8:55 pm

I can confirm the same issue following a v8 to v9 upgrade. Thanks for the post and fix!
brian.sargent
Lurker
 
Posts: 1
Liked: never
Joined: Fri Mar 21, 2014 7:46 pm
Full Name: Brian Sargent

Re: Veeam B&R 9 - Resource not ready: Snapshot

Veeam Logoby RobbieDe » Wed Apr 27, 2016 12:08 pm 1 person likes this post

Thanks for your post! I was also able to resolve my issue using this solution :)
RobbieDe
Lurker
 
Posts: 1
Liked: 1 time
Joined: Wed Apr 27, 2016 12:06 pm


Return to Microsoft Hyper-V



Who is online

Users browsing this forum: No registered users and 5 guests