VSS Writer Offline

Hyper-V specific discussions

VSS Writer Offline

Veeam Logoby Joebocop » Fri Apr 01, 2016 4:18 pm

Seemingly out of nowhere, I have a VM backup job that fails.

Host is Server 2012 R2, guest is Server 2008 R2. Backup server is Veeam 9, u1.

For that Hyper-V host, Diskshadow's "list writers" command outputs:

[...]
+ Component "Microsoft Hyper-V VSS Writer:\09E6A7A8-DE09-4ACC-ABFE-E4F68E063AC7"
- Name: 09E6A7A8-DE09-4ACC-ABFE-E4F68E063AC7
- Logical path:
- Full path: \09E6A7A8-DE09-4ACC-ABFE-E4F68E063AC7
- Caption: Offline\Mail
- Type: VSS_CT_FILEGROUP [2]
- Is selectable: TRUE
- Is top level: TRUE
- Notify on backup complete: FALSE
- Paths affected by this component:
- S:\vms\mail\Snapshots
- S:\vms\mail\Snapshots\7203C8E3-50D1-42C7-9ECC-0E995A313AE1
- S:\vms\mail\Virtual Hard Disks
- S:\vms\mail\Virtual Hard Disks\
- S:\vms\mail\Virtual Machines\
- Volumes affected by this component:
- \\?\Volume{8f0782c9-0a82-4c00-b0fa-11da163258f1}\ [S:\]
- Component Dependencies:
[...]

How do I get the "OFFLINE" status to become "ONLINE", as required by the final step here:
https://www.veeam.com/kb1855

Thus far, I have tried rebooting the guest, and restarting the vmms service on the Hyper-V host.

Thank you.
Joebocop
Novice
 
Posts: 6
Liked: 3 times
Joined: Thu Dec 11, 2014 4:41 am

Re: VSS Writer Offline

Veeam Logoby alanbolte » Fri Apr 01, 2016 11:52 pm

I find sometimes the order services were started within the VM seems to matter. Try restarting the “Hyper-V Volume Shadow Copy Requestor” service now that you've rebooted the guest.
alanbolte
Expert
 
Posts: 635
Liked: 170 times
Joined: Mon Jun 18, 2012 8:58 pm
Full Name: Alan Bolte

Re: VSS Writer Offline

Veeam Logoby Vitaliy S. » Sun Apr 03, 2016 6:04 pm

Also I would check Windows Event log for more details about the issue. If nothing helps, then open a support case with our team for further assistance. Thanks!
Vitaliy S.
Veeam Software
 
Posts: 19575
Liked: 1104 times
Joined: Mon Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov

Re: VSS Writer Offline

Veeam Logoby Joebocop » Tue Apr 05, 2016 5:02 pm 3 people like this post

A restart of the "Hyper-V Volume Shadow Copy Requestor" has perhaps resolved this issue. The backup now completes successfully. Thank you.
Joebocop
Novice
 
Posts: 6
Liked: 3 times
Joined: Thu Dec 11, 2014 4:41 am


Return to Microsoft Hyper-V



Who is online

Users browsing this forum: No registered users and 5 guests