Real-time performance monitoring and troubleshooting
Post Reply
BjoernM
Novice
Posts: 3
Liked: 1 time
Joined: Jun 17, 2020 9:32 am
Full Name: Bjoern Mueller
Contact:

Create a custom alarm for a process/service on a Linux VM does not work as expected

Post by BjoernM »

Hello,

I´m just starting with Veeam One so forgive me if this is something trivial.
As the title already describes I want to create an alarm for a process/service on a Linux VM running in vSphere. Somehow this does not work at all.

Environment:
- Veeam One 10.0.0.750 running on a Server 2016 VM
- vSphere 6.7U3 Environment
- CentOS 8 Linux VM


Problem:
I want to create an alarm for e.g. chronyd service on this CentOS 8 VM
What I do is :
-> Alarm Management
-> Virtual Machine
-> New alarm
->for the Rule I set
- Rule type: Service state
- Condition: Not Equals State: Running
- Service name: chronyd
- Delay time: 1 min
- Severity: Error

The alarm is enabled and the rule is enabled as well.
Saved everything and assigned it to the VM

Expected behaviour:

When I stop the chronyd service on the VM after 1 minute there should be at least an alarm in the alarms section of the VM but nothing happens.


On the other hand when I define an alarm
- Rule type: Process state
- Condition: Not Equals State: Running
- Match: Any / All
- Process name: chronyd
- Delay time: 1 min
- Severity: Error

I get a constant Alarm that the process is not running, though the process tab lists it and the service chronyd is running.

Credentials for process and services are set. I can use both tabs in the Monitor and they show the processes/services. There also the state change from running to dead is shown for the chronyd.service.

If someone can give me some advice what to change or where I make a mistake that would be great.

Vitaliy S.
Product Manager
Posts: 24030
Liked: 1794 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: Create a custom alarm for a process/service on a Linux VM does not work as expected

Post by Vitaliy S. »

Hi Bjoern,

If you try to create this alarm from the right-click while standing on the processes tab, do you see the same behavior? If yes, then opening a support ticket with our technical team is required as everything looks correct to me.

Thanks!

BjoernM
Novice
Posts: 3
Liked: 1 time
Joined: Jun 17, 2020 9:32 am
Full Name: Bjoern Mueller
Contact:

Re: Create a custom alarm for a process/service on a Linux VM does not work as expected

Post by BjoernM »

Hi Vitaliy,

Thx for the quick reply. On the processes tab when I right-click I have only the options to Hang up/ Kill / Terminate the process.
No option to create an alarm.
I will open a support ticket.

Thanks.

Vitaliy S.
Product Manager
Posts: 24030
Liked: 1794 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: Create a custom alarm for a process/service on a Linux VM does not work as expected

Post by Vitaliy S. »

Once you do this, please post your case ID for future reference.

BjoernM
Novice
Posts: 3
Liked: 1 time
Joined: Jun 17, 2020 9:32 am
Full Name: Bjoern Mueller
Contact:

Re: Create a custom alarm for a process/service on a Linux VM does not work as expected

Post by BjoernM » 1 person likes this post

Opened a support case.
The ID is #04247525

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests