Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'

Real-time performance monitoring and troubleshooting

Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'

Veeam Logoby sethiel » Wed Sep 30, 2009 1:19 pm

Hi,
I have fresh install of veeam monitor on MYPC: 192.168.2.4
I try to connect to database installed on different system:
Veeam Monitor -> Options -> Server Settings -> Database -> Change Database ->
Server 192.168.1.2 -> Next (Select database) -> VeeamMonitor -> Next:
Begin configuration process.
Connecting to SQL Server 'MY-SQL-SERV1'
Connected.
Checking database 'VeeamMonitor' ...
Registering new database...
Database registered.
Restarting service...
Service restarted.
CONGRATULATION COMPLETED SUCCESSFULLY!

Finish.

Now I do:
add ESX
Hostname or IP: 192.168.1.3
username: root
pass: passforroot
port: 443

Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON' - marked by red colour

Anyone know why?
sethiel
Novice
 
Posts: 3
Liked: never
Joined: Wed Sep 30, 2009 1:08 pm

Re: Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'

Veeam Logoby Gostev » Wed Sep 30, 2009 8:05 pm

Please go to Monitor Settings > Collector tab > Logon and supply user with Local Administrator privileges and full permissions to VeeamMonitor database, then restart the service.
Gostev
Veeam Software
 
Posts: 21390
Liked: 2349 times
Joined: Sun Jan 01, 2006 1:01 am
Location: Baar, Switzerland

Re: Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'

Veeam Logoby sethiel » Thu Oct 01, 2009 7:01 am

Gostev thanks for answer,

When I type any other account than Local System account I have error message "Service cannot be started cause to failed login"

I remind that SQL Server and MYPC are different machines.
I know that I can install Veeam Monitor Server on SQL Server machine - and that way everything works fine.
But I love to have everything in the order, and I want to have Veeam Monitor Server on the different machine than SQL Server.
sethiel
Novice
 
Posts: 3
Liked: never
Joined: Wed Sep 30, 2009 1:08 pm

Re: Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'

Veeam Logoby Gostev » Thu Oct 01, 2009 11:05 am 1 person likes this post

You should do this:
1. Start > Run > secpol.msc
2. Local Pilicies -> User Rights Assigment
3. Double-click Log on as service
4. Click Add User or Group...
5. Add the user you specified in Monitor Server settings
Gostev
Veeam Software
 
Posts: 21390
Liked: 2349 times
Joined: Sun Jan 01, 2006 1:01 am
Location: Baar, Switzerland

Re: Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'

Veeam Logoby sethiel » Fri Oct 02, 2009 10:04 am

Thank you.
sethiel
Novice
 
Posts: 3
Liked: never
Joined: Wed Sep 30, 2009 1:08 pm


Return to Monitoring



Who is online

Users browsing this forum: No registered users and 3 guests