Real-time performance monitoring and troubleshooting
Post Reply
adept1
Enthusiast
Posts: 29
Liked: 4 times
Joined: May 09, 2015 1:58 pm
Contact:

Pulled power from one PSU - vCenter shows alert, but not Veeam ONE

Post by adept1 » Nov 01, 2019 4:44 am

I'm thinking about decommissioning our old HP Systems Insight Manager server since we have Veeam ONE.

Veeam ONE has been working great, and we've been using it for several years (we're on 9.5u4a).

Today I yanked the power out of one PSU on HP ProLiant DL380 Gen8 server to verify that Veeam ONE would alert me. I received no alert, so I went into the Veeam ONE Monitor console to check, and there's no alert there either.

There is an alert in our vCenter 6.7u3.

Please let me know what to check.

I will open a support request if it's not something obvious.

Thanks!

wishr
Veeam Software
Posts: 1260
Liked: 122 times
Joined: Aug 07, 2018 3:11 pm
Full Name: Fedor Maslov
Contact:

Re: Pulled power from one PSU - vCenter shows alert, but not Veeam ONE

Post by wishr » Nov 01, 2019 9:40 am

Hello Adept1,

You should get an alert in this case if it is not disabled and VONE is able to reach your vCenter. Opening a support case is the best way to proceed.

Thanks

adept1
Enthusiast
Posts: 29
Liked: 4 times
Joined: May 09, 2015 1:58 pm
Contact:

Re: Pulled power from one PSU - vCenter shows alert, but not Veeam ONE

Post by adept1 » Nov 04, 2019 9:57 am

I believe this should fall under the alert of "host hardware status" and this alert is not disabled. Anyway, 03844709 opened for this.

Shestakov
Veeam Software
Posts: 7009
Liked: 717 times
Joined: May 21, 2014 11:03 am
Full Name: Nikita Shestakov
Location: Prague
Contact:

Re: Pulled power from one PSU - vCenter shows alert, but not Veeam ONE

Post by Shestakov » Nov 04, 2019 1:49 pm

Hello,

There is no dedicated alarm for host power status, however, "Host connection failure" should work.
There is an alert in our vCenter 6.7u3.
Could you specify which alarm you are referring to?

Hardware Status alarm deals with more rare cases, such as:
display of Unknown status for the power node
inaccurate reading– for example 0 Watts, xyz Amps for power supplies
absence of power supply failure alarm– in such an event, only a redundancy failure warning is displayed
incorrect reading under Other node regarding system management module I2C err

adept1
Enthusiast
Posts: 29
Liked: 4 times
Joined: May 09, 2015 1:58 pm
Contact:

Re: Pulled power from one PSU - vCenter shows alert, but not Veeam ONE

Post by adept1 » Nov 05, 2019 11:32 pm

In vCenter, you'll see a "host power status" alarm for the host.

"Host connection failure" alarm is not applicable, because the server is still up and running off its other power supply.

I have also tried pulling the power supply out entirely and this did not generate a Veeam ONE alarm either. If this is normal, expected behavior, I'm pretty shocked, since power monitoring is such a basic need.

Waiting to see what support says. It'll be a shame if I have to maintain a whole other monitoring platform when I thought Veeam ONE could do everything I needed.

adept1
Enthusiast
Posts: 29
Liked: 4 times
Joined: May 09, 2015 1:58 pm
Contact:

Re: Pulled power from one PSU - vCenter shows alert, but not Veeam ONE

Post by adept1 » Nov 06, 2019 4:07 am

vCenter:

Image

Image

adept1
Enthusiast
Posts: 29
Liked: 4 times
Joined: May 09, 2015 1:58 pm
Contact:

Re: Pulled power from one PSU - vCenter shows alert, but not Veeam ONE

Post by adept1 » Nov 08, 2019 7:48 am

Support advised to change these registry settings on the Veeam ONE server:

path: HKEY_LOCAL_MACHINE\SOFTWARE\Veeam\Veeam ONE Monitor\Service\
DWORD Name: SensorAlarmDetectType
value: 1

path: HKEY_LOCAL_MACHINE\SOFTWARE\Veeam\Veeam ONE Monitor\Service\
DWORD Name: SensorsRefreshInterval
value: 3600

This made no difference for the HP ProLiant DL380 Gen8 server. I still received no alert from it.

I also tried a Dell server, and I did get an alert, however, it's not very useful. Furthermore, it says the previous status was error, when in fact it wasn't. Also, after reconnecting the power, I got the same alert again 10 minutes later. It's not a surprise this is disabled by default since it seems to be very buggy.

Image

Shestakov
Veeam Software
Posts: 7009
Liked: 717 times
Joined: May 21, 2014 11:03 am
Full Name: Nikita Shestakov
Location: Prague
Contact:

Re: Pulled power from one PSU - vCenter shows alert, but not Veeam ONE

Post by Shestakov » Nov 08, 2019 10:30 am

Thanks for the update.
I'll take you feedback into account as a feature request for the next releases.

adept1
Enthusiast
Posts: 29
Liked: 4 times
Joined: May 09, 2015 1:58 pm
Contact:

Re: Pulled power from one PSU - vCenter shows alert, but not Veeam ONE

Post by adept1 » Nov 11, 2019 1:26 am

Over the weekend this setting caused a lot of alarms that were not correct or relevant. I have now undone this setting.

Shestakov
Veeam Software
Posts: 7009
Liked: 717 times
Joined: May 21, 2014 11:03 am
Full Name: Nikita Shestakov
Location: Prague
Contact:

Re: Pulled power from one PSU - vCenter shows alert, but not Veeam ONE

Post by Shestakov » Nov 11, 2019 9:24 am

Yes, unfortunately there is no good workaround. We will add XML filter for Hyper-V events in next releases.
Thanks for updating!

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests