Real-time performance monitoring and troubleshooting
Post Reply
Nail.Mukhametshin
Enthusiast
Posts: 50
Liked: 3 times
Joined: May 05, 2016 1:15 pm
Full Name: Наиль Мухаметшин
Location: Russia, Moscow
Contact:

Troubleshooting: Collecting data stopped after some time

Post by Nail.Mukhametshin » Jul 07, 2017 1:08 pm

Hi all,

We use Veeam One Free edition.

It installed on Windows Server 2016 on Hyper-V VM with 8 CPU cores (E5-v2699 v4 as backend), 16 GB static memory, 50GB SSD. Right after server restarts it working fine and collects all needed data from attached to it 3 Hyper-V clusters (20 servers, all Windows Server 2012 R2)

After 8 days uptime we see that data collection for CSVs stops for some clusters. VeeamOne server average CPU usage 20% with 100-90% peaks for coupe of second, average 11 GB RAM used, and avg response time to disk operations 5-20 ms. We tied to increase CPUs count or RAM but it do not help.

Please help to troubleshoot this situation.
Nail Mukhametshin | System Engineer | R&D Services Infrastructure Development | Kaspersky Lab

Shestakov
Veeam Software
Posts: 7039
Liked: 725 times
Joined: May 21, 2014 11:03 am
Full Name: Nikita Shestakov
Location: Prague
Contact:

Re: Troubleshooting: Collecting data stopped after some time

Post by Shestakov » Jul 07, 2017 2:09 pm

Hi,
It`s hard to say without logs review. Did you get any connection drops between CSV and Hyper-V?
Anyway you may contact Veeam support team even with free license.
Thanks!

Nail.Mukhametshin
Enthusiast
Posts: 50
Liked: 3 times
Joined: May 05, 2016 1:15 pm
Full Name: Наиль Мухаметшин
Location: Russia, Moscow
Contact:

Re: Troubleshooting: Collecting data stopped after some time

Post by Nail.Mukhametshin » Jul 07, 2017 3:41 pm

I had opened a new case and will post here our findings.
Nail Mukhametshin | System Engineer | R&D Services Infrastructure Development | Kaspersky Lab

Shestakov
Veeam Software
Posts: 7039
Liked: 725 times
Joined: May 21, 2014 11:03 am
Full Name: Nikita Shestakov
Location: Prague
Contact:

Re: Troubleshooting: Collecting data stopped after some time

Post by Shestakov » Jul 07, 2017 3:56 pm

Could you post the support case number as well? Thanks!

Nail.Mukhametshin
Enthusiast
Posts: 50
Liked: 3 times
Joined: May 05, 2016 1:15 pm
Full Name: Наиль Мухаметшин
Location: Russia, Moscow
Contact:

Re: Troubleshooting: Collecting data stopped after some time

Post by Nail.Mukhametshin » Jul 07, 2017 4:07 pm

Sure - it's 02215126
Nail Mukhametshin | System Engineer | R&D Services Infrastructure Development | Kaspersky Lab

Nail.Mukhametshin
Enthusiast
Posts: 50
Liked: 3 times
Joined: May 05, 2016 1:15 pm
Full Name: Наиль Мухаметшин
Location: Russia, Moscow
Contact:

Re: Troubleshooting: Collecting data stopped after some time

Post by Nail.Mukhametshin » Aug 23, 2017 11:24 am

The solution was to change type of collecting performance data from perfmon to WMI:

On VeeamOne server change Registry: HKML\Software\Veeam\Veeam One Monitor\Service\HyperVCollectionType = 1 (dword)
Nail Mukhametshin | System Engineer | R&D Services Infrastructure Development | Kaspersky Lab

Shestakov
Veeam Software
Posts: 7039
Liked: 725 times
Joined: May 21, 2014 11:03 am
Full Name: Nikita Shestakov
Location: Prague
Contact:

Re: Troubleshooting: Collecting data stopped after some time

Post by Shestakov » Aug 24, 2017 2:57 pm

Thanks for the update!

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest