Using object storage as a backup target
Post Reply
macbobs
Novice
Posts: 4
Liked: never
Joined: Feb 01, 2021 8:46 am
Full Name: Robert Crichton
Contact:

AZURE SOBR - new machine weird Authentication error

Post by macbobs »

Hi all,

Hoping someone has seen this one before. I have opened a support ticket (( Case number 05530585 )) but seems to be struggling, hoping the community may be able to help!

I have a new hardware 2022 OS Server which I have whacked Veeam 11 on (11.0.1.1261) set up my local tin storage and set up an Azure SOBR setup to copy jobs to. The Azure storage account is one I use on another instance of Veeam elsewhere in my network.

When a New job runs the local repository job works fine. The SOBR then kicks in and fails with the following :

Server failed to authenticate the request. Make sure the value of Authorization header is formed correctly including the signature.

Further it advises to make sure the MAC signature is the same.


I have added the local repository, the Cloud storage account authenticates and i pick out my Blob Container and then the subfolder.
Tried creating a new Storage Account on Azure - no fancy immutable stuff plain simple cold storage.

Always the same when the SOBR job runs it fails within a second about this MAC signature error.

Anyone else ever seen that please? I even uninstalled and started again same result. I have been using Veeam Ent for years and have built about 10 backup servers over that time (all virtaul it has to be said) but have never had this Scale Out issue with Azure before. The new server OS is 2022 again I have a virtual one talking to the same Azure storage account and its fine. I cant find much out there about this MAC header error other than in Dev forums for folks writing apps that use Azure Blob as there backend and they needed to adjust their code to talk to the Blob but ...nada as far as I can see on Veeam and this issue easily coming to light.

many thanks and open to ideas!!

Mildur
Veeam Software
Posts: 4862
Liked: 1459 times
Joined: May 13, 2017 4:51 pm
Full Name: Fabian K.
Location: Switzerland
Contact:

Re: AZURE SOBR - new machine weird Authentication error

Post by Mildur »

Hi Robert

Can you please post the case number as requested when posting a technical issue?
If you are feeling that the case is struggling, please use the option to escalate the case.
https://www.veeam.com/kb2320

Thanks.
Fabian
Product Management Analyst @ Veeam Software

macbobs
Novice
Posts: 4
Liked: never
Joined: Feb 01, 2021 8:46 am
Full Name: Robert Crichton
Contact:

Re: AZURE SOBR - new machine weird Authentication error

Post by macbobs »

Thanks have updated that (ref 05530585 ) and apologies I didnt read the posting rules but not trying to circumvent the Support folks good works.

Mildur
Veeam Software
Posts: 4862
Liked: 1459 times
Joined: May 13, 2017 4:51 pm
Full Name: Fabian K.
Location: Switzerland
Contact:

Re: AZURE SOBR - new machine weird Authentication error

Post by Mildur » 1 person likes this post

Thank you very much.

I checked our support system and cannot find similar issues.
So I recommend to keep working with our support engineer. I don't believe this is fixable over a forum post.
Also I cannot find similar posts in the forum. Let's see if someone else has the same issues in his environment.

Please use the "Talk to a Manager"-Button in case you need to escalate to a higher tier if offload still isn't working.

Thanks
Fabian
Product Management Analyst @ Veeam Software

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests