Using object storage as a backup target
Post Reply
djmc
Influencer
Posts: 16
Liked: 3 times
Joined: Jul 02, 2013 12:40 am
Full Name: Declan McCann
Contact:

Failed to establish Microsoft Azure Storage connection

Post by djmc »

Hi,
I am trying to create a repo in Azure to use as the capacity tier for a new SOBR.
I have the Azure Storage account and container already setup.
I am using Veeam v10.

In the New Object Storage Repository window, under Account; when I select my Azure credentials I get the above error saying that "The TLS version of the connection is not permitted on this storage account."

Apparently Azure Storage support TLS version 1.0, 1.1 and 1.2.

Has anyone had this issue or any ideas on how to resolve it.

Thanks
D

Mildur
Veeam Legend
Posts: 1486
Liked: 613 times
Joined: May 13, 2017 4:51 pm
Full Name: Fabian Kessler
Location: St. Gallen, Switzerland
Contact:

Re: Failed to establish Microsoft Azure Storage connection

Post by Mildur »

There are some solutions I find with google.
https://pariswells.com/blog/research/ve ... was-closed

Please open a support case for your problem as requested when opening a forum topic here. This is not a support forum and i think you have paid support contract if you can use object storage :)
If it‘s a bug, veeam should become aware of that.
VMCE 9 | Veeam Legends 2021
Working with Veeam since 2017 for a VCSP in Switzerland

veremin
Product Manager
Posts: 18775
Liked: 1889 times
Joined: Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin
Contact:

Re: Failed to establish Microsoft Azure Storage connection

Post by veremin »

Can you also check what TLS version is set in the storage account settings? If it's been changed manually, can you apply the default value (Version 1.0) and see whether it makes any difference? Thanks!

djmc
Influencer
Posts: 16
Liked: 3 times
Joined: Jul 02, 2013 12:40 am
Full Name: Declan McCann
Contact:

Re: Failed to establish Microsoft Azure Storage connection

Post by djmc » 1 person likes this post

Hi Guys,
Thanks for the replies, it turned out to be the TLS version which was set at the Azure end. I set the TLS version to 1.2 in the storage account and it worked ok.

Thanks again,
D

veremin
Product Manager
Posts: 18775
Liked: 1889 times
Joined: Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin
Contact:

Re: Failed to establish Microsoft Azure Storage connection

Post by veremin »

Good to know that our assumption has been correct. Thanks for coming back and confirming it - much appreacited!

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 2 guests