Discussions specific to managed agent-based backups
Post Reply
pls
Influencer
Posts: 12
Liked: 5 times
Joined: May 17, 2019 5:44 pm
Full Name: Phil Shields
Contact:

Oracle: Sequence contains no matching element

Post by pls » Jun 07, 2019 4:12 pm

We are new to Veeam and have an Oracle database on a Linux physical server. To test Veeam with Oracle we have a test physical server running CentOS 7 with Oracle 11.0.2 and the orcl database. We have a backup job that is application aware and is set up to backup log files every 15 minutes. The daily backup runs fine.

The backup of the log files always finishes with the message "Error occurred while performing Oracle redo log backup Details: Sequence contains no matching element". When the secondary backup job runs every 15 minutes should the redo logs be archived? If so that is not occurring. The daily backup job creates an archive log file.

Any suggestions on what might need to be changed with the database or what is going on?

Case # is 03570533.

Thanks

Dima P.
Product Manager
Posts: 10536
Liked: 858 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: Oracle: Sequence contains no matching element

Post by Dima P. » Jun 07, 2019 6:45 pm

Hello Phil,

Can you please clarify what oracle processing settings are you using? What type of account is set for oracle processing (system/oracle account)? Can you confirm that this account has SYSDBA privileges? Thank you!

pls
Influencer
Posts: 12
Liked: 5 times
Joined: May 17, 2019 5:44 pm
Full Name: Phil Shields
Contact:

Re: Oracle: Sequence contains no matching element

Post by pls » Jun 07, 2019 7:48 pm

backup is entire computer
enable application aware processing
On the general tab - Try application processing but ignore failures
Oracle account with sysdba privileges - I am using sys, I have confirmed this acct has sysdba
delete logs older than 24 hours
Backup log files every 15 minutes
There are no scripts
Thanks

Dima P.
Product Manager
Posts: 10536
Liked: 858 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: Oracle: Sequence contains no matching element

Post by Dima P. » Jun 10, 2019 3:58 pm

Phil,

Thank for you the details, the setup looks good. Please keep working with our support team and let us know how it goes. Cheers!

pls
Influencer
Posts: 12
Liked: 5 times
Joined: May 17, 2019 5:44 pm
Full Name: Phil Shields
Contact:

Re: Oracle: Sequence contains no matching element

Post by pls » Jun 11, 2019 8:21 pm 1 person likes this post

We have resolved this issue with help from support. We have discovered that the Linux user we are using for the backup must be in the oinstall group. This is true even though we have that user set up to Elevate account privileges automatically. We also had to run an active full backup for the changes to take affect.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests