Discussions specific to managed agent-based backups
Post Reply
controlfreak
Enthusiast
Posts: 46
Liked: 5 times
Joined: Jan 12, 2018 11:20 pm
Full Name: Control
Location: Washington, USA
Contact:

Veeam deployment service not updating

Post by controlfreak » Apr 16, 2019 11:35 pm

We have agents running 3.0.1 that are managed by a Veeam backup and replication server. We have upgraded at each rev, from initial deployment on 9.5 U3, through 9.5 U4a. Each time we upgrade the Veeam server, we manually push out the agent updates (not automatic due to change control), but the Veeam installer/deployment service does not update. This will lead to baseline configuration deviation as new baseline members will have a new version of the installer service.

We have found that the installer service correlates to the Veeam server version at the time of the agent deployment.

My protection group is configured as:

-Install backup agent automatically
-do not auto-update backup agent (due to change control)
-do not install changed block tacking driver Windows Server OS
-do not perform reboot automatically if required (operational environment, must reboot during maintenance windows)

My process for updating agents in the protection group has been: select an agent in the protection group to upgrade > right click > agent > upgrade agent.

Case # 03517171

Thanks,

Control

HannesK
Veeam Software
Posts: 3991
Liked: 487 times
Joined: Sep 01, 2014 11:46 am
Location: Austria
Contact:

Re: Veeam deployment service not updating

Post by HannesK » Apr 17, 2019 6:11 am

Hello,
sorry for the inconvenience... it's an issue that the version text stays old. The files are updated.

Best regards,
Hannes

controlfreak
Enthusiast
Posts: 46
Liked: 5 times
Joined: Jan 12, 2018 11:20 pm
Full Name: Control
Location: Washington, USA
Contact:

Re: Veeam deployment service not updating

Post by controlfreak » Apr 17, 2019 4:01 pm

Hello Hannes,

It looks to me like the DLL is updating, but the exe is not.

On a newly deployed system:
c:\windows\veeam\backup\veeamdeploymentsvc.exe
  • Product version - 9.5.4.2753
  • Size - 1.19MB
  • md5 hash - f42219c6e0176335c768007fe1835248
On an existing agent system that was upgraded:
c:\windows\veeam\backup\veeamdeploymentsvc.exe
  • Product version - 9.5.4.2615
  • Size - 1.18MB
  • md5 hash - 8d5de3ec20597c9a4eceea67f59d3964

Thanks,

-Control

controlfreak
Enthusiast
Posts: 46
Liked: 5 times
Joined: Jan 12, 2018 11:20 pm
Full Name: Control
Location: Washington, USA
Contact:

Re: Veeam deployment service not updating

Post by controlfreak » Apr 18, 2019 12:10 am

I tested an uninstall and reinstall from the backup console, and this process updated the deployment service exe on the agent machine.

Can we submit this as a bug?

Thanks,

Control

HannesK
Veeam Software
Posts: 3991
Liked: 487 times
Joined: Sep 01, 2014 11:46 am
Location: Austria
Contact:

Re: Veeam deployment service not updating

Post by HannesK » Apr 18, 2019 5:30 am

Hello,
yes, DLL gets updated, exe not is a known issue (but you are right, I did not go into detail...).

Best regards,
Hannes

controlfreak
Enthusiast
Posts: 46
Liked: 5 times
Joined: Jan 12, 2018 11:20 pm
Full Name: Control
Location: Washington, USA
Contact:

Re: Veeam deployment service not updating

Post by controlfreak » Apr 18, 2019 3:18 pm

Thank you for confirming that this is known behavior. We will go the route of uninstall/reinstall to keep our baseline members in sync. Do you expect that this will be resolved in a future release?

HannesK
Veeam Software
Posts: 3991
Liked: 487 times
Joined: Sep 01, 2014 11:46 am
Location: Austria
Contact:

Re: Veeam deployment service not updating

Post by HannesK » Apr 18, 2019 3:21 pm

sorry, I cannot promise that... it's and older issue which exists since quite some time also for non-agent deployments (repository, proxy etc. servers) ...

controlfreak
Enthusiast
Posts: 46
Liked: 5 times
Joined: Jan 12, 2018 11:20 pm
Full Name: Control
Location: Washington, USA
Contact:

Re: Veeam deployment service not updating

Post by controlfreak » Apr 18, 2019 3:29 pm

Thanks for the information.

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests