Rollback during VeeamReporter Free installation

Management reporting and documentation

Rollback during VeeamReporter Free installation

Veeam Logoby schedlbauerm » Wed Aug 18, 2010 7:41 am

Hi !

I tried to install the free edition of VeeamReporter today. The installation is nearly finished when a rollback is started and the unfinished installation gets removed.

It seems that the problem occurs when the application pool on the IIS gets created. The Install messages on the screen disappear very quickly, so I'm not 100%sure.

Where can I found the installation log ?

Thanks Martin
schedlbauerm
Enthusiast
 
Posts: 35
Liked: never
Joined: Thu Jun 25, 2009 6:55 pm
Full Name: Martin Schedlbauer

Re: Rollback during VeeamReporter Free installation

Veeam Logoby Vitaliy S. » Wed Aug 18, 2010 8:22 am

Hi Martin,

Please check %TEMP% folder for the setup log file, this should shed some light on the issue. Additionally, please make sure you meet all system requirements for Veeam Reporter 4.

Thanks!
Vitaliy S.
Veeam Software
 
Posts: 19558
Liked: 1102 times
Joined: Mon Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov

Re: Rollback during VeeamReporter Free installation

Veeam Logoby schedlbauerm » Wed Aug 18, 2010 8:36 am

Hi Vitaliy,

here is the important section of the logfile:



InstallShield 09:36:05: AppHostElement objects detected. Unsupported property.
InstallShield 09:36:05: SetCommonProperties for the following: VeeamReporter
InstallShield 09:36:05: SetVRtDWProperty for property '6016' with value '513'.
InstallShield 09:36:05: GetAdminSection for section 'system.webServer/handlers' and path 'MACHINE/WEBROOT/APPHOST/VeeamReporter' and commitpath 'MACHINE/WEBROOT/APPHOST/VeeamReporter'.
InstallShield 09:36:05: GetAdminSection returned: -2147024894. The system cannot find the file specified.
InstallShield 09:36:05: GetAdminSection for section 'system.webServer/handlers' and path 'MACHINE/WEBROOT/APPHOST/VeeamReporter' and commitpath 'MACHINE/WEBROOT/APPHOST'.
InstallShield 09:36:05: GetAdminSection returned: -2147024894. The system cannot find the file specified.
InstallShield 09:36:05: Error: already using the main configuration file.

InstallShield 09:36:05: PutPropertyValue: sProperty accessPolicy sValue Script, Read bIsPath 0
InstallShield 09:36:05: PutPropertyCommon: sProperty accessPolicy sValue Script, Read bIsPath 0
InstallShield 09:36:05: Element is NULL while looking for the following property: accessPolicy
InstallShield 09:36:05: PutPropertyCommon: no property returned for accessPolicy, don't try to set it now
InstallShield 09:36:05: CommitChanges for path 'MACHINE/WEBROOT/APPHOST' and physical path 'C:\Windows\system32\inetsrv\config\'.
InstallShield 09:36:05: Changing CommitPath from 'MACHINE/WEBROOT/APPHOST' to the following: MACHINE/WEBROOT/APPHOST/VeeamReporter
InstallShield 09:36:05: SetVRtDWProperty for property '6005' with value '1073741824'.
InstallShield 09:36:05: GetAdminSection for section 'system.webServer/directoryBrowse' and path 'MACHINE/WEBROOT/APPHOST/VeeamReporter' and commitpath 'MACHINE/WEBROOT/APPHOST/VeeamReporter'.
InstallShield 09:36:05: GetAdminSection returned: -2147024894. The system cannot find the file specified.
InstallShield 09:36:05: GetAdminSection for section 'system.webServer/directoryBrowse' and path 'MACHINE/WEBROOT/APPHOST/VeeamReporter' and commitpath 'MACHINE/WEBROOT/APPHOST'.
InstallShield 09:36:05: GetAdminSection returned: -2147024894. The system cannot find the file specified.
InstallShield 09:36:05: Error: already using the main configuration file.
InstallShield 09:36:05: Element 'system.webServer/directoryBrowse' not found.
InstallShield 09:36:05: Error with IISRT: -2116

CustomAction caCreateVRoots returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
Action ended 09:36:05: InstallFinalize. Return value 3.


Immediatly after that the rollback begins.

Does this error look familiar to you ?

Kind regards,

Martin
schedlbauerm
Enthusiast
 
Posts: 35
Liked: never
Joined: Thu Jun 25, 2009 6:55 pm
Full Name: Martin Schedlbauer

Re: Rollback during VeeamReporter Free installation

Veeam Logoby Alexey D. » Wed Aug 18, 2010 9:48 am

Hello Martin,

I would suggest installing Reporter on a clean OS with no previous or concurrent copies. Also, do you have any applications running on IIS by any chance? (IIS settings might have been changed by them)
Alexey D.
 

Re: Rollback during VeeamReporter Free installation

Veeam Logoby schedlbauerm » Wed Aug 18, 2010 10:05 am

Hello Alexey,

there are no previous or concurrent copies of VeeamReporter on this OS.

I have one third party application using IIS on this server. So it is possible that some IIS settings might have been changed.

I would prefer to get Veeam Reporter running on this OS.
schedlbauerm
Enthusiast
 
Posts: 35
Liked: never
Joined: Thu Jun 25, 2009 6:55 pm
Full Name: Martin Schedlbauer

Re: Rollback during VeeamReporter Free installation

Veeam Logoby Vitaliy S. » Wed Aug 18, 2010 11:56 am

Martin,

Could you please tell me what OS are you using to install Veeam Reporter 4? If you want to keep Reporter 4 on this particular VM, as a workaround I would recommend to install it on another VM and after that create Veeam Reporter website manually with similar settings on the VM experiencing the issue.

If you are using licensed version, please feel free to contact our support, and they will assist you to make this work in your environment on the desired server.

Thank you.
Vitaliy S.
Veeam Software
 
Posts: 19558
Liked: 1102 times
Joined: Mon Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov


Return to Reporting



Who is online

Users browsing this forum: No registered users and 2 guests