RESTful knowledge exchange
Post Reply
clh_jl
Service Provider
Posts: 14
Liked: 2 times
Joined: Sep 22, 2014 12:49 pm
Contact:

Deleting a Cloud Tenant

Post by clh_jl » Apr 01, 2015 12:49 pm

1. The documentation (http://helpcenter.veeam.com/backup/80/rest/index.html) says there should be a response of 204 No Content, however I am getting 202:

< HTTP/1.1 202 ACCEPTED
< Content-Length: 0
< Server: Microsoft-HTTPAPI/2.0
< Date: Wed, 01 Apr 2015 12:29:08 GMT

2. Are there any plans for a task ID to be returned similar to the tenant creation task, as currently we can't monitor the progress of the deletion task?

3. Finally, I noticed that on occasion the removal task fails (hence question 2. above) with something similar to the below - is this a known issue?

Task [task-25] finished. Operation: "DeleteCloudTenant", Task result: [Fail], Message: "Failed to invoke method 'RemoveCloudTenant'" (ConfirmationNeeded: [False], CredentialsNeeded: [False])

Thanks!

veremin
Product Manager
Posts: 16691
Liked: 1393 times
Joined: Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin
Contact:

Re: Deleting a Cloud Tenant

Post by veremin » Apr 01, 2015 4:48 pm

Tenant deletion request should return 204 as a response code, which also should contain a task ID. The current behaviour is tracked as a bug and should be fixed in the future.

As to the issue 3, I personally haven't seen similar problem before, so, you might want to open a ticket, if the issue persists.

Thanks.

clh_jl
Service Provider
Posts: 14
Liked: 2 times
Joined: Sep 22, 2014 12:49 pm
Contact:

Re: Deleting a Cloud Tenant

Post by clh_jl » Apr 06, 2015 9:49 am

Thanks for the information, is the bugfix likely to make it into the next release?

After more testing it seems that the deletion problem only occured with one specific tenant for some reason - haven't seen it since they were removed.

veremin
Product Manager
Posts: 16691
Liked: 1393 times
Joined: Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin
Contact:

Re: Deleting a Cloud Tenant

Post by veremin » Apr 08, 2015 3:20 pm

Most likely, it will be fixed after Update 2. Thanks.

hogendoorn
Lurker
Posts: 2
Liked: never
Joined: Aug 12, 2015 11:18 am
Full Name: Michael Hogendoorn

Re: Deleting a Cloud Tenant

Post by hogendoorn » Aug 12, 2015 11:38 am

Quick question.

I am currently running version V8 update 2b. and i still get this error. Is it correct?

hogendoorn
Lurker
Posts: 2
Liked: never
Joined: Aug 12, 2015 11:18 am
Full Name: Michael Hogendoorn

Re: Deleting a Cloud Tenant

Post by hogendoorn » Aug 12, 2015 8:04 pm

From question 1 i forgot to mension

veremin
Product Manager
Posts: 16691
Liked: 1393 times
Joined: Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin
Contact:

Re: Deleting a Cloud Tenant

Post by veremin » Aug 13, 2015 10:42 am

As I've mentioned in my last reply, the fix was planned to be provided in update 2.

However, the said behaviour is fixed in version 9 (I've just confirmed that).

Thanks.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest