RESTful knowledge exchange
Post Reply
raphael@schitz.net
Enthusiast
Posts: 71
Liked: 2 times
Joined: Jul 25, 2009 12:14 am
Contact:

Veeam.RestApiService is not listening on port 9419

Post by raphael@schitz.net »

Hi, according to https://community.veeam.com/blogs-and-p ... or-vbr-415 and https://helpcenter.veeam.com/docs/backu ... ml?ver=110 we should now be able to connect to a backup server api service on port 9419 but nothing is listening on our recently upgraded from 10 to 11 server.
I checked the registry key HKEY_LOCAL_MACHINE\SOFTWARE\Veeam\Veeam Backup and Replication\API\RestApiPort to doublecheck the port and its 9419 as expected.
With ProcExplorer i can see sometimes communication on port 9392 but there is no swagger on that port.

Image

What am i missing?
Thanks

Support ID=02189099

veremin
Product Manager
Posts: 18421
Liked: 1822 times
Joined: Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin
Contact:

Re: Veeam.RestApiService is not listening on port 9419

Post by veremin »

The mentioned key seems to be related to Enterprise Manager REST API, not Backup & Replication REST API. So, having it set does not make any difference.

Can you open Swagger UI by navigating to the following page in a web-browser:

Code: Select all

https://<backupserverhostname>:<9419>/swagger/ui/index.html
Thanks!

raphael@schitz.net
Enthusiast
Posts: 71
Liked: 2 times
Joined: Jul 25, 2009 12:14 am
Contact:

Re: Veeam.RestApiService is not listening on port 9419

Post by raphael@schitz.net »

Hi, nothing on that port, i even try to telnet to it locally or remotely to be sure. I also tried 127.0.0.1 locally as well just in case

veremin
Product Manager
Posts: 18421
Liked: 1822 times
Joined: Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin
Contact:

Re: Veeam.RestApiService is not listening on port 9419

Post by veremin »

And if open a backup server -> click menu -> console -> swagger ui, it will also show nothing?

raphael@schitz.net
Enthusiast
Posts: 71
Liked: 2 times
Joined: Jul 25, 2009 12:14 am
Contact:

Re: Veeam.RestApiService is not listening on port 9419

Post by raphael@schitz.net »

Image

I'm on Enterprise Edition

veremin
Product Manager
Posts: 18421
Liked: 1822 times
Joined: Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin
Contact:

Re: Veeam.RestApiService is not listening on port 9419

Post by veremin »

Ah, this explains the issue - REST API is available only in Enterprise Plus edition (or VUL licenses). Thanks!

raphael@schitz.net
Enthusiast
Posts: 71
Liked: 2 times
Joined: Jul 25, 2009 12:14 am
Contact:

Re: Veeam.RestApiService is not listening on port 9419

Post by raphael@schitz.net »

Ok thanks Vladimir.
I understand to marketing strategy for this but it could have been read-only for monitoring and reporting purpose instead of just non accessible.
Is it something we could request for the future?

oleg.feoktistov
Veeam Software
Posts: 904
Liked: 319 times
Joined: Sep 25, 2019 10:32 am
Full Name: Oleg Feoktistov
Contact:

Re: Veeam.RestApiService is not listening on port 9419

Post by oleg.feoktistov » 1 person likes this post

Hi,

You can just contact our sales team and convert your enterprise edition to a fully-featured Veeam Universal License.

Thanks,
Oleg

veremin
Product Manager
Posts: 18421
Liked: 1822 times
Joined: Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin
Contact:

Re: Veeam.RestApiService is not listening on port 9419

Post by veremin » 1 person likes this post

Is it something we could request for the future?
As Oleg's mentioned, these days you can only buy Veeam in a single, fully featured edition - Veeam Universal License. You can keep using the existing license, but we are not planning any feature scope changes for product editions, because we no longer have different product editions available for sale in principle.

Thanks!

raphael@schitz.net
Enthusiast
Posts: 71
Liked: 2 times
Joined: Jul 25, 2009 12:14 am
Contact:

Re: Veeam.RestApiService is not listening on port 9419

Post by raphael@schitz.net »

OK i get, i'll move to VUL then. Thanks a lot for your explanations.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests