Agent-based backups for Windows and Linux, centralized agent management
Post Reply
pls
Influencer
Posts: 20
Liked: 6 times
Joined: May 17, 2019 5:44 pm
Full Name: Phil Shields
Contact:

After upgrade Oracle Restore does not work

Post by pls »

Case #04451995

We recently upgraded from 9.5b to 10a. BUR manages our agents. We have Oracle on a Linux physical server.

I have a test Oracle DB also running on a physical server. To create a test db I do an application restore to the test server. All worked fine in 9.5b. After upgrading to 10a the exact same restore will not work because in the restore wizard it never gets past the validating stage.

Is anyone else doing application restores of an Oracle database in v10a? Are you having any issues?

HannesK
Veeam Software
Posts: 6794
Liked: 1051 times
Joined: Sep 01, 2014 11:46 am
Location: Austria
Contact:

Re: After upgrade Oracle Restore does not work

Post by HannesK »

Hello,
I just read through the case and it looks not like any "well known issue". So I can only recommend to continue working with support.

As you uploaded all logfiles now, they should find something. You can also use the "talk to manager" button in the support portal to escalate the case, if they do not find anything in the logfiles (escalating without logfiles makes no sense)

Best regards,
Hannes

pls
Influencer
Posts: 20
Liked: 6 times
Joined: May 17, 2019 5:44 pm
Full Name: Phil Shields
Contact:

Re: After upgrade Oracle Restore does not work

Post by pls »

I did not want to complicate the original post with this info but here goes. We started on v9.5 and we were having random restore failures. It also took about an hour from starting the restore wizard until the restore actually started because of taking a long time to validate at each step, but I did not know that was not expected behavior. I opened a case and I was asked to update to v9.5b. The upgrade resolved the random restore failures and the extended validation was also resolved. What took at least an hour was now about 5 minutes. If I remember correctly the log files from a restore using v9.5 look a lot like they do now with v10. For example it takes over 3.5 minutes to Enumerating Oracle homes. In v9.5b it takes 15 seconds.

pls
Influencer
Posts: 20
Liked: 6 times
Joined: May 17, 2019 5:44 pm
Full Name: Phil Shields
Contact:

Re: After upgrade Oracle Restore does not work

Post by pls » 1 person likes this post

The Veeam support engineer noticed that the time on our backup server was off by 4 hours. Turns out server was not syncing with ntp server. When we fixed that and the restore went through the validation steps as expected.

HannesK
Veeam Software
Posts: 6794
Liked: 1051 times
Joined: Sep 01, 2014 11:46 am
Location: Austria
Contact:

Re: After upgrade Oracle Restore does not work

Post by HannesK »

nice one - thanks for posting the solution đź‘Ť

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest