Agent-based backup of Windows, Linux, Max, AIX and Solaris machines.
Post Reply
ENAC
Lurker
Posts: 2
Liked: never
Joined: Feb 22, 2021 2:39 pm
Contact:

Backing up an entire computer with an exclusion

Post by ENAC »

Hi , I'd like to back up a PHYSICAL server (Redhat) with Veeam B&R 10 with the entire backup mode ( to be able to restore this machine after a crash in a very fast way),but without the data of a particular mount point ( cache files of my proxy).

Is it possible or do i have to use the volume level backup mode without the cache mount point and manipulate my boot to make my server starting ( otherwise my server don't boot because of the missing mount point ) ?

Thanks
PTide
Product Manager
Posts: 6431
Liked: 729 times
Joined: May 19, 2015 1:46 pm
Contact:

Re: Backing up an entire computer with an exclusion

Post by PTide »

Hi,

Please explain a little bit more about the mountpoint.
What's the filesystem of that mountpoint, and why does your server refuse to start without it if the mountpoint is not essential?

Thanks!
ENAC
Lurker
Posts: 2
Liked: never
Joined: Feb 22, 2021 2:39 pm
Contact:

Re: Backing up an entire computer with an exclusion

Post by ENAC »

The filesystem is ext 4 , even when I try to backup with no exclusion but by choosing all my mount points , my server doesn't start : kernel panic.
I should be able to start the server with a "volume level backup" or I'm wrong ?
PTide
Product Manager
Posts: 6431
Liked: 729 times
Joined: May 19, 2015 1:46 pm
Contact:

Re: Backing up an entire computer with an exclusion

Post by PTide »

Please do the following:

1. Open /etc/veeam.ini file and find [backup] section

2. Find "ignoreDevices" parameter (if it's not there then add it manually)

3. Specify the device that you would like to skip

4. Run an "Entire machine" backup

(check this KB article for details)

After that try to perfrom bare-metal restore again.

Please also post the output of lsblk -af

Thanks!
merku
Enthusiast
Posts: 47
Liked: 11 times
Joined: Feb 08, 2020 3:17 pm
Full Name: Mercurio
Contact:

Re: Backing up an entire computer with an exclusion

Post by merku »

Hi,
I have some backups with Veeam on SUSE and I always get a warning like this:

Code: Select all

1:28:09 AM Cannot find EFI boot manager entry for EFI System Partition GUID [{5ed37c05-fda7-4a6f-9001-4dfd18377366}].
I would like to exclude the warning and ignore it, is it possible to do this using the ignoreDevices option? If so how?
My lsblk -af is:

Code: Select all

NAME FSTYPE FSVER LABEL UUID FSAVAIL FSUSE% MOUNTPOINT
sda
└─sda1 LVM2_member LVM2 001 0VCHQL-z2fs-giXW-PVqu-4lwC-1mM9-t0Wo8F
   ├─VG_HANA-lv_data_BJP xfs 4e9634ba-8745-4f24-959a-40c564f10c21 237.9G 7% /hana/data/BJP
   ├─VG_HANA-lv_data_BWP xfs b82fcc35-8087-47a4-a862-81deae066ef0 523G 49% /hana/data/BWP
   ├─VG_HANA-lv_data_ECD xfs 97abfbd8-fb41-454d-9b08-70c0bd7409f9 325.1G 68% /hana/data/ECD
   ├─VG_HANA-lv_data_ECP xfs ee21480f-a01c-4111-9608-c91a72da3d53 471.6G 54% /hana/data/ECP
   ├─VG_HANA-lv_data_S4P xfs e2978cb9-a093-45fa-88a8-41013e2b546b 563.3G 45% /hana/data/S4P
   ├─VG_HANA-lv_log_BJP xfs 2d2ea9c0-9c08-4c21-bad1-1c1eb6f6ef06 248.9G 3% /hana/log/BJP
   ├─VG_HANA-lv_log_BWP xfs 150e4fa8-789c-4975-9b52-ff97dc5a1064 486.2G 5% /hana/log/BWP
   ├─VG_HANA-lv_log_ECD xfs 1ea2b05a-b57e-4590-956c-564dfd1703eb 250.2G 2% /hana/log/ECD
   ├─VG_HANA-lv_log_ECP xfs 31534c9b-d6f9-4956-b364-332c90509917 485.2G 5% /hana/log/ECP
   ├─VG_HANA-lv_log_S4P xfs 435eaa13-5184-478a-98a6-fb05264eddd0 255.6G 0% /hana/log/S4P
   ├─VG_HANA-lv_shared_BJP xfs 75d344d1-2651-4435-908d-def0c8eb1998 109.4G 14% /hana/shared/BJP
   ├─VG_HANA-lv_shared_BWP xfs 70cdb434-2099-4da9-a29e-2db052bdb2d6 245G 4% /hana/shared/BWP
   ├─VG_HANA-lv_shared_ECD xfs d6126e97-3086-4278-987d-48c1c52b5692 114.5G 11% /hana/shared/ECD
   ├─VG_HANA-lv_shared_ECP xfs b07f0901-47cb-49aa-80b9-8221ed50085f 244.9G 4% /hana/shared/ECP
   ├─VG_HANA-lv_shared_S4P xfs ed8cf1a9-195b-483f-b3bc-b9104af6a5f5 255.6G 0% /hana/shared/S4P
   ├─VG_HANA-lv_software xfs 587e8f7a-cc74-4fa7-b31c-ae10c82b4302 490.8G 2% /software
   └─VG_HANA-lvSBD
sdb
├─sdb1 vfat FAT32 3A46-D9D5 506.2M 1% /boot/efi
├─sdb2 ext2 1.0 8cc6ba3d-a30b-4897-baf3-7b1adfad3dea 46.6G 0% /boot
├─sdb3 swap 1 87829e65-fde7-408b-992c-6f6cf21033c1 [SWAP]
├─sdb4 xfs ec4fd758-6f3e-49e3-ba14-80ed97fa4f21 145.9G 3% /
├─sdb5 xfs 694afc94-178c-4ef8-8ecc-5ec4cfcfde78 149.5G 0% /usr/sap
└─sdb6 LVM2_member LVM2 001 5pLLXV-TiUM-wE83-5KkG-2AHt-F4cI-forR0A
pmem1 xfs 0999533c-d17f-47e5-bb6a-88f679d11890 754.8G 0% /hana/pmem/pmem1
pmem2 xfs 7bebd123-ac4c-4ad1-9ff2-1a5091b7b133 754.8G 0% /hana/pmem/pmem2
pmem3 xfs 7f9a3dca-d947-4836-b0b7-fa3c25e559a7 754.8G 0% /hana/pmem/pmem3
pmem0 xfs 2e7b81b0-f188-4485-81be-2eab34c02527 754.8G 0% /hana/pmem/pmem0
Thanks
PTide
Product Manager
Posts: 6431
Liked: 729 times
Joined: May 19, 2015 1:46 pm
Contact:

Re: Backing up an entire computer with an exclusion

Post by PTide »

Hi,

Have you tried following these instructions? Try them with /boot/efi.

Thanks!
merku
Enthusiast
Posts: 47
Liked: 11 times
Joined: Feb 08, 2020 3:17 pm
Full Name: Mercurio
Contact:

Re: Backing up an entire computer with an exclusion

Post by merku »

Hi,
yes I've try but warning message is still here!
If instead I exclude /dev/sdb1 then the warning disappears.

Should be the same as I see that /boot/efi is the mountpoint of the /dev/sdb1 filesystem.

system:/var/log/veeam # df -k | grep -i boot
/dev/sdb2 51553100 101656 48830004 1% /boot
/dev/sdb1 523248 4936 518312 1% /boot/efi

Correct?

Thanks!
PTide
Product Manager
Posts: 6431
Liked: 729 times
Joined: May 19, 2015 1:46 pm
Contact:

Re: Backing up an entire computer with an exclusion

Post by PTide » 1 person likes this post

My bad, I meant the corresponding block device of /boot/efi. Yes, you are right - if /boot/efi is a mountpoint for /dev/sdb1, then exclude sdb1.

Thank you!
Post Reply

Who is online

Users browsing this forum: No registered users and 21 guests