Agent-based backups for Windows and Linux, centralized agent management
Post Reply
spug100
Influencer
Posts: 10
Liked: 1 time
Joined: Jul 08, 2020 3:39 pm
Full Name: spug
Contact:

brand new install, VM backups work fine, ALL physical backups fail with timeout

Post by spug100 »

case no: 04302452

Hi. brand new install of B&R v10 on a dedicated physical 2016 Server. Install went fine. I have two physical servers I want to back up: a 2016 HyperV server with 3 VMs, and a SBS 2011 physical server. the 3 VMs backup fine, but both physical servers repeatedly fail after timeout. no other errors. both physical servers added fine, and are shown as online and installed within the “physical infrastructure”. I have trawled through all the logs and have found nothing of interest apart from:

“Checking remote agent is alive...” every few minutes

I am also getting a “IVssWriterCallback interface. hr = 0x80070005, Access is denied” On both target servers when the backup starts, but I have read up about this error and it says that this should not stop the backup job from running. I have also tried to run the vss service as the same domain administrator that has been specified from within the b&r server.

As mentioned, if I rescan the problem servers, they are still listed as "online and installed". I have disabled the firewall on both the backup server and the target server to no avail. I have also configured a backup which is very simple and does no application aware processing. Both servers can resolve each other's FQDN. Both are local on the same network. I cannot think of anything else.......

submitted all logs with the support case, but logs showing NOTHING of note!

spug100
Influencer
Posts: 10
Liked: 1 time
Joined: Jul 08, 2020 3:39 pm
Full Name: spug
Contact:

Re: brand new install, VM backups work fine, ALL physical backups fail with timeout

Post by spug100 »

i've been mucking about with various configs. If I try and create a physical backup of the Hyper-V host using "managed by agent" mode, I get the following error when trying to apply the policy/configuration to the agent: (don't know whether this helps?)
Failed to update backup job configuration.Sending backup job configuration
Failed to send backup job configuration to "Job Name" Error: Failed to update backup job Managed by agent job ID: fc84c1ee-fd37-496a-9a6d-1527971f6afd. Managed by agent job name: "Job Name". Invalid job configuration. Connection problems. Exception has been thrown by the target of an invocation. No connection could be made because the target machine actively refused it 192.168.0.11:10005
log file says:
A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 192.168.0.237:10005 (Veeam.Backup.Common.CustomStackException)

spug100
Influencer
Posts: 10
Liked: 1 time
Joined: Jul 08, 2020 3:39 pm
Full Name: spug
Contact:

Re: brand new install, VM backups work fine, ALL physical backups fail with timeout

Post by spug100 » 1 person likes this post

meh. thanks all for answering my question. anyway, I think this had something to do with the 3rd party certificate that I was using (I thought it would be sensible to use the client's SSL cert). Anyway, I used the original Veeam self-signed cert, re-added the physicals servers and it all worked!

Dima P.
Product Manager
Posts: 11976
Liked: 1083 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: brand new install, VM backups work fine, ALL physical backups fail with timeout

Post by Dima P. »

Hello spug,

I am sorry for keeping silence, we've somehow missed your post: looks like the agent related topic accidentally landed under the Hyper-V subforum. I've also asked support management team to review the case details.

Glad to hear that you've resolved the original issue and you are up and running now! Cheers!

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests