Agent-based backups for Windows and Linux, centralized agent management
Post Reply
rv112
Lurker
Posts: 2
Liked: 1 time
Joined: Dec 29, 2019 4:56 pm
Full Name: Carsten
Contact:

"Reconnectable protocol device was closed"

Post by rv112 »

Hi!

Since today I get on both of my backup agents the error "Reconnectable protocol device was closed" when trying to do a backob job to my replication server. I did trying to restart anything but nothing helped.
Any ideas what causes this issue? I also tried disabling the firewall. My Windows Server is in same LAN as the workstation agents.

Thanks!

DGrinev
Expert
Posts: 1943
Liked: 247 times
Joined: Dec 01, 2016 3:49 pm
Full Name: Dmitry Grinev
Location: St.Petersburg
Contact:

Re: "Reconnectable protocol device was closed"

Post by DGrinev »

Hi Carsten and welcome to the community!

There are a bunch of reasons why the error can appear:
Here are the search results for review.
It's worth to contact the support team and let them take a closer look, do not forget to share the case ID in this thread.

Thanks!

rv112
Lurker
Posts: 2
Liked: 1 time
Joined: Dec 29, 2019 4:56 pm
Full Name: Carsten
Contact:

Re: "Reconnectable protocol device was closed"

Post by rv112 » 1 person likes this post

I fixed it my own, thanks! I had installed a new Virtual IP interface that seems to cause this problem. Only one ethernet adapter works again now.

cableguy
Novice
Posts: 4
Liked: 1 time
Joined: Oct 02, 2019 8:48 am
Full Name: Andreas Lietz
Contact:

Re: "Reconnectable protocol device was closed"

Post by cableguy » 1 person likes this post

Tipp: if you get this error, check that your backup job is using the correct backup proxy server.

I just got that same error with some backups and it turned out that we were accidentally using a backup proxy over a slow WAN link instead of the local one. Apparently the slow connection led to this error.

PetrM
Veeam Software
Posts: 1130
Liked: 176 times
Joined: Aug 28, 2013 8:23 am
Full Name: Petr Makarov
Location: Prague, Czech Republic
Contact:

Re: "Reconnectable protocol device was closed"

Post by PetrM »

Thanks for your feedback! However, the best way to resolve any error is to contact our support team and to provide us with a support case ID.
The error mentioned above can be triggered due to many different reasons, most of them are related to unstable connection between Source and Target Data Movers.

Thanks!

techie4hire
Lurker
Posts: 1
Liked: 1 time
Joined: Mar 21, 2021 8:50 pm
Full Name: Scott Ueland
Contact:

Re: "Reconnectable protocol device was closed"

Post by techie4hire » 1 person likes this post

rv112 wrote: Jan 02, 2020 5:00 pm I had installed a new Virtual IP interface that seems to cause this problem. Only one ethernet adapter works again now.
I can confirm this behavior. I recently updated Oracle VirtualBox to 6.1 on several of my laptops, After that, backups via the Windows version of the Veeam Agent would not complete to my Veeam Backup and Replication Server. Same results on both v10 and v11 versions of the above (community editions). "Reconnectable protocol device was closed" in the log, was always the result.

The solution was to disable the VirtualBox Host-Only Ethernet Adapter. This virtual adapter only needs to be enabled for VMs that are using it as a network adapter, otherwise it can be left disabled (which is done by right-clicking on this adapter under "Network Connections" and clicking "Disable").

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests