Agent-based backups for Windows and Linux, centralized agent management
Post Reply
MoranJ2000
Novice
Posts: 9
Liked: never
Joined: Jul 02, 2019 6:29 pm
Full Name: Joseph Moran
Contact:

User name or password incorrect when installing agent

Post by MoranJ2000 »

Hi.
Just installed a VBRCE server for the first time on a (Windows 10 Pro PC), and I created a job to have the server back itself up, but I’m having trouble getting the agent installed.

My attempts to scan the host and install the agent fail with the error “cannot connect to localhost…the user name or password is incorrect". But the credentials are correct-- I’m using a local admin account and have verified it can connect to the ADMIN$ share.

Any ideas what I’m missing here?

Thanks very much.

Joe

nielsengelen
Veeam Software
Posts: 3464
Liked: 690 times
Joined: Jul 15, 2013 11:09 am
Full Name: Niels Engelen
Contact:

Re: User name or password incorrect when installing agent

Post by nielsengelen »

Are you using the account as just "Administrator" or "PCNAME\Administrator" ?
https://foonet.be

MoranJ2000
Novice
Posts: 9
Liked: never
Joined: Jul 02, 2019 6:29 pm
Full Name: Joseph Moran
Contact:

Re: User name or password incorrect when installing agent

Post by MoranJ2000 »

Definitely the latter-- PCname\accountname (not the actual "administrator" account, but a confirmed local admin account).

Not sure if it matters, but this is a Windows 10 Pro PC that is member of an Azure AD domain (i.e. no local domain). I'd try using domain creds instead, but not sure how to even express them to Veeam's satisfaction. For example, when I run the console it logs in under my domain account, which is shown as AzureAD\FirstNameLastName, which I don't know what to make of because it obviously doesn't reference my AD tennant, plus FirstNameLastName is not my actual account name...

Dima P.
Product Manager
Posts: 11611
Liked: 1005 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: User name or password incorrect when installing agent

Post by Dima P. »

Hello Joseph,

Account should be specified in domainname\username format. Can you please clarify if the mentioned Veeam B&R machine is joined to the domain? Also I wonder what type of protection group you've used (individual computer or active directory)? Thank you!

MoranJ2000
Novice
Posts: 9
Liked: never
Joined: Jul 02, 2019 6:29 pm
Full Name: Joseph Moran
Contact:

Re: User name or password incorrect when installing agent

Post by MoranJ2000 »

Hi Dima.

I am specifying the account in the format \machinename\username since it's a local rather than a domain account. I am using individual computer, specifically the one where B&R is running. I have identified this computer both by (static) IP address and as localhost. Either way the error is the same.

MoranJ2000
Novice
Posts: 9
Liked: never
Joined: Jul 02, 2019 6:29 pm
Full Name: Joseph Moran
Contact:

Re: User name or password incorrect when installing agent

Post by MoranJ2000 »

I wanted to add that I'm using version 9.5 Update 4a, and also that when I go to Inventory|Physical and Cloud...\Manually added|Properties|Computers and select Test Now, the credentials test successfully. Yet, I can scan the host in order to install the agent and perform the backup.

I don't get it...

Dima P.
Product Manager
Posts: 11611
Liked: 1005 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: User name or password incorrect when installing agent

Post by Dima P. »

Joseph,

The setup looks fine. Can you check the hosts file, maybe you are using a different definition for local host? Any change this machine is on IPv6? Thanks!

MoranJ2000
Novice
Posts: 9
Liked: never
Joined: Jul 02, 2019 6:29 pm
Full Name: Joseph Moran
Contact:

Re: User name or password incorrect when installing agent

Post by MoranJ2000 »

I checked the hosts file and it's unedited (i.e. just the standard text, everything commented out).

Re: IPv6, my LAN isn't configured for that, but the PC has a link-local address ( think all Windows 10 PCs do by default?).

Dima P.
Product Manager
Posts: 11611
Liked: 1005 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: User name or password incorrect when installing agent

Post by Dima P. »

Joseph,

Unfortunately i am running our of ideas. Any chance you can raise a case with our support team? Cheers!

MoranJ2000
Novice
Posts: 9
Liked: never
Joined: Jul 02, 2019 6:29 pm
Full Name: Joseph Moran
Contact:

Re: User name or password incorrect when installing agent

Post by MoranJ2000 »

This is Community Edition so I don't know if they'll even respond, but I will try. Thanks.

Dima P.
Product Manager
Posts: 11611
Liked: 1005 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: User name or password incorrect when installing agent

Post by Dima P. »

We do provide best effort support for community edition, so that should work. Just do not forget to share the case ID once you have it. Cheers!

MoranJ2000
Novice
Posts: 9
Liked: never
Joined: Jul 02, 2019 6:29 pm
Full Name: Joseph Moran
Contact:

Re: User name or password incorrect when installing agent

Post by MoranJ2000 »

Case ID is 03862601

Dima P.
Product Manager
Posts: 11611
Liked: 1005 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: User name or password incorrect when installing agent

Post by Dima P. »

Joseph,

Perfect, thank you. Already asked support team to take a look. Cheers!

MPECSInc
Service Provider
Posts: 3
Liked: never
Joined: Jul 25, 2016 2:36 pm
Full Name: Philip Elder
Location: St. Albert, AB, Canada
Contact:

Re: User name or password incorrect when installing agent

Post by MPECSInc »

Please update with the fix.

Hitting this exact problem on Windows 10 Pro for Workstations.

Everything checks out but hit the user name and password error.

Dima P.
Product Manager
Posts: 11611
Liked: 1005 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: User name or password incorrect when installing agent

Post by Dima P. »

Hello MPECSInc,

If you faced the same issue, kindly, raise a support ticket and share the case ID with us. Thank you in advance!

mecki
Veeam ProPartner
Posts: 12
Liked: 1 time
Joined: Sep 08, 2015 3:48 am
Full Name: Martin Eckart-W.
Contact:

Re: User name or password incorrect when installing agent

Post by mecki »

The local accounts are disabled to access the admin shares ($shares) at default. Navigate to
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System.
Create a DWORD value called LocalAccountTokenFilterPolicy and assign it a value of 1
that do the trick.
Or use domain accounts...
Martin
VMCE, VMCT

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests