Discussions specific to tape backups
v.eremin
Product Manager
Posts: 16160
Liked: 1320 times
Joined: Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin
Contact:

Re: Remote tape library. Slow performance

Post by v.eremin » Jan 26, 2015 12:02 pm

I was talking about utility provided by your tape device manufacturer. Anyway, what type of repository you're using? And where is it located? Thanks.

tochi
Influencer
Posts: 14
Liked: never
Joined: Jan 26, 2015 10:05 am
Full Name: Renen Quinto
Contact:

Re: Remote tape library. Slow performance

Post by tochi » Jan 27, 2015 12:23 am

Sorry, but we don't have any utility for that... its a Dell PowerVault LTO4 standalone drive. Backup jobs repository is of course directed to a Disk, the one that is having a slow performance is the "file to tape" job. The Veeam server is installed on a VM, the tape is installed on a tape server through a private lan connection running at 1Gbps. The tape drive is used in Sym BE before Veeam, and its throughput is running around 1.5GB/Min or at least 25MB/s, right now we're seeing 10MB/s on veeam file to tape job.

v.eremin
Product Manager
Posts: 16160
Liked: 1320 times
Joined: Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin
Contact:

Re: Remote tape library. Slow performance

Post by v.eremin » Jan 27, 2015 9:27 am

Feel free to open a ticket with our support team and let them confirm your environment. Thanks.

tochi
Influencer
Posts: 14
Liked: never
Joined: Jan 26, 2015 10:05 am
Full Name: Renen Quinto
Contact:

Re: Remote tape library. Slow performance

Post by tochi » Jan 27, 2015 12:02 pm

Thanks,I just did... I'll also update things here when its resolved.

karthik108417
Novice
Posts: 8
Liked: 2 times
Joined: Mar 24, 2013 1:45 pm
Full Name: Karthikeyan Balasubramani
Location: Abu Dhabi
Contact:

Re: Remote tape library. Slow performance

Post by karthik108417 » Feb 02, 2015 7:14 pm

Hi,
I faced the same issue after upgrading to v8
I had my backup server running on win2008 R2 connected to IBM tape library (FC) drive and the backup to tape job was really slow running at 24mb/s

After a long troubleshooting, I upgraded my backup server OS to Win2012 R2 and ran the tape job again and now I can see the speed has drastically increased it's running at 90-120 mb/s and now the job finishes within the time.

Regards
Karthikeyan B

v.eremin
Product Manager
Posts: 16160
Liked: 1320 times
Joined: Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin
Contact:

Re: Remote tape library. Slow performance

Post by v.eremin » Feb 03, 2015 9:37 am

Thank you for taking time and sharing the found resolution. By the way, was upgrade the only thing that helped to increase performance? Did support team suggest it for specific reason or it was rather one of recommended troubleshooting steps? Thanks.

karthik108417
Novice
Posts: 8
Liked: 2 times
Joined: Mar 24, 2013 1:45 pm
Full Name: Karthikeyan Balasubramani
Location: Abu Dhabi
Contact:

Re: Remote tape library. Slow performance

Post by karthik108417 » Feb 09, 2015 6:07 am

Hi,

Yes upgrading the operating system to Win2012 R2 only resolved my issue.

I didn't open a case with support for this issue.

Regards
Karthikeyan B

Dima P.
Product Manager
Posts: 9782
Liked: 774 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: Remote tape library. Slow performance

Post by Dima P. » Feb 11, 2015 8:35 am

Karthikeyan,
Was thinking about your resolution – any chance you have noticed the difference in drivers versions for Win 2008R2 and Win 2012R2 operating systems? Or it was the same driver for both?

karthik108417
Novice
Posts: 8
Liked: 2 times
Joined: Mar 24, 2013 1:45 pm
Full Name: Karthikeyan Balasubramani
Location: Abu Dhabi
Contact:

Re: Remote tape library. Slow performance

Post by karthik108417 » Feb 16, 2015 4:49 am

Hello,

Yes I didn't go with Microsoft Drivers for Tape Library, I downloaded IBM Tape library drivers and installed it.

Regards
Karthikeyan B

v.eremin
Product Manager
Posts: 16160
Liked: 1320 times
Joined: Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin
Contact:

Re: Remote tape library. Slow performance

Post by v.eremin » Feb 16, 2015 10:26 am

Hmm, then, as Dmitry's tried to point out, the drivers' replacement (not the OS upgrade) might have been the reason of increased performance. Thanks.

gosnells
Influencer
Posts: 12
Liked: 1 time
Joined: Jul 23, 2012 4:28 am
Full Name: Mike Smith
Contact:

Re: Remote tape library. Slow performance

Post by gosnells » Jun 12, 2015 3:39 pm

finally! Very glad to have found this Veeam reg tweak.

8core Xeon, 32GB mem
2012R2
ML6010 (8Gbps FC)
multi-homed
2GbE LAG to production/mgnt network
10GbE to iSCSI SAN network
10GbE to CIFS backup network

Veeam 8, 8p1 & 8u2
No matter what the source (local Perc array, 16disk iSCSI Target, CIFS dedupe appliance), performance was averaging <35MB/s rendering multiple TB backups unworkable. No joy with consistent acceptable tape library backup performance.

Until now. Reg tweak applied. Decent, consistent performance - 145+MB/s - i.e. what the LTO6 should be capable of.

Thank you.

habibalby
Expert
Posts: 376
Liked: 23 times
Joined: Jul 18, 2011 9:30 am
Full Name: Hussain Al Sayed
Location: Bahrain
Contact:

Re: Remote tape library. Slow performance

Post by habibalby » Jul 08, 2016 1:15 pm

[SupportID=01844091]

Hi Guys,
My backup structure is layout and backup to tape between 9MB ~ 30MB...

Physical Sever Dell R720
Windows 2012 R2
8 Cores Dual CPUs
16 GB RAM
Dell Tape Library LTO 2000 with two drives connected via SAS.

Physical server is added to Veeam as Remote Tape Library
MUBBACK001 is just configured as Proxy (perhaps to increase the backup performance)


Veeam Media server is a VM with 20 GB Ram & 8 vCPUs Cores.
4 vNICs;
Production where all servers are connected.
vSphere is Where ESXi & vCenter Management network is connected.
iSCSI on its own network switches separated from LAN traffic to access all iSCSI Repositories.
Another iSCSI NIC is added on the same iSCSI Network Switches to access different repository.

iSCSI & CIFS Network;
CIFS is configured on EMC VNXe 3150 and Shared, added to the Veeam Media Server VM (Repository Server).
CIFS is mapped to the Veeam Media Server.

All backup to disk Jobs goes to the CIFS & Veeam backup files to tape from CIFS share to.

Any recommendations...?

Regards,

skrause
Expert
Posts: 381
Liked: 75 times
Joined: Dec 08, 2014 2:58 pm
Full Name: Steve Krause
Contact:

Re: Remote tape library. Slow performance

Post by skrause » Jul 08, 2016 6:35 pm

Are the volumes you are reading from using windows deduplication?

I found that reading backup files which had been deduped reduced my tape performance by a minimum of 50% versus from non-deduped locations and showed the bottleneck as "proxy".
Steve Krause
Veeam Certified Architect

habibalby
Expert
Posts: 376
Liked: 23 times
Joined: Jul 18, 2011 9:30 am
Full Name: Hussain Al Sayed
Location: Bahrain
Contact:

Re: Remote tape library. Slow performance

Post by habibalby » Jul 08, 2016 9:16 pm

hi steve,
that's perhaps he cause of the issue. on VNXe CIFS shares is enabled with Deduplications. I'm going to disable that and will see how it goes.
Thanks,

habibalby
Expert
Posts: 376
Liked: 23 times
Joined: Jul 18, 2011 9:30 am
Full Name: Hussain Al Sayed
Location: Bahrain
Contact:

Re: Remote tape library. Slow performance

Post by habibalby » Jul 09, 2016 11:27 am

Hi Steve,
Tried that, but still the same. Writing backup files to CIFS shares via Windows Map drive is unusable speed at all max 11MB/s. iSCSI LUN added to the Veeam VM Media Server (Which also act as a repository server) end up having speed range between 50~87 MB/s. Backing up from Veeam Job from iSCSI LUN to Tape speed range between 60~116 MB/s.

Added Local Disk of R720 Server (Where Tape Library is connected) as Repository to, backup to disk 55~90 MB/s. Backing up Veeam Job from this Repository to tape speed between 80~126 MB/s.

It seems the CIFS shars that accessed via Map Drive on the Repository and this Map Drive added to veeam as Repository, is where the bottleneck arise.

Any thoughts,..??

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest