Ejecting Magazine puts library as "offline" - v9

Everything about backing up to tape

Ejecting Magazine puts library as "offline" - v9

Veeam Logoby digitlman » Tue Mar 29, 2016 1:51 pm

Upgraded from v8 to v9 and the Update 1 yesterday.

Everything seems to be fine, except that now when I eject a magazine from my HP library, Veeam shows the library as "offline" until I basically rescan the offline library.

Maybe it would have popped back online by itself.

I guess this is more of an annoyance than anything right now.
digitlman
Enthusiast
 
Posts: 94
Liked: 3 times
Joined: Thu Jun 10, 2010 6:32 pm

Re: Ejecting Magazine puts library as "offline" - v9

Veeam Logoby v.Eremin » Tue Mar 29, 2016 2:53 pm

Everything seems to be fine, except that now when I eject a magazine from my HP library, Veeam shows the library as "offline" until I basically rescan the offline library.

It's expected behaviour. Though, there is an automatic rescan happening every 3 minutes, so manual rescan is not required. Thanks.
v.Eremin
Veeam Software
 
Posts: 13255
Liked: 968 times
Joined: Fri Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin

Re: Ejecting Magazine puts library as "offline" - v9

Veeam Logoby arfea » Thu Mar 31, 2016 9:09 am

Hello,

We have the same problem since upgrade v8 to v9.

In v8, library was always online. What to do in v9 to have the same operation ?

thanks.
arfea
Lurker
 
Posts: 2
Liked: never
Joined: Thu Mar 31, 2016 8:58 am
Full Name: Damien THIBAULT

Re: Ejecting Magazine puts library as "offline" - v9

Veeam Logoby Dima P. » Fri Apr 08, 2016 5:16 pm

Damien,

Can you clarify if the automated rescan (as described in previous post) works in you case? Thanks.
Dima P.
Veeam Software
 
Posts: 6231
Liked: 439 times
Joined: Mon Feb 04, 2013 2:07 pm
Location: SPb
Full Name: Dmitry Popov

Re: Ejecting Magazine puts library as "offline" - v9

Veeam Logoby rreed » Wed Apr 13, 2016 1:30 pm

Same here; I hadn't noticed it before but did yesterday while swapping tapes. Had me panicking and checking around for bumped cables, failed library, rebooted server, etc. Haha Looked back at the console after a few minutes of double-checking I hadn't caused it and realized its next scan picked back up everything after the library had done its normal re-scanning of tapes after magazine insert and Veeam did its normal re-scanning as well. Phew!
VMware 6
Veeam B&R v9
Dell DR4100's
EMC DD2200's
EMC DD620's
Dell TL2000 via PE430 (SAS)
rreed
Expert
 
Posts: 354
Liked: 72 times
Joined: Tue Jun 30, 2015 6:06 pm

Re: Ejecting Magazine puts library as "offline" - v9

Veeam Logoby pkelly_sts » Thu Apr 14, 2016 3:35 pm

I'm soon upgrading to v9, but as part of testing of tape backups in v8, whilst still using BExec, I created (I think) the registry entry to tell Veeam to only scan for tapes once per day (or something similar, can't quite remember the details right now).

I just wanted to check, after reading this topic, whether that registry change will persist after upgrading to v9, or will I have to juggle it again? I'll initially have to continue using BExec for a few days after the v9 upgrade just to be safe so want to be aware of anything I might need to watch for...
[New Sig: PLEASE get GFS tape support for incrementals!!!]
pkelly_sts
Expert
 
Posts: 500
Liked: 54 times
Joined: Thu Jun 13, 2013 10:08 am
Full Name: Paul Kelly

Re: Ejecting Magazine puts library as "offline" - v9

Veeam Logoby v.Eremin » Fri Apr 15, 2016 9:43 am

I was told that the said key is supposed to work properly. Thanks.
v.Eremin
Veeam Software
 
Posts: 13255
Liked: 968 times
Joined: Fri Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin

Re: Ejecting Magazine puts library as "offline" - v9

Veeam Logoby arfea » Mon Apr 18, 2016 7:58 am

Hello Dima,

The automated rescan works but we have to wait a few time. Before it was instantaneous.
arfea
Lurker
 
Posts: 2
Liked: never
Joined: Thu Mar 31, 2016 8:58 am
Full Name: Damien THIBAULT

Re: Ejecting Magazine puts library as "offline" - v9

Veeam Logoby v.Eremin » Mon Apr 18, 2016 11:11 am

As far as I know, the said behaviour has always been the same. Once the magazine is ejected, a library goes to offline state, till a next rescan (either manual or automatic) takes place. Thanks.
v.Eremin
Veeam Software
 
Posts: 13255
Liked: 968 times
Joined: Fri Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin

[MERGED] Tape offline when Tapes are exchanged

Veeam Logoby futureweb » Thu Sep 08, 2016 2:14 pm

Hi,

we have some tape backup jobs, that take longer than 24 hours.
We do have a HP Tapelibrary. (MSL2024).
Veeam we do have 9.0.0.1491

We experience a job termination occasionally, when the tape tray from the library is removed to swap tapes.
When Veeam is opened, I see that the complete libary goes "offline" when the tray is removed, this might be the reason for the termination.

But why does Veeam take the whole library offline, when a tray is removed?
It doesn't interfere with any tape job, not even, if at the same time it wants to swap a tape, as there is still a 2nd tray, that can't be removed at the same time.

So I am a little confused.

Thanks
Patrick
futureweb
Enthusiast
 
Posts: 53
Liked: 5 times
Joined: Thu Sep 03, 2015 12:15 am
Full Name: Patrick

Re: Ejecting Magazine puts library as "offline" - v9

Veeam Logoby v.Eremin » Fri Sep 09, 2016 9:50 am

As mentioned above, the described behaviour is expected. However, once the automatic rescan (happening every 3 minutes) takes place, the library will get online again. Thanks.
v.Eremin
Veeam Software
 
Posts: 13255
Liked: 968 times
Joined: Fri Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin


Return to Tape



Who is online

Users browsing this forum: No registered users and 9 guests