Failing Tape Jobs - 'The System cannot find the file...'

Everything about backing up to tape

Failing Tape Jobs - 'The System cannot find the file...'

Veeam Logoby danatk » Sat Nov 16, 2013 3:13 pm

Hi Guys - We are getting regular failures of tape jobs with the following error:

WinApi function 'CreateFile' failed, code '2', message 'The system cannot find the file specified'

All our tape jobs are set to run continuously and back up when new files appear. This seems to work great most of the time, but during busy periods (e.g. weekend full backup window) we get several failed jobs with this error. The backup then re-runs, presumably because it is continuous and still has files it needs to back up after the failure. Eventually all the jobs complete OK.

Any ideas? I will raise a support call, but thought I'd check on the forums first...

thanks,
dan.
danatk
Influencer
 
Posts: 19
Liked: 1 time
Joined: Thu Oct 24, 2013 8:58 am

Re: Failing Tape Jobs - 'The System cannot find the file...'

Veeam Logoby Dima P. » Mon Nov 18, 2013 9:59 am

Hello Dan,

For me it looks like the system glitch - so it definitely should be investigated by support team. Please update this thread with the support case, once you have it. Thank you.
Dima P.
Veeam Software
 
Posts: 6249
Liked: 440 times
Joined: Mon Feb 04, 2013 2:07 pm
Location: SPb
Full Name: Dmitry Popov

Re: Failing Tape Jobs - 'The System cannot find the file...'

Veeam Logoby danatk » Mon Nov 18, 2013 12:37 pm

OK thanks - we just updated to Patch 2 since the weekend and rebooted the whole environment. I will wait a few days to see how it works out and then will raise a support call if we still see the problem.
danatk
Influencer
 
Posts: 19
Liked: 1 time
Joined: Thu Oct 24, 2013 8:58 am

Re: Failing Tape Jobs - 'The System cannot find the file...'

Veeam Logoby Dima P. » Mon Nov 18, 2013 12:54 pm

Great, please keep us posted!
Dima P.
Veeam Software
 
Posts: 6249
Liked: 440 times
Joined: Mon Feb 04, 2013 2:07 pm
Location: SPb
Full Name: Dmitry Popov

Re: Failing Tape Jobs - 'The System cannot find the file...'

Veeam Logoby f.dapra@ifinet.it » Thu Nov 21, 2013 4:20 pm

I had the same problem and discovered it was another service on the veeam service that was trying to use the tape drive. (old Backup Exec that was reactivated for a restore operation)
f.dapra@ifinet.it
Novice
 
Posts: 4
Liked: never
Joined: Tue Jul 24, 2012 12:10 pm
Full Name: Fabrizio Da Pra

Re: Failing Tape Jobs - 'The System cannot find the file...'

Veeam Logoby v.Eremin » Fri Nov 22, 2013 8:44 am

Yep, Fabrizio is right here. Usage of vendor-provided Windows drivers and absence of other tape backup software running simultaneously have been the requirement for some time.

So, whenever you face issues with VB&R tape functionality checking the above mentioned things should be the first investigation step you conduct.

Thanks.
v.Eremin
Veeam Software
 
Posts: 13266
Liked: 968 times
Joined: Fri Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin

Re: Failing Tape Jobs - 'The System cannot find the file...'

Veeam Logoby danatk » Sat Nov 23, 2013 3:03 pm

thanks....we don't share the library with any other backup software, so that's not the issue.

the good news is that we haven't seen the problem so far this weekend - the backups are running OK.
danatk
Influencer
 
Posts: 19
Liked: 1 time
Joined: Thu Oct 24, 2013 8:58 am

Re: Failing Tape Jobs - 'The System cannot find the file...'

Veeam Logoby v.Eremin » Sun Nov 24, 2013 8:42 pm

If the issue shows up again, don't hesitate to open a ticket with our support team. Thanks.
v.Eremin
Veeam Software
 
Posts: 13266
Liked: 968 times
Joined: Fri Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin

Re: Failing Tape Jobs - 'The System cannot find the file...'

Veeam Logoby danatk » Mon Nov 25, 2013 9:05 am

thanks vladimir - all our backups ran without errors over the weekend so I think the problem is solved.

it's really nice to come in on Monday morning and only see the green 'success' node in the 'last 24' hours view :)
danatk
Influencer
 
Posts: 19
Liked: 1 time
Joined: Thu Oct 24, 2013 8:58 am

Re: Failing Tape Jobs - 'The System cannot find the file...'

Veeam Logoby v.Eremin » Mon Nov 25, 2013 9:53 am

Glad to hear that you've nailed it down. Hopefully, starting form this moment, you will get only green ticks in "Last 24 hours" view. :)

Thanks.
v.Eremin
Veeam Software
 
Posts: 13266
Liked: 968 times
Joined: Fri Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin


Return to Tape



Who is online

Users browsing this forum: No registered users and 8 guests