Hardware encryption not enabled for my tape drive

Discussions specific to tape backups

Hardware encryption not enabled for my tape drive

Veeam Logoby dsegel » Sat Aug 19, 2017 9:21 pm

I'm backing up to a Dell TL1000 LTO-7 autoloader with an encryption license. The drive says that encryption is licensed and available, but when I select encryption in my media pool it says "8/19/2017 9:05:37 AM :: New tape backup session started, encryption: software "

Is there some trick to get it to recognize that the drive can do hardware encryption?
dsegel
Influencer
 
Posts: 11
Liked: never
Joined: Wed Aug 09, 2017 3:51 pm
Full Name: Daniel Segel

Re: Hardware encryption not enabled for my tape drive

Veeam Logoby Dima P. » Sun Aug 20, 2017 7:48 pm

Hi Daniel,

Hardware encryption should be enabled on the library level, so please check your tape library console.

P.S. Found some sort of web guide. Looks valid.
Dima P.
Veeam Software
 
Posts: 7121
Liked: 510 times
Joined: Mon Feb 04, 2013 2:07 pm
Location: SPb
Full Name: Dmitry Popov

Re: Hardware encryption not enabled for my tape drive

Veeam Logoby dsegel » Tue Aug 22, 2017 2:07 pm

Encryption is enabled on the tape drive, and it uses its own key management system. I suspect that VBR doesn't know that it's enabled, so it's trying to encrypt the data itself. I'm going to turn it off in VBR and test to see if it still encrypts on the tapes.
dsegel
Influencer
 
Posts: 11
Liked: never
Joined: Wed Aug 09, 2017 3:51 pm
Full Name: Daniel Segel

Re: Hardware encryption not enabled for my tape drive

Veeam Logoby Dima P. » Tue Aug 22, 2017 5:24 pm

Hi Daniel,

Try to create new Media Pool with encryption enabled and new File to tape job. Run job for a single file as a source and check the encryption state.
Dima P.
Veeam Software
 
Posts: 7121
Liked: 510 times
Joined: Mon Feb 04, 2013 2:07 pm
Location: SPb
Full Name: Dmitry Popov

Re: Hardware encryption not enabled for my tape drive

Veeam Logoby marieelieg » Mon Nov 27, 2017 7:36 am

Hello dears,

If hardware encryption is enabled on my tape library, do I still need to enable encryption at the media pool level?
https://helpcenter.veeam.com/docs/backu ... tml?ver=95

Thanks in advance :D
marieelieg
Enthusiast
 
Posts: 82
Liked: 3 times
Joined: Thu Oct 20, 2016 7:15 am

Re: Hardware encryption not enabled for my tape drive

Veeam Logoby v.Eremin » Mon Nov 27, 2017 10:38 am

Correct.
v.Eremin
Veeam Software
 
Posts: 14227
Liked: 1066 times
Joined: Fri Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin

Re: Hardware encryption not enabled for my tape drive

Veeam Logoby marieelieg » Mon Nov 27, 2017 1:23 pm

Thanks v.Eremin!
marieelieg
Enthusiast
 
Posts: 82
Liked: 3 times
Joined: Thu Oct 20, 2016 7:15 am

Re: Hardware encryption not enabled for my tape drive

Veeam Logoby v.Eremin » Mon Nov 27, 2017 1:46 pm

You're welcome, in case of hardware encryption the encryption key will be passed to tape device and the device will leverage it to encrypt data on tapes. Otherwise, this function will be performed by tape server. Thanks.
v.Eremin
Veeam Software
 
Posts: 14227
Liked: 1066 times
Joined: Fri Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin


Return to Tape



Who is online

Users browsing this forum: No registered users and 1 guest