Discussions specific to tape backups
Post Reply
jimscott
Influencer
Posts: 15
Liked: never
Joined: Oct 04, 2017 11:22 am
Full Name: Jim Scott
Contact:

Restore from encrypted tapes

Post by jimscott » Jul 06, 2019 12:42 pm

hello all,
I am having the following issue with a restore.

I have a Veeam backup job that has backed up several VMware VMs as normal with Veeam B&R.
This backup job plus daily incremental are copied to tape. The tape media pool is encrypted using Veeam and an encrypted media pool.

I have taken the tapes to another site and I am trying to restore with different hardware (B&R server + different tape drive). However when I try and restore I can see the tapes, I have entered the password after the tapes have been catalogued but I am getting an error when I try and restore the tapes back stating the Tape drive does not support hardware encryption.

Any ideas?
Jim

csydas
Expert
Posts: 193
Liked: 46 times
Joined: Jan 16, 2018 5:14 pm
Full Name: Harvey Carel
Contact:

Re: Restore from encrypted tapes

Post by csydas » Jul 06, 2019 9:23 pm

Hi Jim,

Just to be sure, both sites have hw encryption available, correct? Hardware encryption is how they get ya :) It's an extra cost, but it's convenient. You need to make sure that your DR site tape has the hw encryption license installed also.

jimscott
Influencer
Posts: 15
Liked: never
Joined: Oct 04, 2017 11:22 am
Full Name: Jim Scott
Contact:

Re: Restore from encrypted tapes

Post by jimscott » Jul 12, 2019 4:59 pm

Hi, we have never installed a license in the past for HW encryption. The only passwords we use are inside the media pool in Veeam - Tape Infrastructure.

veremin
Product Manager
Posts: 16524
Liked: 1374 times
Joined: Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin
Contact:

Re: Restore from encrypted tapes

Post by veremin » Jul 12, 2019 5:09 pm

So, use encryption option is enabled in the media pool settings, right? If so, check whether both source and target libraries support hardware encryption and whether they both have it enabled.

It seems that tapes have been encrypted by source library and cannot be read by target one due it not supporting encryption or not having it enabled.

Thanks!

jimscott
Influencer
Posts: 15
Liked: never
Joined: Oct 04, 2017 11:22 am
Full Name: Jim Scott
Contact:

Re: Restore from encrypted tapes

Post by jimscott » Jul 12, 2019 5:24 pm

Is it enabled in the media pool. Use encryption is ticked and a password is set in Veeam. The restore process works fine until I updated the restore server to 9.5-4a. I reinstalled server 2012 R2 and Veeam 9.5 Update3 and tried some encrypted tapes from before the upgrade then they restored ok after entering the encryption password for the media pool.

veremin
Product Manager
Posts: 16524
Liked: 1374 times
Joined: Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin
Contact:

Re: Restore from encrypted tapes

Post by veremin » Jul 15, 2019 1:17 pm

Again, you should check whether source and target libraries support hardware encryption.

If hardware encryption is enabled for the tape media, Veeam Backup & Replication automatically disables its software encryption mechanism for such tape libraries. The Veeam encryption mechanism can only be used if hardware encryption is disabled at the tape device level or not supported.

It seems that tapes have been encrypted by source library via hardware encryption and cannot be read by target one due it not supporting encryption or not having it enabled.

Hope this makes sense.

Thanks!

Post Reply

Who is online

Users browsing this forum: No registered users and 9 guests