Discussions specific to tape backups
Post Reply
mkretzer
Expert
Posts: 525
Liked: 110 times
Joined: Dec 17, 2015 7:17 am
Contact:

Restore error after U4b: Error [MT]SCSI PASS THROUGH DIRECT

Post by mkretzer » Jul 12, 2019 6:51 pm

Hello,

case 03662660.
After update 4b we get:

Error Restore error. Error: [MT]SCSI PASS THROUGH DIRECT ended with Scsi Error Fixed format, current; Sense key: Illegal Request. Additional sense: Invalid field in command information unit

when we try to restore. We tried different media sets, different drives and tapes written by different drives. No restore is working!

Markus

mkretzer
Expert
Posts: 525
Liked: 110 times
Joined: Dec 17, 2015 7:17 am
Contact:

Re: Restore not possible after u4b

Post by mkretzer » Jul 12, 2019 10:50 pm

Support found something and we verified via backup test: Hardware encryption does not seem to work with 4b!

2 days ago with 4a backups used HW encryption now with 4b it only uses software encryption. Also we cannot restore......

Dima P.
Product Manager
Posts: 10284
Liked: 832 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: Restore not possible after u4b

Post by Dima P. » Jul 15, 2019 5:10 pm

Hello Makrus,

The case is being reviewed by RnD folks. Stay tuned.

mkretzer
Expert
Posts: 525
Liked: 110 times
Joined: Dec 17, 2015 7:17 am
Contact:

Re: Restore not possible after u4b

Post by mkretzer » Jul 15, 2019 6:55 pm

Thank you i see that it was escalated :-)

Gostev
SVP, Product Management
Posts: 24416
Liked: 3402 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: Restore not possible after u4b

Post by Gostev » Jul 16, 2019 1:20 pm

QC confirmed this as a bug that happens when the tape library's hardware encryption setting is set to "Application managed". We will issue a KB with the hotfix shortly. The data on tapes is fine, so restore will work fine from the existing tapes once the hotfix is applied.

mkretzer
Expert
Posts: 525
Liked: 110 times
Joined: Dec 17, 2015 7:17 am
Contact:

Re: Restore not possible after u4b

Post by mkretzer » Jul 16, 2019 5:49 pm

@gostev worst timing ever for us in the middle of an audit :-)

But at least we can show them what a failed restore test looks like. This happens not so often with Veeam...
Do you have an ETA for the patch?

Dima P.
Product Manager
Posts: 10284
Liked: 832 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: Restore not possible after u4b

Post by Dima P. » Jul 16, 2019 6:12 pm

Markus,

Sorry to hear that! We've prepared a private fix for Update 4b and now it's being tested by our QA department. Once it's signed - you'll get it via support team.

mkretzer
Expert
Posts: 525
Liked: 110 times
Joined: Dec 17, 2015 7:17 am
Contact:

Re: Restore not possible after u4b

Post by mkretzer » Jul 16, 2019 7:02 pm

Is the fix only "touching" the restore part? Then we could test now - it cannot get any worse as "unable to restore"

Dima P.
Product Manager
Posts: 10284
Liked: 832 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: Restore not possible after u4b

Post by Dima P. » Jul 17, 2019 3:55 pm

Yes, fix will include enable the ability to perform recovery from the previously written tape and correct the accidental failover to application aware encryption during backup (whenever hardware encryption is available it should be used instead of software encryption).

mkretzer
Expert
Posts: 525
Liked: 110 times
Joined: Dec 17, 2015 7:17 am
Contact:

Re: Restore not possible after u4b

Post by mkretzer » Jul 17, 2019 8:32 pm

... and it works perfectly! Many thanks!

Dima P.
Product Manager
Posts: 10284
Liked: 832 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: Restore not possible after u4b

Post by Dima P. » Jul 18, 2019 11:01 am

Markus,

Glad to hear it and sorry for any inconvenience caused. Cheers!

Gostev
SVP, Product Management
Posts: 24416
Liked: 3402 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: Restore not possible after u4b

Post by Gostev » Jul 18, 2019 10:17 pm 2 people like this post

Here's a KB article with the hotfix > KB2981

bucoops
Enthusiast
Posts: 44
Liked: 4 times
Joined: Aug 01, 2016 6:37 pm
Full Name: Richard
Contact:

Re: Restore error after U4b: Error [MT]SCSI PASS THROUGH DIRECT

Post by bucoops » Aug 15, 2019 3:36 pm 1 person likes this post

Had the same (trouser filling) error when trying to restore a 2 year old backup tape. The hotfix worked for me (phew!).

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 3 guests