Using tape as a backup target
Post Reply
sbbots
Enthusiast
Posts: 96
Liked: 25 times
Joined: Aug 16, 2013 5:44 pm
Full Name: Matt B

Scheduling Problem - Files to tape

Post by sbbots »

Because we are planning to purchase the Standard version I am forced to use files-to-tape instead of backups-to-tape :cry: We do 2 full offsite backups per month to tape so I setup 2 full backups to disk (on the 1st and 3rd Sat of each month) and then 2 corresponding file backups to tape. Now for the problem...

Veeam keeps changing the scheduled time to run the tape jobs. After I set the time for the tape jobs (11:59pm) and click finish the console shows the "Next run" time correctly, but after a few seconds the scheduled time changes for no reason at all.

Below is what the console shows after I click finish...

Image

After a few seconds it changes the "next run" time...

Image

Any ideas why this might be happening?

veremin
Product Manager
Posts: 18831
Liked: 1903 times
Joined: Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin
Contact:

Re: Scheduling Problem - Files to tape

Post by veremin »

Did you, probably, disable the incremental schedule for the file to tape copy job? If so, try to tick the corresponding option (Incremental Backup -> Run incremental backup), set there the same time (3 Saturday, 11:59), untick it back and click “Finish”. After it, the schedule shouldn’t change any longer.

Thanks.

sbbots
Enthusiast
Posts: 96
Liked: 25 times
Joined: Aug 16, 2013 5:44 pm
Full Name: Matt B

Re: Scheduling Problem - Files to tape

Post by sbbots »

v.Eremin wrote:Did you, probably, disable the incremental schedule for the file to tape copy job? If so, try to tick the corresponding option (Incremental Backup -> Run incremental backup), set there the same time (3 Saturday, 11:59), untick it back and click “Finish”. After it, the schedule shouldn’t change any longer.
Thanks.
That was the first thing I tried. I did it 3-4 times and same problem - console shows it correctly for 4-5 seconds then changes. I have checked the scheduling settings a dozen times on both the original jobs and the tape jobs. Problem persists and it is not just cosmetic (console just showing the wrong date) but it actually ran the tape job last night when it wasn't even scheduled!

I am having a lot of issues with Veeam right now (SMTP notifications no longer work for no reason at all, old restore points not being removed, job scheduling, ect etc), so I am going to do a clean install of Veeam today; E.G. completely remove Veeam and SQL database, then reinstall. I really hope this works because my high enthusiasm for Veeam is starting to dwindle day by day. Using vRanger with Arcserve to tape worked fine, Veeam doesn't.

Erhardt
Influencer
Posts: 18
Liked: never
Joined: Aug 23, 2013 2:25 pm
Full Name: Erhardt
Contact:

Re: Scheduling Problem - Files to tape

Post by Erhardt »

sbbots wrote: I am having a lot of issues with Veeam right now (SMTP notifications no longer work for no reason at all, old restore points not being removed, job scheduling, ect etc
I had to reenter the "Main"-SMTP-Password under Options after upgrading to Veeam 7 - did you check it?
Old restore points i remove with "remove from backups/replicas" (to remove them from SQL database) and then i remove them from disk manually. If i use the option "remove from disk" i had problems with old restore points, too, because they stucked in the SQL database.

sbbots
Enthusiast
Posts: 96
Liked: 25 times
Joined: Aug 16, 2013 5:44 pm
Full Name: Matt B

Re: Scheduling Problem - Files to tape

Post by sbbots »

Erhardt wrote:I had to reenter the "Main"-SMTP-Password under Options after upgrading to Veeam 7 - did you check it?
Old restore points i remove with "remove from backups/replicas" (to remove them from SQL database) and then i remove them from disk manually. If i use the option "remove from disk" i had problems with old restore points, too, because they stucked in the SQL database.
Tried that already. SMTP notifications were delivered just fine the first week after I installed v7. Then 2 days ago no notifications and I started to see an error at the end of backup reports. Checked the settings, re-entered user/password for SMTP, clicked the test mail button, received the test mail and yet the problem persists. Just like the schedule problem it makes no sense at all.

veremin
Product Manager
Posts: 18831
Liked: 1903 times
Joined: Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin
Contact:

Re: Scheduling Problem - Files to tape

Post by veremin »

I’ve just tested this – and it seems that after the incremental schedule had been enabled/disabled in accordance with the full one, the next job run was shown correctly. So, if you experience different behaviour, it might be worth opening a ticket with our support team and letting them investigate it directly, since it’s the fastest and most reliable way to address any technical issue.

Thanks.

sbbots
Enthusiast
Posts: 96
Liked: 25 times
Joined: Aug 16, 2013 5:44 pm
Full Name: Matt B

Re: Scheduling Problem - Files to tape

Post by sbbots »

v.Eremin wrote:I’ve just tested this – and it seems that after the incremental schedule had been enabled/disabled in accordance with the full one, the next job run was shown correctly. So, if you experience different behaviour, it might be worth opening a ticket with our support team and letting them investigate it directly, since it’s the fastest and most reliable way to address any technical issue.
Thanks Vlad, I really appreciate the support you guys have given so far in my various threads. Like I mentioned before - once I click finish the console displays the correct time, then after a few seconds it just switches back to a schedule that I have not set anywhere.

I am doing a clean install of Veeam right now. Once it is complete I will setup a few jobs and see if it works correctly.

sbbots
Enthusiast
Posts: 96
Liked: 25 times
Joined: Aug 16, 2013 5:44 pm
Full Name: Matt B

Re: Scheduling Problem - Files to tape

Post by sbbots »

sbbots wrote:I am doing a clean install of Veeam right now. Once it is complete I will setup a few jobs and see if it works correctly.
So far, so good :D

After a clean install (which included removing the SQL instance) I decided to start from scratch rather than restore the server config. After creating the backup jobs the scheduled times I set for file-to-tape are now sticking correctly. Now, I just have to leave my server alone and let it run for the next 3-4 weeks unattended (other then swapping a tape on the 1st). If all I see are success email notifications during that period then you have a happy Veeam customer.

Thanks for the help.

horst
Enthusiast
Posts: 38
Liked: 4 times
Joined: Aug 27, 2013 6:55 am
Location: GER
Contact:

Re: Scheduling Problem - Files to tape

Post by horst »

Hi all,

I have the same Problem with the randomly changing schedular time for my backup to tape job.
I generated a full backup job (no incremental), that should run every day from monday to saturday at 11 pm.

As sbbots wrote, the backup time is shown correctly, after generating the backup job. But then Veeam B&R is changing the time to 8 pm itself :?
The software was installed on a fresh Windows Server 2012. So I don`t think, the problem will be solved, by setting it up again. Could it be a bug in the software?

veremin
Product Manager
Posts: 18831
Liked: 1903 times
Joined: Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin
Contact:

Re: Scheduling Problem - Files to tape

Post by veremin »

Hi, Horst. May I ask you to try to enable an incremental schedule temporarily, set there the exact same time you’ve set for full, then, disable it back and click “Finish”? In my test environment, once I implemented the aforesaid workaround, the time has never changed.

Thanks.

horst
Enthusiast
Posts: 38
Liked: 4 times
Joined: Aug 27, 2013 6:55 am
Location: GER
Contact:

Re: Scheduling Problem - Files to tape

Post by horst »

Hi, I tried the work around and until now, the time didn`t change from itselfe.
So now I hope, the copy job will run automatically tonight at 11 pm and then tomorrow I will have another look at it.

Thanks for your hint!

veremin
Product Manager
Posts: 18831
Liked: 1903 times
Joined: Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin
Contact:

Re: Scheduling Problem - Files to tape

Post by veremin »

Glad to hear that my input was helpful. Kindly, keep us updated about the results you get. Thanks.

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests