Discussions specific to tape backups
Post Reply
AmyOps
Novice
Posts: 4
Liked: never
Joined: Jan 10, 2018 11:01 am
Full Name: Amu Senior
Contact:

Tape backup sending the wrong data to tape

Post by AmyOps » Jan 10, 2018 11:27 am

Hi All,

We have multiple local backups which are then transferred to tape as a synthetic full.

When one of our local backups takes longer to run and runs after the tape backup begins the tape backup takes longer to run as you would expect but works perfectly fine and still does the synth full.

The next day however it will backup the previous days data and not the latest and it will only transfer a VBK and not perform a synthetic full.

So yesterday we had a problem with the local backup running for longer on the 8th the data from the 8th was backed up as normal but today the same data was backed up again nd the data from the last night (the 9th) was never written to tape. Despite the fact the speed of the local backup returned to normal and completed before last night's running of the tape backup

Can anyone explain why we do not see the effect of this until the second running of the tape and why Veeam carries the issue over into the next day? (and if there is anything we can do to prevent this)

Kind Regards,
Amy

v.Eremin
Veeam Software
Posts: 15209
Liked: 1146 times
Joined: Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin
Contact:

Re: Tape backup sending the wrong data to tape

Post by v.Eremin » Jan 10, 2018 1:26 pm

Can you shed some light on how backup (or backup copy) and backup to tape jobs are configured? More specifically, simple and full backup schedules as well as virtual full backup schedule? Thanks.

AmyOps
Novice
Posts: 4
Liked: never
Joined: Jan 10, 2018 11:01 am
Full Name: Amu Senior
Contact:

Re: Tape backup sending the wrong data to tape

Post by AmyOps » Jan 10, 2018 1:45 pm

Hi,

Thank you.

We have four endpoint jobs with 1 retention point that target a share on the server where the tape drive is installed.

The tape backup is a full (synthetic full created every night to a tape that goes offsite) The tape backup job is scheduled to start at 23:30 every night.

The issue is that one of the Endpoint backups is around 1.6 TB. Normally the Endpoint backup completes before the tape job starts. However if this Endpoint backup completes AFTER the tape backup has already started it would appear the synthetic full is still created as normal. However the following night instead of a synthetic full being created when writing to tape, the file that gets written to tape is the same VBK file that the Endpoint created more than 24 hours previously (from the night that the endpoint backup exceeded the tape job start time). We cannot bring the start time of the Endpoint job forward as this will affect production hours and previously the tape backup used to start after midnight (we had issues and Veeam Support recommended starting the backup prior to midnight).

Any advice would be well received as we are just trying to understand why on the second night a synthetic full is not written to tape as normal.

Kind Regards,
Amy

v.Eremin
Veeam Software
Posts: 15209
Liked: 1146 times
Joined: Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin
Contact:

Re: Tape backup sending the wrong data to tape

Post by v.Eremin » Jan 10, 2018 2:31 pm

However the following night instead of a synthetic full being created when writing to tape, the file that gets written to tape is the same VBK file that the Endpoint created more than 24 hours previously (from the night that the endpoint backup exceeded the tape job start time).
I'm slightly confused. How come backup to tape job (started after backup job) archived previous night backup, if there was only one restore point left, given your retention?

AmyOps
Novice
Posts: 4
Liked: never
Joined: Jan 10, 2018 11:01 am
Full Name: Amu Senior
Contact:

Re: Tape backup sending the wrong data to tape

Post by AmyOps » Jan 10, 2018 5:11 pm

Hi,

Thank you.

There is always one VBK and one VIB for each Endpoint server in the target folder.

Normally when the backup to tape job runs it creates a synthetic full and one VBK file gets written to tape .

On the first day when the Endpoint surpassed the time that the tape backup began, the tape backup reported that it had completed a synthetic full. On the second day it did a transfer of the VBK from the previous backup (not the latest the one over 24 hours ago) and did not do a synthetic full but only transferred the VBK.

This is the what we are trying to understand why this happens and why it doesn't happen until the next day even if the next days tape runs on schedule.

Kind Regards,
Amy

Dima P.
Veeam Software
Posts: 8756
Liked: 647 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: Tape backup sending the wrong data to tape

Post by Dima P. » Jan 11, 2018 6:58 pm

Amy,
AmyOps wrote:On the first day when the Endpoint surpassed the time that the tape backup began, the tape backup reported that it had completed a synthetic full. On the second day it did a transfer of the VBK from the previous backup (not the latest the one over 24 hours ago) and did not do a synthetic full but only transferred the VBK.
Synthetic full is not created only in case you have the full backup on disk. I assume tape job started, checked that you do not have an incremental restore point for the given day, checked that the closest restore point is a full backup from the day before and then wrote that full backup to tape. Check this article for more details.

AmyOps
Novice
Posts: 4
Liked: never
Joined: Jan 10, 2018 11:01 am
Full Name: Amu Senior
Contact:

Re: Tape backup sending the wrong data to tape

Post by AmyOps » Jan 12, 2018 10:11 am

Hi Dima,

Thank you.

Normally I would think the same thing except, we do not see the issue on the day the endpoint runs over the tape backup start time, we see it on the second run even when the next endpoint completed before the tape backup started.

Kind Regards,
Amy

lyapkost
Veeam Software
Posts: 136
Liked: 17 times
Joined: Nov 27, 2015 2:26 pm
Full Name: Konstantin
Location: Saint Petersburg
Contact:

Re: Tape backup sending the wrong data to tape

Post by lyapkost » Jan 18, 2018 9:45 am

Hi Amy.
AmyOps wrote:There is always one VBK and one VIB for each Endpoint server in the target folder.
The tape job will not work as expected with such source jobs. Consider changing retention settings so that source jobs have at least 3 restore points. This is a mandatory prerequisite.

Post Reply

Who is online

Users browsing this forum: No registered users and 10 guests