Agent on Ubuntu trying the wrong IP address to VBR server

Backup agent for Linux servers and workstations on-premises or in the public cloud

Agent on Ubuntu trying the wrong IP address to VBR server

Veeam Logoby dsegel » Wed Sep 13, 2017 4:19 pm

I'm running VAL on an Ubuntu 14.04 server to back up to a VBR server. It keeps trying all the available IP addresses on the VBR server, despite being configured with the specific IP it should use to connect to it. This slows down the start and running of each job by qiote a bit. Is there any way to force it to only use the one IP?

Code: Select all
[13.09.2017 09:06:31] <140620674881280> lpbcore|     IP endpoints: [192.168.2.16:2501; 192.168.1.16:2501; 192.168.2.17:2501; 192.168.1.17:2501; 10.2.1.16:2501].
[13.09.2017 09:06:31] <140620674881280>        |     Trying to connect to the endpoint [192.168.2.16:2501]
[13.09.2017 09:06:38] <140620666488576> lpbcore| Lease keeper: sending keep-alive request.
[13.09.2017 09:08:38] <140620674881280>        |   Connection status: system:110 ( Connection timed out ).
[13.09.2017 09:08:38] <140620674881280>        |     Trying to connect to the endpoint [192.168.1.16:2501]
[13.09.2017 09:09:08] <140620666488576> lpbcore| Lease keeper: sending keep-alive request.
[13.09.2017 09:10:45] <140620674881280>        |   Connection status: system:110 ( Connection timed out ).
[13.09.2017 09:10:45] <140620674881280>        |     Trying to connect to the endpoint [192.168.2.17:2501]
[13.09.2017 09:11:38] <140620666488576> lpbcore| Lease keeper: sending keep-alive request.
n[13.09.2017 09:12:52] <140620674881280>        |   Connection status: system:110 ( Connection timed out ).
[13.09.2017 09:12:52] <140620674881280>        |     Trying to connect to the endpoint [192.168.1.17:2501]
[13.09.2017 09:14:08] <140620666488576> lpbcore| Lease keeper: sending keep-alive request.
[13.09.2017 09:15:00] <140620674881280>        |   Connection status: system:110 ( Connection timed out ).
[13.09.2017 09:15:00] <140620674881280>        |     Trying to connect to the endpoint [10.2.1.16:2501]
[13.09.2017 09:15:00] <140620674881280>        |   Connection status: system:0 ( Success ).
dsegel
Influencer
 
Posts: 11
Liked: never
Joined: Wed Aug 09, 2017 3:51 pm
Full Name: Daniel Segel

Re: Agent on Ubuntu trying the wrong IP address to VBR serve

Veeam Logoby Crashinit » Wed Sep 27, 2017 9:39 pm

Did you find a solution to this?
I am having the same issue.
It is slowing the backup job by up to 30 minutes.

Craig
Crashinit
Influencer
 
Posts: 11
Liked: never
Joined: Thu Nov 10, 2016 9:58 pm
Full Name: Craig Connoll

Re: Agent on Ubuntu trying the wrong IP address to VBR serve

Veeam Logoby Tibo » Thu Oct 19, 2017 1:28 pm

Same issue here. It takes 30 minutes to start.
Tibo
Service Provider
 
Posts: 10
Liked: never
Joined: Fri May 20, 2011 8:15 am
Full Name: Tibo

Re: Agent on Ubuntu trying the wrong IP address to VBR serve

Veeam Logoby vmniels » Fri Oct 20, 2017 1:56 pm

Please contact support for insight and assistance in a solution. If possible post the support ID for future references. Thanks!
VCP-DCV
Veeam Certified Architect (VMCA)
http://foonet.be
vmniels
Veeam Software
 
Posts: 1918
Liked: 413 times
Joined: Mon Jul 15, 2013 11:09 am
Full Name: Niels Engelen

Re: Agent on Ubuntu trying the wrong IP address to VBR serve

Veeam Logoby PTide » Fri Oct 20, 2017 3:42 pm

Hi,

When VBR server is contacted by Agent it returns all IP addresses of the host where the target data mover is working, i.e. a repository or its gateway. In case the host has multiple IP addresses then multiple IPs will be returned.
Currently there is no conventional fix for that, however we're considering to fix this in future release. It should be possible to workaround the issue by setting an iptables rule that will forwards all port 2501 outbound traffic to the correct IP. Please note, that if there are multiple agents sending backups to the same repository then ports next to 2501 will be assigned for data transfer, e.g. agent1: 2501, agent2: 2502, agent3:2503.

Thanks
PTide
Veeam Software
 
Posts: 3996
Liked: 336 times
Joined: Tue May 19, 2015 1:46 pm

Re: Agent on Ubuntu trying the wrong IP address to VBR serve

Veeam Logoby brenoribas » Wed Jun 27, 2018 10:59 am

I have exactly the same issue and I believe that is a bug in Linux agent and I made the following workaround to avoid communication between Linux Agent and Veeam Backup Server:

1 - Created a shared folder into backup repository (CIFS or NFS)
2 - Mount the shared folder in Linux
3 - Configure the backup job from the Veeam Agent for Linux utility instead of using Veeam Backup Server console.

In this way, the backup will be managed by the agent instead of Backup Server and the backup files will be saved directly on shared folder into backup repository.

Before this, I did try to create iptables NAT rules but doesn't worked

Anyway, will be useful Veeam Support check this case, because when the Backup Server has multiple IPs, the Linux agent can face issues.

Case # 03060006
brenoribas
Lurker
 
Posts: 2
Liked: never
Joined: Wed Jun 27, 2018 10:50 am
Full Name: Breno Fernando Ribas

Re: Agent on Ubuntu trying the wrong IP address to VBR serve

Veeam Logoby PTide » Wed Jun 27, 2018 3:12 pm

Hi Breno and welcome to the community.

Anyway, will be useful Veeam Support check this case, because when the Backup Server has multiple IPs, the Linux agent can face issues.

On Agent - did you specify an IP address or DNS name of VBR server?
Where does your VBR repository reside - is it on VBR server or on a separate machine? If the latter, does the machine have multiple IP addresses?

Thanks
PTide
Veeam Software
 
Posts: 3996
Liked: 336 times
Joined: Tue May 19, 2015 1:46 pm

Re: Agent on Ubuntu trying the wrong IP address to VBR serve

Veeam Logoby brenoribas » Thu Jun 28, 2018 4:24 pm

Hi PTide,

I tried to add using DNS and IP address but I received the same error.

My repository is attached to the Veeam backup server using iSCSI protocol.
brenoribas
Lurker
 
Posts: 2
Liked: never
Joined: Wed Jun 27, 2018 10:50 am
Full Name: Breno Fernando Ribas

Re: Agent on Ubuntu trying the wrong IP address to VBR serve

Veeam Logoby PTide » Thu Jun 28, 2018 5:04 pm

Then it is exactly the same behaviour that I've described earlier - if target repository has multiple IP addresses, then VBR will return all of those addresses to VAL. In your case the storage is connected to VBR via iSCSI therefore data-mover service runs on the very same machine with VBR, therefore it returns all available addresses to VAL. The same behaviour can be observed if you try to replace VAL with VAW.

Thanks
PTide
Veeam Software
 
Posts: 3996
Liked: 336 times
Joined: Tue May 19, 2015 1:46 pm


Return to Veeam Agent for Linux



Who is online

Users browsing this forum: No registered users and 4 guests