Backing up to QNAP NAS

Backup agent for Linux servers and workstations on-premises or in the public cloud

Backing up to QNAP NAS

Veeam Logoby bdleo » Wed Oct 19, 2016 8:08 pm

Hello All,

I am trying to configure Veeam on RHEL 6 and i get the following error when trying to backup to a windows share folder.

I have proper network access to the share, veeam is able to create a folder with a job name but it fails to create the backup.
Code: Select all
2016-10-19 12:02:38 Job started at 2016-10-19 12:02:38
     2016-10-19 12:02:38 Starting backup
     2016-10-19 12:02:38 [error] Failed to create volume snapshot                                                                             00:00:02
     2016-10-19 12:02:40 [error] Child execution has failed. Exit code: [1].
     2016-10-19 12:02:40 [error] Failed to load module [veeamsnap] with parameters [deferiocache=0 debuglogging=0].
     2016-10-19 12:02:40 [error] Failed to perform backup


i have attached my logs at http://jmp.sh/JPQx0ib

Upon reviewing the logs i notice the following errors:
Code: Select all
[19.10.2016 11:20:37] <140283452159744> lpbcore| ERR |Child execution has failed. Exit code: [1].
[19.10.2016 11:20:37] <140283452159744> lpbcore| >>  |--tr:Failed to execute [modprobe].
[19.10.2016 11:20:37] <140283452159744> lpbcore| >>  |Failed to load module [veeamsnap] with parameters [deferiocache=0 debuglogging=0].
[19.10.2016 11:20:37] <140283452159744> lpbcore| >>  |--tr:Unable to create snapshot.
[19.10.2016 11:20:37] <140283452159744> lpbcore| >>  |--tr:Failed to execute method [0] for class [N10lpbcorelib11interaction9proxystub21CResourcesServiceStubE].
[19.10.2016 11:20:37] <140283452159744> lpbcore| >>  |An exception was thrown from thread [140283452159744].


I have tried uninstalling and reinstalling Veeam and Veeamsnap and updating the necessary dependencies.

thanks in advance
bdleo
Novice
 
Posts: 3
Liked: never
Joined: Wed Oct 19, 2016 7:59 pm

Re: Backing up to QNAP NAS

Veeam Logoby vmniels » Thu Oct 20, 2016 6:57 am

What is the output if you do modprobe veeamsnap and then lsmod | grep veeam ?

Seems the installation of the kernel module failed and therefor it won't work.
VCP-DCV
Veeam Certified Engineer
http://foonet.be
vmniels
Veeam Software
 
Posts: 1444
Liked: 319 times
Joined: Mon Jul 15, 2013 11:09 am
Full Name: Niels Engelen

Re: Backing up to QNAP NAS

Veeam Logoby bdleo » Fri Oct 21, 2016 4:29 pm

Code: Select all
[root@eclipsetest ~]# lsmod | grep veeam
[root@eclipsetest ~]# modprobe veeamsnap
FATAL: Module veeamsnap not found.
[root@eclipsetest ~]#


I figured that the modprobe module was missing, when i navigate to /etc/modprobe.d
i can not find 10-unsupported-modules.conf How can i install modprobe?
bdleo
Novice
 
Posts: 3
Liked: never
Joined: Wed Oct 19, 2016 7:59 pm

Re: Backing up to QNAP NAS

Veeam Logoby Mike Resseler » Sun Oct 23, 2016 8:09 am

Hi,

The Veeamsnap module seems not to be installed... Could you try to install the solution again following the instructions here: https://www.veeam.com/blog/veeam-backup ... lable.html

Is it possible that you installed the veeam-...rpm package and not the veeamsnap-...rpm package which should have been done first?

Thanks
Mike
Mike Resseler
Veeam Software
 
Posts: 2986
Liked: 354 times
Joined: Fri Feb 08, 2013 3:08 pm
Location: Belgium, the land of the fries, the beer, the chocolate and the diamonds...
Full Name: Mike Resseler

Re: Backing up to QNAP NAS

Veeam Logoby bdleo » Mon Oct 24, 2016 9:49 pm

Fixed the issue.

After uninstalling veeam and veeamsnap, i re-installed kernel-devel and then was able to successfully install veemsnap.

Thanks!
bdleo
Novice
 
Posts: 3
Liked: never
Joined: Wed Oct 19, 2016 7:59 pm

Re: Backing up to QNAP NAS

Veeam Logoby Mike Resseler » Tue Oct 25, 2016 6:57 am

Interesting...

So you actually had installed Veeamsnap first. But to get it fixed, you needed to reinstall kernel-devel... Where there are other packages that didn't work? I wonder if it was Veeam that did something wrong the first time you installed or it was already in a bad shape before that...

thanks for coming back to us with the solution!

Mike
Mike Resseler
Veeam Software
 
Posts: 2986
Liked: 354 times
Joined: Fri Feb 08, 2013 3:08 pm
Location: Belgium, the land of the fries, the beer, the chocolate and the diamonds...
Full Name: Mike Resseler

Re: Backing up to QNAP NAS

Veeam Logoby PTide » Tue Oct 25, 2016 10:26 am

Since kernel-devel is needed to compile kernel modules I suspect that the kernel module could not be compiled properly during the first attempt due to some problems with the kernel-devel package (wrong version for example) that is why reinstallation did the trick.
PTide
Veeam Software
 
Posts: 2886
Liked: 236 times
Joined: Tue May 19, 2015 1:46 pm


Return to Veeam Agent for Linux



Who is online

Users browsing this forum: Google Feedfetcher and 4 guests