backup to 9.5 fails at 99% [error] read: Connection timed o

Backup agent for Linux servers and workstations on-premises or in the public cloud

backup to 9.5 fails at 99% [error] read: Connection timed o

Veeam Logoby bkc » Fri Dec 16, 2016 11:12 pm

47 minutes into a backup job storing to a 9.5 repo, 99% complete, I see this

Veeam Agent for Linux [ bob2 ]


Backup 99% Status: Failed



Summary Data

Duration: 00:47:42 Processed: 142.3 GB (99%)
Processing rate: 52 MB/s Read: 142.3 GB
Bottleneck: Network Transferred: 75.7 GB (1.9x)

Time Action Duration

17:15:58 Job bob2-us-teamer started at 2016-12-16 17:15:58 EST
17:15:59 Waiting for backup infrastructure resources availability 00:00:10
17:16:09 Preparing to backup
17:16:11 Creating volume snapshot 00:00:01
17:16:12 Starting full backup to [vmteamer]us-backup-on-orwell
17:16:19 Backed up sda 10.2 GB at 32.0 MB/s 00:05:26
17:21:56 Backed up VG 132.1 GB at 54.8 MB/s 00:41:09
18:03:39 [error] Failed to perform backup
18:03:39 [error] read: Connection timed out


I will pm a link to logs to PTide
bkc
Influencer
 
Posts: 19
Liked: 3 times
Joined: Tue Dec 21, 2010 10:31 pm
Full Name: brad clements

Re: backup to 9.5 fails at 99% [error] read: Connection tim

Veeam Logoby vmniels » Sat Dec 17, 2016 9:26 am

Could you tell a bit more about the target and job settings ?

Did you retry the job and did it fail again?
VCP-DCV
Veeam Certified Engineer
http://foonet.be
vmniels
Veeam Software
 
Posts: 1505
Liked: 325 times
Joined: Mon Jul 15, 2013 11:09 am
Full Name: Niels Engelen

Re: backup to 9.5 fails at 99% [error] read: Connection tim

Veeam Logoby PTide » Sat Dec 17, 2016 12:50 pm

Please open a support case and post your case ID (BTW did you do that the "invalid snapshot configuration issue?) - we'd like to take a closer look at your setup. Also please collect VBR logs as well - those will be required too.

Thank you
PTide
Veeam Software
 
Posts: 3019
Liked: 246 times
Joined: Tue May 19, 2015 1:46 pm

Re: backup to 9.5 fails at 99% [error] read: Connection tim

Veeam Logoby bkc » Sat Dec 17, 2016 8:35 pm

I only have Veeam B&R 9.5 license, not Veeam Agent for Linux license.

Don't I need the later to open a case about Veeam Agent for Linux?


And no, I did not open a formal case for the 'invalid snapshot' error because I do not have a license for Veeam Agent for Linx
bkc
Influencer
 
Posts: 19
Liked: 3 times
Joined: Tue Dec 21, 2010 10:31 pm
Full Name: brad clements

Re: backup to 9.5 fails at 99% [error] read: Connection tim

Veeam Logoby PTide » Sat Dec 17, 2016 8:44 pm

Those users who don't have license installed are still eligible for best-effort support. Both of your issues are subjects for a deeper investigation, so feel free to submit a case. Should you have any technical difficulties while opening the case please let me know.

Thanks
PTide
Veeam Software
 
Posts: 3019
Liked: 246 times
Joined: Tue May 19, 2015 1:46 pm

Re: backup to 9.5 fails at 99% [error] read: Connection tim

Veeam Logoby bkc » Mon Dec 19, 2016 3:13 pm

How do I get the logs for this job out of VBR?

I can see the Linux Agent Backup job listed in the console under 'Jobs', but when I use the support wizard to export logs, the job is not listed.
bkc
Influencer
 
Posts: 19
Liked: 3 times
Joined: Tue Dec 21, 2010 10:31 pm
Full Name: brad clements

Re: backup to 9.5 fails at 99% [error] read: Connection tim

Veeam Logoby PTide » Mon Dec 19, 2016 4:13 pm

Just collect all VBR logs for the period when the Agent job has failed.
PTide
Veeam Software
 
Posts: 3019
Liked: 246 times
Joined: Tue May 19, 2015 1:46 pm

Re: backup to 9.5 fails at 99% [error] read: Connection tim

Veeam Logoby bkc » Wed Dec 21, 2016 9:48 pm

I ran the backup job again, storing to B&R repository, and it did not fail this time.

Then I ran the job again a couple hours later, it did an incremental and worked w/o fail.

I think we can call this failure a glitch. I will report back if it fails again.
bkc
Influencer
 
Posts: 19
Liked: 3 times
Joined: Tue Dec 21, 2010 10:31 pm
Full Name: brad clements

Re: backup to 9.5 fails at 99% [error] read: Connection tim

Veeam Logoby PTide » Wed Dec 21, 2016 9:54 pm

Great news! Although it works fine for now it'd be great if you provided us with VBR logs so QA team could make sure that it's really a glitch.

Thanks
PTide
Veeam Software
 
Posts: 3019
Liked: 246 times
Joined: Tue May 19, 2015 1:46 pm

Re: backup to 9.5 fails at 99% [error] read: Connection tim

Veeam Logoby bkc » Fri Dec 23, 2016 2:55 pm 1 person likes this post

Today's backup also ran w/o error.

On Wednesday of this week IT guys found and fixed a big packet loss problem on the network I was using for the first backup. They said it was up to 36% packet loss through the switch I was using to reach VBR server.

That makes me think the connection timed out error really was a networking issue last Friday.
bkc
Influencer
 
Posts: 19
Liked: 3 times
Joined: Tue Dec 21, 2010 10:31 pm
Full Name: brad clements


Return to Veeam Agent for Linux



Who is online

Users browsing this forum: No registered users and 6 guests