Standalone backup agent for Linux servers and workstations on-premises or in the public cloud
Post Reply
RogerMialkowski
Lurker
Posts: 2
Liked: 1 time
Joined: Apr 15, 2016 6:41 pm
Full Name: Roger Mialkowski
Contact:

Error after upgrading CentOS 8.0 to 8.1

Post by RogerMialkowski » Jan 18, 2020 4:54 pm

Hello all,

I have a dev VM that I upgraded to the newly released CentOS 8.1 from CentOS 8.0 and Veeam is having trouble making a snapshot. After I saw the error, I did a "dnf reinstall veeam" and "dnf reinstall kmod-veeamsnap" but that didn't seem to help. I have not tried removing Veeam completely and installing from scratch since that may reset my existing backups and settings. Here's the log in case there are any hints as to what may be the issue:

Code: Select all

[18.01.2020 11:38:57] <140639752668928> lpbcore| [1] LVM volume groups were detected.
[18.01.2020 11:38:57] <140639752668928> lpbcore| Enumerating BTRFS subvolumes...
[18.01.2020 11:38:57] <140639752668928> lpbcore| [0] BTRFS subvolumes were detected.
[18.01.2020 11:38:57] <140639752668928> lpbcore| WARN|Snapshot storage type by default is stretch.
[18.01.2020 11:38:57] <140639752668928> vsnap  | Checking whether veeamsnap kernel module is loaded.
[18.01.2020 11:38:57] <140639752668928> vsnap  | Module is not loaded.
[18.01.2020 11:38:57] <140639752668928> vsnap  | Checking the compatibility of the kernel module with others
[18.01.2020 11:38:57] <140639752668928> vsnap  | Loading kernel module veeamsnap with parameters [zerosnapdata=1 debuglogging=0 snapstore_block_size_pow=14 change_tracking_block_size_pow=18 logdir=/var/log/veeam fixflags=0].
[18.01.2020 11:38:57] <140639752668928>        |   Arguments: [modprobe veeamsnap zerosnapdata=1 debuglogging=0 snapstore_block_size_pow=14 change_tracking_block_size_pow=18 logdir=/var/log/veeam fixflags=0].
[18.01.2020 11:38:57] <140639752668928> vsnap  | Loading kernel module veeamsnap with parameters [zerosnapdata=1 debuglogging=0 snapstore_block_size_pow=14 change_tracking_block_size_pow=18 logdir=/var/log/veeam fixflags=0]. Failed.
[18.01.2020 11:38:57] <140639752668928> lpbcore| ERR |Snapshot creation operation has failed.
[18.01.2020 11:38:57] <140639752668928> lpbcore| >>  |Child execution has failed. Exit code: [1].
[18.01.2020 11:38:57] <140639752668928> lpbcore| >>  |--tr:Failed to execute [modprobe].
[18.01.2020 11:38:57] <140639752668928> lpbcore| >>  |Failed to load module [veeamsnap] with parameters [zerosnapdata=1 debuglogging=0 snapstore_block_size_pow=14 change_tracking_block_size_pow=18 logdir=/var/log/veeam fixflags=0].
[18.01.2020 11:38:57] <140639752668928> lpbcore| >>  |An exception was thrown from thread [140639752668928].
[18.01.2020 11:38:57] <140639752668928>        | Thread finished. Role: 'snapshot operation'.
[18.01.2020 11:38:57] <140640130717440> lpbcore| ERR |Child execution has failed. Exit code: [1].
[18.01.2020 11:38:57] <140640130717440> lpbcore| >>  |--tr:Failed to execute [modprobe].
[18.01.2020 11:38:57] <140640130717440> lpbcore| >>  |Failed to load module [veeamsnap] with parameters [zerosnapdata=1 debuglogging=0 snapstore_block_size_pow=14 change_tracking_block_size_pow=18 logdir=/var/log/veeam fixflags=0].
[18.01.2020 11:38:57] <140640130717440> lpbcore| >>  |--tr:Failed to finish snapshot creation process.
[18.01.2020 11:38:57] <140640130717440> lpbcore| >>  |--tr:Failed to execute method [1] for class [lpbcorelib::interaction::proxystub::CSnapshotOperationStub].
[18.01.2020 11:38:57] <140640130717440> lpbcore| >>  |An exception was thrown from thread [140639752668928].
[18.01.2020 11:38:59] <140640130717440> lpbcore| Starting proxystub protocol dispatch loop. ok.
[18.01.2020 11:38:59] <140640130717440>        | Closing socket device.
[18.01.2020 11:38:59] <140640130717440>        | Thread finished. Role: 'peer local sock peer'.
[18.01.2020 11:38:59] <140639769454336> lpbcore| Manager process [4970] has been shutdown.
[18.01.2020 11:38:59] <140639769454336>        | Thread finished. Role: 'Manager process [4970] shutdown handler.'.
[18.01.2020 11:38:59] <140640122324736> lpbcore| Cleaning up resources for job process [4970].
[18.01.2020 11:38:59] <140639761061632> lpbcore| ERR |Backup job has failed.
[18.01.2020 11:38:59] <140639761061632> lpbcore| >>  |Child execution has failed. Exit code: [1].
[18.01.2020 11:38:59] <140639761061632> lpbcore| >>  |--tr:Failed to execute [modprobe].
[18.01.2020 11:38:59] <140639761061632> lpbcore| >>  |Failed to load module [veeamsnap] with parameters [zerosnapdata=1 debuglogging=0 snapstore_block_size_pow=14 change_tracking_block_size_pow=18 logdir=/var/log/veeam fixflags=0].
[18.01.2020 11:38:59] <140639761061632> lpbcore| >>  |--tr:Failed to finish snapshot creation process.
[18.01.2020 11:38:59] <140639761061632> lpbcore| >>  |--tr:Failed to execute method [1] for class [lpbcorelib::interaction::proxystub::CSnapshotOperationStub].
[18.01.2020 11:38:59] <140639761061632> lpbcore| >>  |--tr:Failed to create volume snapshot.
[18.01.2020 11:38:59] <140639761061632> lpbcore| >>  |Backup job has failed.
[18.01.2020 11:38:59] <140639761061632> lpbcore| >>  |An exception was thrown from thread [140640130717440].
[18.01.2020 11:38:59] <140639761061632> lpbcore| Job can not be retried. Retry is disabled.
[18.01.2020 11:38:59] <140639761061632>        | Thread finished. Role: 'backup job retry handler'.
[18.01.2020 11:38:59] <140639777847040>        | Closing socket device.
[18.01.2020 11:43:07] <140640147502848> lpbcore| Starting proxystub protocol dispatch loop. ok.
[18.01.2020 11:43:07] <140640147502848>        | Closing socket device.
[18.01.2020 11:43:07] <140640147502848>        | Thread finished. Role: 'peer local sock peer'.
Thanks,
Roger

Ge0rge
Novice
Posts: 5
Liked: 1 time
Joined: Nov 08, 2019 7:07 am
Contact:

Re: Error after upgrading CentOS 8.0 to 8.1

Post by Ge0rge » Jan 19, 2020 9:10 am

same problem here as well

Mildur
Service Provider
Posts: 100
Liked: 31 times
Joined: May 13, 2017 4:51 pm
Contact:

Re: Error after upgrading CentOS 8.0 to 8.1

Post by Mildur » Jan 19, 2020 4:36 pm

CentOS 8.* is not supported.
You have to wait for veeam support of this OS Version.

Only CentOS 6.0 – 7.74 is official supported.
https://helpcenter.veeam.com/docs/agent ... tml?ver=30

marcoos
Lurker
Posts: 1
Liked: 2 times
Joined: Jan 20, 2020 5:56 pm
Contact:

Re: Error after upgrading CentOS 8.0 to 8.1

Post by marcoos » Jan 20, 2020 6:08 pm 2 people like this post

Temporarily switching to the previous kernel fixes the operation of veeam agent in Centos 8.1

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest