error during install veeam-1.0.0.499-1.el6.i386.rpm

Backup agent for Linux servers and workstations on-premises or in the public cloud

error during install veeam-1.0.0.499-1.el6.i386.rpm

Veeam Logoby baber » Tue Jul 26, 2016 9:14 am

i want install veeam agent for linux and appear this error

rpm -ivh veeam-1.0.0.499-1.el6.i386.rpm
Preparing... ########################################### [100%]
1:veeam ########################################### [100%]
Starting veeamservice: /usr/sbin/veeamservice: error while loading shared libraries: libblkid.so.1: cannot open shared object file: No such file or directory
[FAILED]
baber
Enthusiast
 
Posts: 78
Liked: never
Joined: Thu Nov 21, 2013 12:02 pm
Full Name: Babak Saedi nejad

Re: error during install veeam-1.0.0.499-1.el6.i386.rpm

Veeam Logoby vmniels » Tue Jul 26, 2016 9:15 am

Can you try the following:
Code: Select all
yum install libblkid-devel


And then try to start the service again?
VCP-DCV
Veeam Certified Engineer
http://foonet.be
vmniels
Veeam Software
 
Posts: 1440
Liked: 318 times
Joined: Mon Jul 15, 2013 11:09 am
Full Name: Niels Engelen

Re: error during install veeam-1.0.0.499-1.el6.i386.rpm

Veeam Logoby baber » Tue Jul 26, 2016 9:23 am

vmniels wrote:Can you try the following:
Code: Select all
yum install libblkid-devel


And then try to start the service again?


thsnks it has been successfully installed and this message appear :

rpm -ivh veeam-1.0.0.499-1.el6.i386.rpm
Preparing... ########################################### [100%]
package veeam-1.0.0.499-1.el6.i386 is already installed
You have new mail in /var/spool/mail/root
[root@redhat rpm]# veeam
veeam: error while loading shared libraries: libfuse.so.2: cannot open shared object file: No such file or directory


veeam can not run
baber
Enthusiast
 
Posts: 78
Liked: never
Joined: Thu Nov 21, 2013 12:02 pm
Full Name: Babak Saedi nejad

Re: error during install veeam-1.0.0.499-1.el6.i386.rpm

Veeam Logoby vmniels » Tue Jul 26, 2016 9:27 am

It seems you are missing quite some development libraries.

For libfuse this should be:
Code: Select all
yum install  fuse fuse-devel


Please take a look at the list below and make sure you have these packages installed or else veeam won't run.
Software Dependencies
Protected Linux installation must have the following components installed:
• dkms*
• gcc
• make
• perl
• kernel-headers**
• kernel-devel**
• libudev
• libacl
• libattr
• lvm2
• libfuse
VCP-DCV
Veeam Certified Engineer
http://foonet.be
vmniels
Veeam Software
 
Posts: 1440
Liked: 318 times
Joined: Mon Jul 15, 2013 11:09 am
Full Name: Niels Engelen

Re: error during install veeam-1.0.0.499-1.el6.i386.rpm

Veeam Logoby baber » Tue Jul 26, 2016 9:32 am

vmniels wrote:It seems you are missing quite some development libraries.

For libfuse this should be:
Code: Select all
yum install  fuse fuse-devel


Please take a look at the list below and make sure you have these packages installed or else veeam won't run.
Software Dependencies
Protected Linux installation must have the following components installed:
• dkms*
• gcc
• make
• perl
• kernel-headers**
• kernel-devel**
• libudev
• libacl
• libattr
• lvm2
• libfuse


these packages has been installed but not work

rpm -qa fuse*
fuse-devel-2.8.3-4.el6.x86_64
fuse-libs-2.8.3-4.el6.x86_64
fuse-libs-2.8.3-4.el6.i686
fuse-2.8.3-4.el6.x86_64
fuse-devel-2.8.3-4.el6.i686
[root@redhat rpm]# veeam
veeam: error while loading shared libraries: libacl.so.1: cannot open shared object file: No such file or directory
baber
Enthusiast
 
Posts: 78
Liked: never
Joined: Thu Nov 21, 2013 12:02 pm
Full Name: Babak Saedi nejad

Re: error during install veeam-1.0.0.499-1.el6.i386.rpm

Veeam Logoby vmniels » Tue Jul 26, 2016 9:39 am

The list states you need libacl as well which you are missing.
Code: Select all
yum install libacl-devel libattr-devel libudevel
VCP-DCV
Veeam Certified Engineer
http://foonet.be
vmniels
Veeam Software
 
Posts: 1440
Liked: 318 times
Joined: Mon Jul 15, 2013 11:09 am
Full Name: Niels Engelen

Re: error during install veeam-1.0.0.499-1.el6.i386.rpm

Veeam Logoby baber » Tue Jul 26, 2016 9:43 am

vmniels wrote:The list states you need libacl as well which you are missing.
Code: Select all
yum install libacl-devel libattr-devel libudevel


after install and run veeam command this error appear

[root@redhat rpm]# veeam
veeam: error while loading shared libraries: libpanel.so.5: cannot open shared object file: No such file or directory
baber
Enthusiast
 
Posts: 78
Liked: never
Joined: Thu Nov 21, 2013 12:02 pm
Full Name: Babak Saedi nejad

Re: error during install veeam-1.0.0.499-1.el6.i386.rpm

Veeam Logoby vmniels » Tue Jul 26, 2016 9:45 am

Try the following:
Code: Select all
yum groupinstall "Development tools"


Basically you need the development packages as well for any of the missing libraries.
VCP-DCV
Veeam Certified Engineer
http://foonet.be
vmniels
Veeam Software
 
Posts: 1440
Liked: 318 times
Joined: Mon Jul 15, 2013 11:09 am
Full Name: Niels Engelen

Re: error during install veeam-1.0.0.499-1.el6.i386.rpm

Veeam Logoby baber » Tue Jul 26, 2016 10:05 am

vmniels wrote:Try the following:
Code: Select all
yum groupinstall "Development tools"


Basically you need the development packages as well for any of the missing libraries.

all of these packages has been installed but veeam command not ework


[root@redhat rpm]# veeam
veeam: error while loading shared libraries: libpanel.so.5: cannot open shared object file: No such file or directory
You have new mail in /var/spool/mail/root
baber
Enthusiast
 
Posts: 78
Liked: never
Joined: Thu Nov 21, 2013 12:02 pm
Full Name: Babak Saedi nejad

Re: error during install veeam-1.0.0.499-1.el6.i386.rpm

Veeam Logoby vmniels » Tue Jul 26, 2016 10:07 am

Try installing libncurses-dev as package.
VCP-DCV
Veeam Certified Engineer
http://foonet.be
vmniels
Veeam Software
 
Posts: 1440
Liked: 318 times
Joined: Mon Jul 15, 2013 11:09 am
Full Name: Niels Engelen

Re: error during install veeam-1.0.0.499-1.el6.i386.rpm

Veeam Logoby baber » Tue Jul 26, 2016 10:51 am

vmniels wrote:Try installing libncurses-dev as package.


i download ncurses-devel-6.0-309.22.x86_64.rpm
but when want install appear this message attached pic

[img]
https://s31.postimg.org/rfc7rrd2z/err.jpg
[/img]

how can solve that ?
baber
Enthusiast
 
Posts: 78
Liked: never
Joined: Thu Nov 21, 2013 12:02 pm
Full Name: Babak Saedi nejad

Re: error during install veeam-1.0.0.499-1.el6.i386.rpm

Veeam Logoby vmniels » Tue Jul 26, 2016 10:53 am

What if you install via yum? What the error specificly means I can't say. Might be a broken download.

Yum install libncurses-dev should work or "yum install libncurses-devel"
VCP-DCV
Veeam Certified Engineer
http://foonet.be
vmniels
Veeam Software
 
Posts: 1440
Liked: 318 times
Joined: Mon Jul 15, 2013 11:09 am
Full Name: Niels Engelen

Re: error during install veeam-1.0.0.499-1.el6.i386.rpm

Veeam Logoby PTide » Tue Jul 26, 2016 11:22 am

Hi,

I'm curios if the installation of veeamsnap package went OK? Did you install it using rpm or yum? If the former then please try to reinstall it with the usage of yum - it should pull all needed packages automatically.

Thanks
PTide
Veeam Software
 
Posts: 2884
Liked: 236 times
Joined: Tue May 19, 2015 1:46 pm

Re: error during install veeam-1.0.0.499-1.el6.i386.rpm

Veeam Logoby sg_sc » Tue Jul 26, 2016 10:36 pm

might I suggest:
Code: Select all
cd /path/to/
yum reinstall veeamsnap*.rpm
yum reinstall veeam-*.rpm
When using yum to install a local RPM file it will try to install the dependencies automatically.
sg_sc
Enthusiast
 
Posts: 35
Liked: 5 times
Joined: Tue Mar 29, 2016 4:22 pm
Full Name: sg_sc

Re: error during install veeam-1.0.0.499-1.el6.i386.rpm

Veeam Logoby baber » Wed Jul 27, 2016 5:30 am

thanks but my big problem is my server don't have internet connection and it can not access to internet now have to install manually packages
baber
Enthusiast
 
Posts: 78
Liked: never
Joined: Thu Nov 21, 2013 12:02 pm
Full Name: Babak Saedi nejad

Next

Return to Veeam Agent for Linux



Who is online

Users browsing this forum: No registered users and 2 guests