Backup agent for Linux servers and workstations on-premises or in the public cloud
romain1985
Lurker
Posts: 2
Liked: never
Joined: Jun 23, 2016 9:58 pm
Contact:

Failed to get whole disk by device number

Post by romain1985 » Jun 23, 2016 10:08 pm

Hello,
I installed Veeam agent 1.0.0.499 (32 bits, i386) to my personal OpenVZ (vps), Debian 7 .

I press [C] to create my first backup job and I get this error message :
No such file or directory
Failed to get whole disk by device number [243:136]

Do you have an idea to resolve this issue ?

Regards,
Romain

vmniels
Veeam Software
Posts: 1969
Liked: 430 times
Joined: Jul 15, 2013 11:09 am
Full Name: Niels Engelen
Contact:

Re: Failed to get whole disk by device number

Post by vmniels » Jun 24, 2016 7:13 am

This is related to OpenVZ way of creating the containers. Certain folders are linked to the host OS such as /bin, /usr/bin,... and we depend on certain things (I guess in this case /dev) which can't be read.
VCP-DCV
Veeam Certified Architect (VMCA)
http://foonet.be

romain1985
Lurker
Posts: 2
Liked: never
Joined: Jun 23, 2016 9:58 pm
Contact:

Re: Failed to get whole disk by device number

Post by romain1985 » Jun 24, 2016 7:45 pm

Hello,
That mean it is impossible to use Veeam to backup OpenVZ container ?

Thanks.

vmniels
Veeam Software
Posts: 1969
Liked: 430 times
Joined: Jul 15, 2013 11:09 am
Full Name: Niels Engelen
Contact:

Re: Failed to get whole disk by device number

Post by vmniels » Jun 24, 2016 10:24 pm

Additional testing will be needed to confirm if it will work or not. Thanks for the feedback already!
VCP-DCV
Veeam Certified Architect (VMCA)
http://foonet.be

hawkeye80
Novice
Posts: 7
Liked: 2 times
Joined: Mar 18, 2015 8:12 am
Contact:

Re: Failed to get whole disk by device number

Post by hawkeye80 » Jul 15, 2016 9:07 am

Got a similar error on initial configuration.

Code: Select all

Failed to get whole disk by device number [2:12].
Test system is a Oracle Linux 6 VM with UEK kernel and LVM configured.

PTide
Veeam Software
Posts: 4247
Liked: 349 times
Joined: May 19, 2015 1:46 pm
Contact:

Re: Failed to get whole disk by device number

Post by PTide » Jul 15, 2016 10:05 am

Hi,

Please post a download link to an archive with logs. Also please post the outputs of dmesg -T and lsblk.

Thak you

hawkeye80
Novice
Posts: 7
Liked: 2 times
Joined: Mar 18, 2015 8:12 am
Contact:

Re: Failed to get whole disk by device number

Post by hawkeye80 » Jul 15, 2016 10:54 am

Hi PTide,

please find the logs and outputs here https://file.io/01WACh
dmesg -T is not available on OEL6, so I've cleared the dmesg, rebooted and tried veeam again. So the entries are all fresh.

Kind regards,
Daniel

pguima
Novice
Posts: 3
Liked: never
Joined: Jul 28, 2016 7:17 am
Full Name: Luiz Guimaraes
Contact:

Re: Failed to get whole disk by device number

Post by pguima » Jul 28, 2016 7:42 am

Also receiving similar error CentOS 7 running on openVZ.

PTide
Veeam Software
Posts: 4247
Liked: 349 times
Joined: May 19, 2015 1:46 pm
Contact:

Re: Failed to get whole disk by device number

Post by PTide » Jul 28, 2016 12:43 pm

Hi,
Also receiving similar error CentOS 7 running on openVZ.
Does it fail when you try to backup the openVZ host, or it fails if you start veeam inside the container? If the former then please provide a detailed description of the job settings, host configuration. Please include the exact error message, dmesg -T output and lsblk -af output, also please share an archive that contains /var/log/veeam directory.

Thank you.

pguima
Novice
Posts: 3
Liked: never
Joined: Jul 28, 2016 7:17 am
Full Name: Luiz Guimaraes
Contact:

Re: Failed to get whole disk by device number

Post by pguima » Jul 31, 2016 1:40 am

Unfortunately, my dmesg log are blank and the output for the command are null. Please see the veeam logs, here https://file.io/JpHnFY

PTide
Veeam Software
Posts: 4247
Liked: 349 times
Joined: May 19, 2015 1:46 pm
Contact:

Re: Failed to get whole disk by device number

Post by PTide » Aug 03, 2016 12:01 pm

<...>and the output for the command are null
What does lsblk -af shows? Also I see /dev/simfs in the log, are you trying to run VAL inside an openVZ container?

Thanks

pguima
Novice
Posts: 3
Liked: never
Joined: Jul 28, 2016 7:17 am
Full Name: Luiz Guimaraes
Contact:

Re: Failed to get whole disk by device number

Post by pguima » Jan 27, 2017 8:34 am

Mostly likely, I have running on a hosted VPS, I installed the release version but still have issues. This is what I get now
boost::filesystem::directory_iterator::construct: No such file or directory: "/sys/block"

PTide
Veeam Software
Posts: 4247
Liked: 349 times
Joined: May 19, 2015 1:46 pm
Contact:

Re: Failed to get whole disk by device number

Post by PTide » Jan 27, 2017 9:01 am

Hi,

VAL is not designed to operate inside a container. Anyway please provide logs (use 'M' key on the main screen). Also could tell who is your hoster, please?

Thanks

vchrizz
Novice
Posts: 4
Liked: never
Joined: Feb 13, 2017 12:27 pm
Full Name: Christoph Loesch
Contact:

Re: Failed to get whole disk by device number

Post by vchrizz » Feb 13, 2017 1:31 pm

hi,

im getting the same error when using the linux agent within an openvz container.
the mountpoint /sys is mounted and available, but /sys/block is not available due to the nature of (openvz-) containers.
so i guess the agent tries to access physical disks which are not available.

are there any plans for the linux agent to also back up containers in another way than accessing the physical disk(s)?

thanks

PTide
Veeam Software
Posts: 4247
Liked: 349 times
Joined: May 19, 2015 1:46 pm
Contact:

Re: Failed to get whole disk by device number

Post by PTide » Feb 13, 2017 3:58 pm

Hi,

No, currently we don't have that functionality on the list due to a low demand. Anyway your feedback is noted, thank you!

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests