Failed to get whole disk by device number

Backup agent for Linux servers and workstations on-premises or in the public cloud

Failed to get whole disk by device number

Veeam Logoby MyKey0815 » Thu Aug 25, 2016 1:16 pm

Hello,

I will test a UCS (Univention coporate Server 4.1) with Veeam Linux Backup. So i install in Virtualbox 5.0 a VM with UCS. In this UCS Setup I want to install the Veeam Backup for Linux Beta 499 (BTW: License is still valid only 7 days). The Install was working fine. But now I want to create a Backup Job.

I start with the command "veeam" and then press the button "c". Then the message come up: "No such file or directory. Failed to get whole disk by device number [7:0]"

What can I do to test Veeam with UCS before i install them on my real system (UCS is installed on real machines)?

Thanks for your reply
Michael
MyKey0815
Enthusiast
 
Posts: 33
Liked: 3 times
Joined: Thu Aug 25, 2016 12:54 pm
Full Name: Michael Kolowicz

Re: Failed to get whole disk by device number

Veeam Logoby vmniels » Thu Aug 25, 2016 3:37 pm

Could you post output on the following:
lsblk -a
dmesg -T
And the veeam logs found under /var/log (you can upload them to a file sharing platform)
VCP-DCV
Veeam Certified Engineer
http://foonet.be
vmniels
Veeam Software
 
Posts: 1444
Liked: 319 times
Joined: Mon Jul 15, 2013 11:09 am
Full Name: Niels Engelen

Re: Failed to get whole disk by device number

Veeam Logoby MyKey0815 » Thu Aug 25, 2016 4:03 pm

lsblk -a
Code: Select all
NAME                     MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda                        8:0    0  40,8G  0 disk
ââsda1                     8:1    0   487M  0 part /boot
ââsda2                     8:2    0     1K  0 part
ââsda5                     8:5    0  40,3G  0 part
  ââvg_ucs-root (dm-0)   254:0    0  37,7G  0 lvm  /
  ââvg_ucs-swap_1 (dm-1) 254:1    0   2,6G  0 lvm  [SWAP]
sr0                       11:0    1   1,2G  0 rom


The files you found on for dmesg and veeam.log you found on https://we.tl/ai7rlFCIUA
MyKey0815
Enthusiast
 
Posts: 33
Liked: 3 times
Joined: Thu Aug 25, 2016 12:54 pm
Full Name: Michael Kolowicz

Re: Failed to get whole disk by device number

Veeam Logoby MyKey0815 » Fri Aug 26, 2016 4:38 pm

I have try to install on physical Hardware. Same error if i use UCS 4.1-3 (based on Wheezy - Debian 7)

I try an installation from USB-Stick and from DVD - same result: "No such file or directory. Failed to get whole disk by device number [7:0]"

Could it be a problem with Debian 7 or the distribution UCS?
MyKey0815
Enthusiast
 
Posts: 33
Liked: 3 times
Joined: Thu Aug 25, 2016 12:54 pm
Full Name: Michael Kolowicz

Re: Failed to get whole disk by device number

Veeam Logoby vmniels » Fri Aug 26, 2016 5:01 pm

Debian 7 is fully supported. Might be related to the UCS part but looking into the logs for further info.
VCP-DCV
Veeam Certified Engineer
http://foonet.be
vmniels
Veeam Software
 
Posts: 1444
Liked: 319 times
Joined: Mon Jul 15, 2013 11:09 am
Full Name: Niels Engelen

Re: Failed to get whole disk by device number

Veeam Logoby MyKey0815 » Fri Aug 26, 2016 5:10 pm

Here a part of my log

Code: Select all
[25.08.2016 17:53:56] <140549182703360>        | Thread started. Thread id: 140549182703360, parent id: 140549216274176, role: (async) LPBConfig session (127.0.0.1:34138)
[25.08.2016 17:53:56] <140549182703360> lpbcore| LpbCfgSession: Tcp loop.
[25.08.2016 17:53:58] <140549207881472> lpbcore| WARN|Failed to get information on device [/dev/loop0].
[25.08.2016 17:53:58] <140549207881472> lpbcore| >>  |No such file or directory
[25.08.2016 17:53:58] <140549207881472> lpbcore| >>  |Failed to get whole disk by device number [7:0].
[25.08.2016 17:53:58] <140549207881472> lpbcore| ERR |No such file or directory
[25.08.2016 17:53:58] <140549207881472> lpbcore| >>  |Failed to get whole disk by device number [7:0].
[25.08.2016 17:53:58] <140549207881472> lpbcore| >>  |--tr:Failed to enumerate block devices in current system.
[25.08.2016 17:53:58] <140549207881472> lpbcore| >>  |--tr:Failed to execute method [5] for class [N10lpbcorelib11interaction9proxystub15CLpbServiceStubE].
[25.08.2016 17:53:58] <140549207881472> lpbcore| >>  |An exception was thrown from thread [698087168].
[25.08.2016 17:54:05] <140549191096064>        | Closing socket device.
[25.08.2016 17:54:05] <140549191096064>        | Thread finished. Role: '(async) LPB database session (127.0.0.1:34136)'.
MyKey0815
Enthusiast
 
Posts: 33
Liked: 3 times
Joined: Thu Aug 25, 2016 12:54 pm
Full Name: Michael Kolowicz

Re: Failed to get whole disk by device number

Veeam Logoby MyKey0815 » Mon Aug 29, 2016 3:27 pm

Hello vmniels,

dmesg -T
And the veeam logs found under /var/log (you can upload them to a file sharing platform)


did you find my files? Are the helpfull and can you give me hint what the reason for the error message is?

Thanks
Michael
MyKey0815
Enthusiast
 
Posts: 33
Liked: 3 times
Joined: Thu Aug 25, 2016 12:54 pm
Full Name: Michael Kolowicz

Re: Failed to get whole disk by device number

Veeam Logoby PTide » Mon Aug 29, 2016 4:00 pm

Hi,

Yes, I got your files however I need some clarification regarding your settings:

I start with the command "veeam" and then press the button "c". Then the message come up: "No such file or directory. Failed to get whole disk by device number [7:0]"
Do you get the error right after you press "C" button?

Was veeamsvc.log the only file in /var/log/veeam directory? If not then please archive and share the whole directory. Do you have any onboard raid device on your physical host?

Thanks
PTide
Veeam Software
 
Posts: 2886
Liked: 236 times
Joined: Tue May 19, 2015 1:46 pm

Re: Failed to get whole disk by device number

Veeam Logoby MyKey0815 » Mon Aug 29, 2016 6:47 pm

Hello,

thank you for your reply. Here my response.

1) When I press the "C" button then it take some time. I think 5 till 10 seconds and the message come up

2) I hove no other file in the log-directory (only a other directory namesd "config"). Here is the content of the veeamconfig.log
Code: Select all
[25.08.2016 18:08:47] <139869491091296>        | ====================================================================================
[25.08.2016 18:08:47] <139869491091296> lpb    | {
[25.08.2016 18:08:47] <139869491091296> lpb    |   Veeam Agent for Linux BETA (expires in 7 days): veeam.
[25.08.2016 18:08:47] <139869491091296> lpb    |   Version: 1.0.0.499
[25.08.2016 18:08:47] <139869491091296> lpb    |   PID: 4634
[25.08.2016 18:08:47] <139869491091296> lpb    |   uname
[25.08.2016 18:08:47] <139869491091296> lpb    |     sysname : Linux
[25.08.2016 18:08:47] <139869491091296> lpb    |     release : 4.1.0-ucs190-amd64
[25.08.2016 18:08:47] <139869491091296> lpb    |     version : #1 SMP Debian 4.1.6-1.190.201604142226 (2016-04-14)
[25.08.2016 18:08:47] <139869491091296> lpb    |     machine : x86_64
[25.08.2016 18:08:47] <139869491091296> lpb    | }
[25.08.2016 18:08:47] <139869491091296> lpbcore| Connecting to veeam service...
[25.08.2016 18:08:47] <139869491091296>        |   Trying to connect to the endpoint [127.0.0.1:3500]
[25.08.2016 18:08:47] <139869491091296>        |   Connection status: system:0 ( Success ).
[25.08.2016 18:08:47] <139869491091296> net    |   Sending reconnect options: [disabled].
[25.08.2016 18:08:47] <139869491091296> lpbcore|   [DEV] Created [0x27cea70]
[25.08.2016 18:08:47] <139869491091296> lpbcore| Connecting to veeam service... ok.
[25.08.2016 18:08:47] <139869491091296>        | Trying to connect to the endpoint [127.0.0.1:3500]
[25.08.2016 18:08:47] <139869491091296>        |   Connection status: system:0 ( Success ).
[25.08.2016 18:08:47] <139869491091296> net    | Sending reconnect options: [disabled].
[25.08.2016 18:08:47] <139869491091296> lpbcore| Creating DB accessor [0x27cefd0].
[25.08.2016 18:08:47] <139869491091296> lpbcore| Detecting whether we are running under recovery ISO.
[25.08.2016 18:08:47] <139869491091296> lpbcore| Recovery ISO: [0].
[25.08.2016 18:08:47] <139869491091296>        | Trying to connect to the endpoint [127.0.0.1:3500]
[25.08.2016 18:08:47] <139869491091296>        |   Connection status: system:0 ( Erfolg ).
[25.08.2016 18:08:47] <139869491091296> net    | Sending reconnect options: [disabled].
[25.08.2016 18:08:47] <139869491091296> lpbcore| Creating DB accessor [0x2da0100].
[25.08.2016 18:08:47] <139869491091296>        | Trying to connect to the endpoint [127.0.0.1:3500]
[25.08.2016 18:08:47] <139869491091296>        |   Connection status: system:0 ( Erfolg ).
[25.08.2016 18:08:47] <139869491091296> net    | Sending reconnect options: [disabled].
[25.08.2016 18:08:47] <139869491091296> lpbconf| Convert oijs to FileLevelTableUiItems.
[25.08.2016 18:08:47] <139869491091296> lpbconf| CShareRepositoryPageController::reloadPage.
[25.08.2016 18:08:47] <139869491091296> lpbconf| CShareRepositoryPageController::updateView.
[25.08.2016 18:08:47] <139869491091296> lpbconf| CLocalRepositoryPageController::reloadPage
[25.08.2016 18:08:47] <139869491091296> lpbconf| CLocalRepositoryPageController::updateView()
[25.08.2016 18:08:47] <139869491091296> lpbconf| Unable get space for path: []. reason: [Datei oder Verzeichnis nicht gefunden]
[25.08.2016 18:08:47] <139869431179008> cli    | Thread [PaintTimer thrd].
[25.08.2016 18:08:47] <139869439571712> cli    | Thread [NcEvtDispatcher].
[25.08.2016 18:08:47] <139869447964416> cli    | Thread [NcEvtQueue].
[25.08.2016 18:08:48] <139869439571712> lpbconf|   CJobWizardController::showForm
[25.08.2016 18:08:50] <139869439571712> lpbcore| WARN|Method invocation was not finalized. Method id [5]. Class: [N10lpbcorelib11interaction11ILpbServiceE]
[25.08.2016 18:08:50] <139869439571712> lpbcore| ERR |No such file or directory
[25.08.2016 18:08:50] <139869439571712> lpbcore| >>  |Failed to get whole disk by device number [7:0].
[25.08.2016 18:08:50] <139869439571712> lpbcore| >>  |--tr:Failed to enumerate block devices in current system.
[25.08.2016 18:08:50] <139869439571712> lpbcore| >>  |--tr:Failed to execute method [5] for class [N10lpbcorelib11interaction9proxystub15CLpbServiceStubE].
[25.08.2016 18:08:50] <139869439571712> lpbcore| >>  |--tr:Failed to invoke method [5] in class [N10lpbcorelib11interaction11ILpbServiceE].
[25.08.2016 18:08:50] <139869439571712> lpbcore| >>  |An exception was thrown from thread [-465389824].
[25.08.2016 18:08:50] <139869439571712> lpbconf| ERR |WelcomeController::keyPressed
[25.08.2016 18:08:50] <139869439571712> lpbconf| >>  |No such file or directory
[25.08.2016 18:08:50] <139869439571712> lpbconf| >>  |Failed to get whole disk by device number [7:0].
[25.08.2016 18:08:50] <139869439571712> lpbconf| >>  |--tr:Failed to enumerate block devices in current system.
[25.08.2016 18:08:50] <139869439571712> lpbconf| >>  |--tr:Failed to execute method [5] for class [N10lpbcorelib11interaction9proxystub15CLpbServiceStubE].
[25.08.2016 18:08:50] <139869439571712> lpbconf| >>  |An exception was thrown from thread [-465389824].
[25.08.2016 18:08:50] <139869439571712> lpbconf| ERR |No such file or directory
[25.08.2016 18:08:50] <139869439571712> lpbconf| >>  |Failed to get whole disk by device number [7:0].
[25.08.2016 18:08:50] <139869439571712> lpbconf| >>  |--tr:Failed to enumerate block devices in current system.
[25.08.2016 18:08:50] <139869439571712> lpbconf| >>  |--tr:Failed to execute method [5] for class [N10lpbcorelib11interaction9proxystub15CLpbServiceStubE].
[25.08.2016 18:08:50] <139869439571712> lpbconf| >>  |An exception was thrown from thread [-465389824].
[25.08.2016 18:08:55] <139869431179008> cli    | Thread [PaintTimer thrd]. ok.
[25.08.2016 18:08:55] <139869439571712> cli    | Thread [NcEvtDispatcher]. ok.
[25.08.2016 18:08:55] <139869447964416> cli    | Thread [NcEvtQueue]. ok.
[25.08.2016 18:08:55] <139869491091296> lpbcore| Destroying MainUi.


3) No Installation (not the VM on Virtual box or the physical PC) have a raid controller

I hope you find the answers helpfull

CU
Michael
MyKey0815
Enthusiast
 
Posts: 33
Liked: 3 times
Joined: Thu Aug 25, 2016 12:54 pm
Full Name: Michael Kolowicz

Re: Failed to get whole disk by device number

Veeam Logoby MyKey0815 » Tue Aug 30, 2016 8:42 am

Hello,

FYI: I have add a second Harddisk but the problem still exists. The message come up again.

Now I have tested to "restore" a backup (i have no one created - but i want to if the ui react fine). That works perfect. I can chose a job or can import backups by browsing a directory on the disk

I hope this additional info is helpfull to investigate the reason

CU Michael
MyKey0815
Enthusiast
 
Posts: 33
Liked: 3 times
Joined: Thu Aug 25, 2016 12:54 pm
Full Name: Michael Kolowicz

Re: Failed to get whole disk by device number

Veeam Logoby PTide » Tue Aug 30, 2016 4:17 pm

Now I have tested to "restore" a backup (i have no one created - but i want to if the ui react fine). That works perfect. I can chose a job or can import backups by browsing a directory on the disk
May I ask you how you managed to test restore and import backup if you had not created one?

Did you try to use command line interface to create a backup job?

P.S. Also please keep in mind that UCS is not Debian although it is derived from it, and we cannot guarantee that VAL will work on your installation.

Thank you
PTide
Veeam Software
 
Posts: 2886
Liked: 236 times
Joined: Tue May 19, 2015 1:46 pm

Re: Failed to get whole disk by device number

Veeam Logoby MyKey0815 » Tue Aug 30, 2016 6:01 pm 1 person likes this post

Hello,

@PTide: Thanks for you reply. 1.) In my respose i write down, that i have NO BACKUP created. But I want only to test, if the possibity to chose the option. I press the button and can select a NOT EXISTING backup
2.) The commandline i didn´t use till now. Good idea. I will it test tomorow

BTW: I have read that you release a tomorow a new version. I will wait until the release and try it again

CU
Michael
MyKey0815
Enthusiast
 
Posts: 33
Liked: 3 times
Joined: Thu Aug 25, 2016 12:54 pm
Full Name: Michael Kolowicz

Solved: Failed to get whole disk by device number

Veeam Logoby MyKey0815 » Wed Aug 31, 2016 12:19 pm 1 person likes this post

Build 678 - BETA 2 is fixing this problem on UCS. Now I can start to configure the BackupJobs

Thank you
MyKey0815
Enthusiast
 
Posts: 33
Liked: 3 times
Joined: Thu Aug 25, 2016 12:54 pm
Full Name: Michael Kolowicz

Re: Failed to get whole disk by device number

Veeam Logoby vmniels » Wed Aug 31, 2016 12:19 pm

Great to hear. Happy testing!
VCP-DCV
Veeam Certified Engineer
http://foonet.be
vmniels
Veeam Software
 
Posts: 1444
Liked: 319 times
Joined: Mon Jul 15, 2013 11:09 am
Full Name: Niels Engelen


Return to Veeam Agent for Linux



Who is online

Users browsing this forum: No registered users and 5 guests