Handling Multipath Devices

Backup agent for Linux servers and workstations on-premises or in the public cloud

Handling Multipath Devices

Veeam Logoby togenshi » Thu Dec 15, 2016 4:17 am

Hey,

I have an issue with multipath devices. When I do a "entire system" backup, it seems to proceed through the lsblk list. Unfortunately the drive is wish to be backed up can be in set up on anyone of the blk devices.
Code: Select all
root@sloth:/export# lsblk
NAME                        MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda                           8:0    0 557.8G  0 disk
├─sda1                        8:1    0   243M  0 part /boot
├─sda2                        8:2    0     1K  0 part
└─sda5                        8:5    0 557.5G  0 part
  ├─sloth--vg-root (dm-0)   252:0    0 541.5G  0 lvm  /
  └─sloth--vg-swap_1 (dm-1) 252:1    0    16G  0 lvm  [SWAP]
sdb                           8:16   0     1T  0 disk
└─sdb1                        8:17   0  1024G  0 part
sdc                           8:32   0     1T  0 disk
└─sdc1                        8:33   0  1024G  0 part
sdd                           8:48   0     1T  0 disk
└─sdd1                        8:49   0  1024G  0 part /export/san-1
sde                           8:64   0     1T  0 disk
└─sde1                        8:65   0  1024G  0 part


Code: Select all
create: 3600a09800059dbb9000002a955c35df0 undef DELL    ,MD38xxf         
size=1.0T features='0' hwhandler='0' wp=undef
|-+- policy='round-robin 0' prio=1 status=undef
| `- 2:0:0:0 sdb         8:16  undef ready running
|-+- policy='round-robin 0' prio=1 status=undef
| `- 2:0:1:0 sdc         8:32  undef ready running
|-+- policy='round-robin 0' prio=1 status=undef
| `- 2:0:2:0 sdd         8:48  undef ready running
`-+- policy='round-robin 0' prio=1 status=undef
  `- 2:0:3:0 sde         8:64  undef ready running

Code: Select all
 11:29:42        Backed up sda 245.0 MB at 56.4 MB/s                                                                      00:00:05
      11:30:28        Backed up sdb 202.2 GB at 159.0 MB/s                                                                     00:21:43
      11:53:03        [error] Backing up sdc                                                                                   00:00:02
      11:53:08        [error] Failed to perform backup
      11:53:08        [error] The specified item was already backed up or backup was not completed
      11:53:08        [error] Failed to download disk
      11:53:08        [error] read: End of file
      11:53:08        [error] Failed to upload disk
      11:53:08        [error] Agent failed to process method {DataTransfer.SyncDisk}


Any chance to make the agent multipath aware?
togenshi
Influencer
 
Posts: 22
Liked: 4 times
Joined: Mon Jul 27, 2015 1:16 am

Re: Handling Multipath Devices

Veeam Logoby PTide » Thu Dec 15, 2016 10:28 am

Hi,

Please provide logs (press M in the main menu and exports logs to an archive).

Thank you.
PTide
Veeam Software
 
Posts: 3022
Liked: 247 times
Joined: Tue May 19, 2015 1:46 pm

Re: Handling Multipath Devices

Veeam Logoby togenshi » Mon Dec 19, 2016 3:17 am

I screwed up setting up multipathing but not sure if you wish to interpret this as an error still. Waiting on maintenance window to fix multipath.
Veeam Log:

https://drive.google.com/file/d/0B46Ua4 ... sp=sharing
togenshi
Influencer
 
Posts: 22
Liked: 4 times
Joined: Mon Jul 27, 2015 1:16 am

Re: Handling Multipath Devices

Veeam Logoby PTide » Mon Dec 19, 2016 10:45 am

Do you mean that multipath had been already screwed up before you started the backup?
PTide
Veeam Software
 
Posts: 3022
Liked: 247 times
Joined: Tue May 19, 2015 1:46 pm

Re: Handling Multipath Devices

Veeam Logoby togenshi » Mon Dec 19, 2016 11:51 pm

There wasn't a profile setup for the SAN model we have and since we used UUID to mount the partitions, linux didn't care if the partition was found on drives sd[b-e].
togenshi
Influencer
 
Posts: 22
Liked: 4 times
Joined: Mon Jul 27, 2015 1:16 am

Re: Handling Multipath Devices

Veeam Logoby PTide » Tue Dec 20, 2016 6:47 pm

So does the issue persist after multipath reconfiguration?
PTide
Veeam Software
 
Posts: 3022
Liked: 247 times
Joined: Tue May 19, 2015 1:46 pm

Re: Handling Multipath Devices

Veeam Logoby togenshi » Wed Dec 21, 2016 3:36 am

Looks like the agent to picking up the devices from /dev/mapper/<id> instead of sd[b-e]. Still running the backup. I expect this should be ok.
togenshi
Influencer
 
Posts: 22
Liked: 4 times
Joined: Mon Jul 27, 2015 1:16 am

Re: Handling Multipath Devices

Veeam Logoby togenshi » Tue Jan 03, 2017 5:40 am

Issue resolved and confirmed issue is fixed.
togenshi
Influencer
 
Posts: 22
Liked: 4 times
Joined: Mon Jul 27, 2015 1:16 am

Re: Handling Multipath Devices

Veeam Logoby Mike Resseler » Tue Jan 03, 2017 5:43 am

Togenshi,

Thanks for coming back to us and confirming it is fixed. It is appreciated!
Mike Resseler
Veeam Software
 
Posts: 3165
Liked: 362 times
Joined: Fri Feb 08, 2013 3:08 pm
Location: Belgium, the land of the fries, the beer, the chocolate and the diamonds...
Full Name: Mike Resseler


Return to Veeam Agent for Linux



Who is online

Users browsing this forum: No registered users and 6 guests