install issues

Backup agent for Linux servers and workstations on-premises or in the public cloud

install issues

Veeam Logoby comwireitadam » Wed Mar 29, 2017 4:05 am

Hey Guys

Having issues installing Veeam Agent for linux.

Get the following error when running yum install veeam


Error: Package: veeamsnap-1.0.0.944-1.noarch (veeam)
Requires: dkms
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

trying to run rpm -ivh veeamsnap-1.0.0.499-1.noarch.rpm
return the following
error: open of veeamsnap-1.0.0.499-1.noarch.rpm failed: No such file or directory

uname -r = 3.10.0-514.10.2.el7.x86_64
uname - a= 3.10.0-514.10.2.el7.x86_64 #1 SMP Fri Mar 3 00:04:05 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux


where to next??
comwireitadam
Novice
 
Posts: 7
Liked: never
Joined: Wed Mar 29, 2017 4:01 am
Full Name: Adam Kangas

Re: install issues

Veeam Logoby vmniels » Wed Mar 29, 2017 10:38 am

I guess you are missing the EPEL repo. Can you try yum install epel-release ? Afterwards try again with yum install veeam as explained via the steps in https://helpcenter.veeam.com/docs/agent ... tml?ver=10.
VCP-DCV
Veeam Certified Engineer
http://foonet.be
vmniels
Veeam Software
 
Posts: 1517
Liked: 328 times
Joined: Mon Jul 15, 2013 11:09 am
Full Name: Niels Engelen

Re: install issues

Veeam Logoby PTide » Wed Mar 29, 2017 2:15 pm

Hi,

Niels is right - you need to enable EPEL repository so yum can get dkms package from there.

Code: Select all
trying to run rpm -ivh veeamsnap-1.0.0.499-1.noarch.rpm
return the following
error: open of veeamsnap-1.0.0.499-1.noarch.rpm failed: No such file or directory
I guess that's happened due to a typo - supposed to be 944.

Thanks
PTide
Veeam Software
 
Posts: 3022
Liked: 247 times
Joined: Tue May 19, 2015 1:46 pm

Re: install issues

Veeam Logoby comwireitadam » Fri Mar 31, 2017 3:53 am

so i get the following now. seems to have installed


Code: Select all
[root@xeon ~]# yum install epel-release
Loaded plugins: fastestmirror, langpacks
base                                                     | 3.6 kB     00:00
extras                                                   | 3.4 kB     00:00
rpmforge                                                 | 1.9 kB     00:00
updates                                                  | 3.4 kB     00:00
veeam                                                    | 3.3 kB     00:00
(1/2): veeam/primary_db                                    | 2.8 kB   00:01
(2/2): updates/7/x86_64/primary_db                         | 3.9 MB   00:01
Loading mirror speeds from cached hostfile
 * base: mirror.internode.on.net
 * extras: mirror.internode.on.net
 * rpmforge: mirror.as24220.net
 * updates: mirror.internode.on.net
Resolving Dependencies
--> Running transaction check
---> Package epel-release.noarch 0:7-9 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                Arch             Version         Repository        Size
================================================================================
Installing:
 epel-release           noarch           7-9             extras            14 k

Transaction Summary
================================================================================
Install  1 Package

Total download size: 14 k
Installed size: 24 k
Is this ok [y/d/N]: y
Downloading packages:
epel-release-7-9.noarch.rpm                                |  14 kB   00:00
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
Warning: RPMDB altered outside of yum.
  Installing : epel-release-7-9.noarch                                      1/1
  Verifying  : epel-release-7-9.noarch                                      1/1

Installed:
  epel-release.noarch 0:7-9

Complete!
[root@xeon ~]# rpm -ivh ./veeam-release* && yum check-update
error: ./veeam-release: not an rpm package (or package manifest):
[root@xeon ~]# dir
admin@acd.cloud      initial-setup-ks.cfg                       Public
anaconda-ks.cfg      insync-portable                            Templates
autotask_install.sh  insync-portable_1.3.8.36087_amd64.tar.bz2  veeam-release
Desktop              list.txt                                   Videos
Documents            mono.rpm                                   zcs
Downloads            Music
ifcfg-enoSTATIC      Pictures
[root@xeon ~]# cd veeam-release/
[root@xeon veeam-release]# dir
veeam-release-el7-1.0-1.i386.rpm
[root@xeon veeam-release]# rpm -ivh ./veeam-release* && yum check-update
Preparing...                          ################################# [100%]
        package veeam-release-el7-1.0-1.i386 is already installed
        file /etc/yum.repos.d/veeam.repo from install of veeam-release-el7-1.0-1                                                                                                                                                             .i386 conflicts with file from package veeam-release-el6-1.0-1.x86_64
[root@xeon veeam-release]# yum install veeam
Loaded plugins: fastestmirror, langpacks
epel/x86_64/metalink                                     | 3.4 kB     00:00
epel                                                     | 4.3 kB     00:00
(1/3): epel/x86_64/group_gz                                | 170 kB   00:00
(2/3): epel/x86_64/updateinfo                              | 764 kB   00:02
(3/3): epel/x86_64/primary_db                              | 4.6 MB   00:02
Loading mirror speeds from cached hostfile
 * base: mirror.internode.on.net
 * epel: mirror.as24220.net
 * extras: mirror.internode.on.net
 * rpmforge: mirror.as24220.net
 * updates: mirror.internode.on.net
Resolving Dependencies
--> Running transaction check
---> Package veeam.i386 0:1.0.0.944-1.el7 will be installed
--> Processing Dependency: veeamsnap = 1.0.0.944 for package: veeam-1.0.0.944-1.                                                                                                                                                             el7.i386
--> Running transaction check
---> Package veeamsnap.noarch 0:1.0.0.944-1 will be installed
--> Processing Dependency: gcc for package: veeamsnap-1.0.0.944-1.noarch
--> Processing Dependency: dkms for package: veeamsnap-1.0.0.944-1.noarch
--> Running transaction check
---> Package dkms.noarch 0:2.3-1.20161202gitde1dca9.el7 will be installed
---> Package gcc.x86_64 0:4.8.5-11.el7 will be installed
--> Processing Dependency: cpp = 4.8.5-11.el7 for package: gcc-4.8.5-11.el7.x86_                                                                                                                                                             64
--> Processing Dependency: glibc-devel >= 2.2.90-12 for package: gcc-4.8.5-11.el                                                                                                                                                             7.x86_64
--> Processing Dependency: libmpc.so.3()(64bit) for package: gcc-4.8.5-11.el7.x8                                                                                                                                                             6_64
--> Running transaction check
---> Package cpp.x86_64 0:4.8.5-11.el7 will be installed
---> Package glibc-devel.x86_64 0:2.17-157.el7_3.1 will be installed
--> Processing Dependency: glibc-headers = 2.17-157.el7_3.1 for package: glibc-d                                                                                                                                                             evel-2.17-157.el7_3.1.x86_64
--> Processing Dependency: glibc-headers for package: glibc-devel-2.17-157.el7_3                                                                                                                                                             .1.x86_64
---> Package libmpc.x86_64 0:1.0.1-3.el7 will be installed
--> Running transaction check
---> Package glibc-headers.x86_64 0:2.17-157.el7_3.1 will be installed
--> Processing Dependency: kernel-headers >= 2.2.1 for package: glibc-headers-2.                                                                                                                                                             17-157.el7_3.1.x86_64
--> Processing Dependency: kernel-headers for package: glibc-headers-2.17-157.el                                                                                                                                                             7_3.1.x86_64
--> Running transaction check
---> Package kernel-headers.x86_64 0:3.10.0-514.10.2.el7 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package           Arch      Version                           Repository  Size
================================================================================
Installing:
 veeam             i386      1.0.0.944-1.el7                   veeam       21 M
Installing for dependencies:
 cpp               x86_64    4.8.5-11.el7                      base       5.9 M
 dkms              noarch    2.3-1.20161202gitde1dca9.el7      epel        78 k
 gcc               x86_64    4.8.5-11.el7                      base        16 M
 glibc-devel       x86_64    2.17-157.el7_3.1                  updates    1.1 M
 glibc-headers     x86_64    2.17-157.el7_3.1                  updates    668 k
 kernel-headers    x86_64    3.10.0-514.10.2.el7               updates    4.8 M
 libmpc            x86_64    1.0.1-3.el7                       base        51 k
 veeamsnap         noarch    1.0.0.944-1                       veeam       73 k

Transaction Summary
================================================================================
Install  1 Package (+8 Dependent packages)

Total download size: 50 M
Installed size: 116 M
Is this ok [y/d/N]: y
Downloading packages:
warning: /var/cache/yum/x86_64/7/epel/packages/dkms-2.3-1.20161202gitde1dca9.el7                                                                                                                                                             .noarch.rpm: Header V3 RSA/SHA256 Signature, key ID 352c64e5: NOKEY
Public key for dkms-2.3-1.20161202gitde1dca9.el7.noarch.rpm is not installed
(1/9): dkms-2.3-1.20161202gitde1dca9.el7.noarch.rpm        |  78 kB   00:00
(2/9): glibc-devel-2.17-157.el7_3.1.x86_64.rpm             | 1.1 MB   00:01
(3/9): glibc-headers-2.17-157.el7_3.1.x86_64.rpm           | 668 kB   00:01
(4/9): libmpc-1.0.1-3.el7.x86_64.rpm                       |  51 kB   00:00
warning: /var/cache/yum/x86_64/7/veeam/packages/veeamsnap-1.0.0.944-1.noarch.rpm                                                                                                                                                             : Header V4 RSA/SHA512 Signature, key ID 8aaddc66: NOKEY
Public key for veeamsnap-1.0.0.944-1.noarch.rpm is not installed
(5/9): veeamsnap-1.0.0.944-1.noarch.rpm                    |  73 kB   00:01
(6/9): cpp-4.8.5-11.el7.x86_64.rpm                         | 5.9 MB   00:06
(7/9): kernel-headers-3.10.0-514.10.2.el7.x86_64.rpm       | 4.8 MB   00:07
(8/9): veeam-1.0.0.944-1.el7.i386.rpm                      |  21 MB   00:18
(9/9): gcc-4.8.5-11.el7.x86_64.rpm                         |  16 MB   00:35
--------------------------------------------------------------------------------
Total                                              1.4 MB/s |  50 MB  00:35
Retrieving key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-7
Importing GPG key 0x352C64E5:
 Userid     : "Fedora EPEL (7) <epel@fedoraproject.org>"
 Fingerprint: 91e9 7d7c 4a5e 96f1 7f3e 888f 6a2f aea2 352c 64e5
 Package    : epel-release-7-9.noarch (@extras)
 From       : /etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-7
Is this ok [y/N]: y
Retrieving key from http://repository.veeam.com/keys/RPM-GPG-KEY-VeeamSoftwareRe                                                                                                                                                             po
Retrieving key from file:///etc/pki/rpm-gpg/VeeamSoftwareRepo
Importing CA key 0xFBF8A590:
 Userid     : "Veeam Software Repository key <support@veeam.com>"
 Fingerprint: efaf f6b4 4e68 80ea ddd2 17e4 7afd eeb8 fbf8 a590
 Package    : veeam-release-el7-1.0-1.i386 (installed)
 From       : /etc/pki/rpm-gpg/VeeamSoftwareRepo
Is this ok [y/N]: y
GPG key signature verified against CA Key(s)
Retrieving key from http://repository.veeam.com/keys/VeeamSoftwareRepo
Retrieving key from file:///etc/pki/rpm-gpg/VeeamSoftwareRepo
GPG key signature verified against CA Key(s)
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Installing : libmpc-1.0.1-3.el7.x86_64                                    1/9
  Installing : cpp-4.8.5-11.el7.x86_64                                      2/9
  Installing : kernel-headers-3.10.0-514.10.2.el7.x86_64                    3/9
  Installing : glibc-headers-2.17-157.el7_3.1.x86_64                        4/9
  Installing : glibc-devel-2.17-157.el7_3.1.x86_64                          5/9
  Installing : gcc-4.8.5-11.el7.x86_64                                      6/9
  Installing : dkms-2.3-1.20161202gitde1dca9.el7.noarch                     7/9
  Installing : veeamsnap-1.0.0.944-1.noarch                                 8/9
Loading new veeamsnap-1.0.0.944 DKMS files...
Building for 3.10.0-514.10.2.el7.x86_64
Building initial module for 3.10.0-514.10.2.el7.x86_64
Done.

veeamsnap:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/3.10.0-514.10.2.el7.x86_64/extra/
Adding any weak-modules

depmod...

DKMS: install completed.
  Installing : veeam-1.0.0.944-1.el7.i386                                   9/9
Created symlink from /etc/systemd/system/multi-user.target.wants/veeamservice.se                                                                                                                                                             rvice to /usr/lib/systemd/system/veeamservice.service.
Job for veeamservice.service failed because the control process exited with erro                                                                                                                                                             r code. See "systemctl status veeamservice.service" and "journalctl -xe" for det                                                                                                                                                             ails.
  Verifying  : glibc-headers-2.17-157.el7_3.1.x86_64                        1/9
  Verifying  : libmpc-1.0.1-3.el7.x86_64                                    2/9
  Verifying  : kernel-headers-3.10.0-514.10.2.el7.x86_64                    3/9
  Verifying  : cpp-4.8.5-11.el7.x86_64                                      4/9
  Verifying  : dkms-2.3-1.20161202gitde1dca9.el7.noarch                     5/9
  Verifying  : gcc-4.8.5-11.el7.x86_64                                      6/9
  Verifying  : veeam-1.0.0.944-1.el7.i386                                   7/9
  Verifying  : veeamsnap-1.0.0.944-1.noarch                                 8/9
  Verifying  : glibc-devel-2.17-157.el7_3.1.x86_64                          9/9

Installed:
  veeam.i386 0:1.0.0.944-1.el7

Dependency Installed:
  cpp.x86_64 0:4.8.5-11.el7
  dkms.noarch 0:2.3-1.20161202gitde1dca9.el7
  gcc.x86_64 0:4.8.5-11.el7
  glibc-devel.x86_64 0:2.17-157.el7_3.1
  glibc-headers.x86_64 0:2.17-157.el7_3.1
  kernel-headers.x86_64 0:3.10.0-514.10.2.el7
  libmpc.x86_64 0:1.0.1-3.el7
  veeamsnap.noarch 0:1.0.0.944-1

Complete!


but when running veeamconfig ui. it says


-bash: /usr/bin/veeamconfig: /lib/ld-linux.so.2: bad ELF interpreter: No such file or directory


where to from here?
comwireitadam
Novice
 
Posts: 7
Liked: never
Joined: Wed Mar 29, 2017 4:01 am
Full Name: Adam Kangas

Re: install issues

Veeam Logoby vmniels » Fri Mar 31, 2017 7:25 am

Can you try the following "yum install glibc-common glibc glibc.i686" and then run the "veeam" command again to see if it resolves the issue?
VCP-DCV
Veeam Certified Engineer
http://foonet.be
vmniels
Veeam Software
 
Posts: 1517
Liked: 328 times
Joined: Mon Jul 15, 2013 11:09 am
Full Name: Niels Engelen

Re: install issues

Veeam Logoby comwireitadam » Mon Apr 03, 2017 3:43 am

Thanks

Different error now

[root@xeon ~]# veeamconfig ui
veeamconfig: error while loading shared libraries: libfuse.so.2: cannot open shared object file: No such file or directory
comwireitadam
Novice
 
Posts: 7
Liked: never
Joined: Wed Mar 29, 2017 4:01 am
Full Name: Adam Kangas

Re: install issues

Veeam Logoby vmniels » Mon Apr 03, 2017 7:22 am

You can resolve this by running:
yum install fuse fuse-libs

You might need some additional ones as well to be installed - make sure these are installed (or a like package for CentOS):
Code: Select all
Protected Linux installation must have the following components installed:
• dkms*
• gcc
• make
• perl
• kernel-headers**
• kernel-devel**
• libudev
• libacl
• libattr
• lvm2
• libfuse
VCP-DCV
Veeam Certified Engineer
http://foonet.be
vmniels
Veeam Software
 
Posts: 1517
Liked: 328 times
Joined: Mon Jul 15, 2013 11:09 am
Full Name: Niels Engelen

Re: install issues

Veeam Logoby comwireitadam » Wed Apr 05, 2017 4:29 am

i tried this for all those components and it says they are all installed and at the latest version.

i will try a restart of the server tonight.
comwireitadam
Novice
 
Posts: 7
Liked: never
Joined: Wed Mar 29, 2017 4:01 am
Full Name: Adam Kangas

Re: install issues

Veeam Logoby PTide » Wed Apr 05, 2017 9:32 am

Wait a second...as far as I can see from the first post you have a 64 bit system, right?
uname - a= 3.10.0-514.10.2.el7.x86_64 #1 SMP Fri Mar 3 00:04:05 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
If so then why do you install 32-bit version of veeam repository in the first place?

[root@xeon veeam-release]# dir
veeam-release-el7-1.0-1.i386.rpm
[root@xeon veeam-release]# rpm -ivh ./veeam-release* && yum check-update

Thanks
PTide
Veeam Software
 
Posts: 3022
Liked: 247 times
Joined: Tue May 19, 2015 1:46 pm

Re: install issues

Veeam Logoby comwireitadam » Thu Apr 06, 2017 1:25 am

ok thanks

how do i fix this problem now

ive removed veeam


Preparing... ################################# [100%]
file /etc/yum.repos.d/veeam.repo from install of veeam-release-el7-1.0-1.x86_64 conflicts with file from package veeam-release-el6-1.0-1.x86_64
file /etc/yum.repos.d/veeam.repo from install of veeam-release-el7-1.0-1.x86_64 conflicts with file from package veeam-release-el7-1.0-1.i386
comwireitadam
Novice
 
Posts: 7
Liked: never
Joined: Wed Mar 29, 2017 4:01 am
Full Name: Adam Kangas

Re: install issues

Veeam Logoby comwireitadam » Thu Apr 06, 2017 1:38 am

I have now resolved this.

Thanks for the help
comwireitadam
Novice
 
Posts: 7
Liked: never
Joined: Wed Mar 29, 2017 4:01 am
Full Name: Adam Kangas

Re: install issues

Veeam Logoby comwireitadam » Thu Apr 13, 2017 7:17 am

I now have anther issue

I get the following error come up



Code: Select all
 Summary                              Data

     Duration:           00:00:00         Processed:          ---
     Processing rate:    ---              Read:               ---
     Bottleneck:         ---              Transferred:        ---

      Time            Action                                                                                                                                                                                                 Duration

      16:39:56        Job BackupJob1 started at 2017-04-13 16:39:56 ACST
      16:39:56        Preparing to backup
      16:39:56        [warn] Backup is missing in repository
      16:39:56        [error] Failed to perform backup
      16:39:56        [error] No objects to backup


the destination for the job is /dev and the backup mode is set to entire machine


Code: Select all
 [root@xeon dev]# lsblk -a
lsblk: dm-0: failed to get device path
lsblk: dm-0: failed to get device path
lsblk: dm-0: failed to get device path
lsblk: dm-0: failed to get device path
lsblk: dm-0: failed to get device path
NAME      MAJ:MIN RM   SIZE RO TYPE   MOUNTPOINT
sda         8:0    0 931.5G  0 disk
├─sda1      8:1    0   500M  0 part   /boot
├─sda2      8:2    0 781.4G  0 part
│ └─md126   9:126  0   1.5T  0 raid10 /home
├─sda3      8:3    0     2G  0 part
├─sda4      8:4    0     1K  0 part
└─sda5      8:5    0 147.7G  0 part
  └─md127   9:127  0 295.1G  0 raid10 /
sdb         8:16   0 931.5G  0 disk
├─sdb1      8:17   0 781.4G  0 part
│ └─md126   9:126  0   1.5T  0 raid10 /home
├─sdb2      8:18   0     2G  0 part
└─sdb3      8:19     147.7G  0 part
  └─md127   9:127  0 295.1G  0 raid10 /
sdc         8:32   0 931.5G  0 disk
├─sdc1      8:33   0 781.4G  0 part
│ └─md126   9:126  0   1.5T  0 raid10 /home
├─sdc2      8:34   0     2G  0 part
└─sdc3      8:35     147.7G  0 part
  └─md127   9:127  0 295.1G  0 raid10 /
sdd         8:48   0 931.5G  0 disk
├─sdd1      8:49   0 781.4G  0 part
│ └─md126   9:126  0   1.5T  0 raid10 /home
├─sdd2      8:50   0     2G  0 part
└─sdd3      8:51     147.7G  0 part
  └─md127   9:127  0 295.1G  0 raid10 /
sde         8:64   0   256M  1 disk
└─sde1      8:65   0   251M  1 part   /run/media/root/VID
sdf         8:80   0   1.8T  0 disk
└─sdf1      8:81   0   1.8T  0 part   /dev
sr0        11:0    1  1024M  0 rom
comwireitadam
Novice
 
Posts: 7
Liked: never
Joined: Wed Mar 29, 2017 4:01 am
Full Name: Adam Kangas

Re: install issues

Veeam Logoby vmniels » Thu Apr 13, 2017 7:31 am

You can't/shouldn't backup to /dev as the /dev directory contains the special device files for all the devices of the server. This folder is best to be left alone :-).

You should make a folder like '/mnt/veeam' and try to backup files there however if you select entire machine you'll need to use something like a share via NFS as target.
VCP-DCV
Veeam Certified Engineer
http://foonet.be
vmniels
Veeam Software
 
Posts: 1517
Liked: 328 times
Joined: Mon Jul 15, 2013 11:09 am
Full Name: Niels Engelen

Re: install issues

Veeam Logoby PTide » Thu Apr 13, 2017 12:34 pm

Niels is spot on about /dev directory.

Regarding performing full backup to a local destination - that might work sometimes if you have enough space and the data change rate is not very intense, however that's neither supported nor recommended approach anyway.

Thanks
PTide
Veeam Software
 
Posts: 3022
Liked: 247 times
Joined: Tue May 19, 2015 1:46 pm


Return to Veeam Agent for Linux



Who is online

Users browsing this forum: No registered users and 4 guests