Backup agent for Linux servers and workstations on-premises or in the public cloud
Post Reply
chris400
Influencer
Posts: 10
Liked: 3 times
Joined: Feb 04, 2017 10:31 am
Full Name: Christoph
Contact:

VAL stops with latest ArchLinux - [ID# 02133145]

Post by chris400 » May 02, 2017 8:14 pm

I know, arch linux is not officially supported. I use https://github.com/CodeImp/arch_packages

veeam 1.0.0.944-1
Kernel 4.10.13-1-ARCH

My last successful backup was on April 4th, afterwards (April 14th) backups are failing.

Michael from support told me, that there is an hotfix for that, but it's not for Arch Linux :-(
[19.04.2017 23:44:44] <140115575834368> lpbcore| No master boot record found on device.
[19.04.2017 23:44:44] <140115575834368> lpbcore| ERR |No medium found
[19.04.2017 23:44:44] <140115575834368> lpbcore| >> |Failed to probe device [/dev/sr0].
[19.04.2017 23:44:44] <140115575834368> lpbcore| >> |An exception was thrown from thread [140115575834368].

It looks similar to one of a known bugs that have been fixed by a special hotfix.
Anybody else running Arch Linux, is it working at yours?
What causes the bug? I have a very simple partition setup (64GB SSD, MBR, part1 ext4 53GB, part2 swap 8,5GB). The GUI just shows an error "LvmDriver: Failed to create LVM..."

Michael also said, that the hotfix might be included in VAL Update 1, which will be released soon.

PTide
Veeam Software
Posts: 4247
Liked: 349 times
Joined: May 19, 2015 1:46 pm
Contact:

Re: VAL stops with latest ArchLinux - [ID# 02133145]

Post by PTide » May 03, 2017 2:41 pm

Hi,

Please try to set units=”h” in /etc/lvm/lvm.conf.

Thanks

chris400
Influencer
Posts: 10
Liked: 3 times
Joined: Feb 04, 2017 10:31 am
Full Name: Christoph
Contact:

Re: VAL stops with latest ArchLinux - [ID# 02133145]

Post by chris400 » May 04, 2017 7:46 pm

Thx PTide, It's working again.

Can you give more details on that? :-)

I also have two questions:
1. is that the hotfix Michael was talking about?
2. Veeamsupport here (forum) is better than via supportticket? ;-)

Here is the root cause:
https://sourceware.org/git/?p=lvm2.git; ... dfb5cff467
it was changed in lvm2-2.02.169

PTide
Veeam Software
Posts: 4247
Liked: 349 times
Joined: May 19, 2015 1:46 pm
Contact:

Re: VAL stops with latest ArchLinux - [ID# 02133145]

Post by PTide » May 05, 2017 7:39 am

1. No, it's not. When you say "hotfix" that usually implies "package that has been built for some specific reason to fix some specific problem". Changing a variable via config file is not a hotfix in any way. :)
2. If you either use unsupported version of OS and/or use FREE version of VAL then the answer is "yes"

Thank you

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests