VAL unable to see Multipath Device

Backup agent for Linux servers and workstations on-premises or in the public cloud

VAL unable to see Multipath Device

Veeam Logoby togenshi » Thu Jun 22, 2017 8:39 am

System: Ubuntu 16.04 LTS
Problem: Unable to see a multipathed device. Works fine with Ubuntu 14.04 LTS. Using FC SAN storage.

Code: Select all
root@sloth:~# lsblk -p
NAME                                                    MAJ:MIN RM   SIZE RO TYPE  MOUNTPOINT
/dev/sda                                                  8:0    0 557.8G  0 disk 
├─/dev/sda1                                               8:1    0   476M  0 part  /boot
├─/dev/sda2                                               8:2    0   3.7G  0 part  [SWAP]
└─/dev/sda3                                               8:3    0 553.6G  0 part  /
/dev/sdb                                                  8:16   0     1T  0 disk 
└─/dev/mapper/3600a09800059dbb9000002a955c35df0         252:0    0     1T  0 mpath
  └─/dev/mapper/3600a09800059dbb9000002a955c35df0-part1 252:1    0  1024G  0 part  /export/san-1
/dev/sdc                                                  8:32   0     1T  0 disk 
└─/dev/mapper/3600a09800059dbb9000002a955c35df0         252:0    0     1T  0 mpath
  └─/dev/mapper/3600a09800059dbb9000002a955c35df0-part1 252:1    0  1024G  0 part  /export/san-1
/dev/sdd                                                  8:48   0     1T  0 disk 
└─/dev/mapper/3600a09800059dbb9000002a955c35df0         252:0    0     1T  0 mpath
  └─/dev/mapper/3600a09800059dbb9000002a955c35df0-part1 252:1    0  1024G  0 part  /export/san-1
/dev/sde                                                  8:64   0     1T  0 disk 
└─/dev/mapper/3600a09800059dbb9000002a955c35df0         252:0    0     1T  0 mpath
  └─/dev/mapper/3600a09800059dbb9000002a955c35df0-part1 252:1    0  1024G  0 part  /export/san-1
/dev/sr0                                                 11:0    1  1024M  0 rom   



Code: Select all
UUID=57fc0572-99c5-47b4-97ff-e235f2871924 /               ext4    errors=remount-ro 0       1
# /boot was on /dev/sda1 during installation
UUID=0db96e6a-2884-4c75-a906-9f59a483d809 /boot           ext4    defaults        0       2
# swap was on /dev/sda2 during installation
UUID=1a64445b-908e-4686-a743-896e015bcfbe none            swap    sw              0       0
UUID=f69b0518-9387-4ccd-adc8-d428588dad82 /export/san-1   ext4    rw              0       0


Result in veeam:
Image

Code: Select all
root@sloth:~# veeamconfig job edit --objects /dev/sda,/dev/mapper/3600a09800059dbb9000002a955c35df0-part1 for --name sloth
Error: Unable to backup following devices: /dev/mapper/3600a09800059dbb9000002a955c35df0-part1


Also cannot use files and folders option to back up the server.
Image

Logs can be found here: https://drive.google.com/file/d/0B46Ua4 ... sp=sharing
togenshi
Influencer
 
Posts: 22
Liked: 4 times
Joined: Mon Jul 27, 2015 1:16 am

Re: VAL unable to see Multipath Device

Veeam Logoby vmniels » Thu Jun 22, 2017 8:42 am

We can't backup a raw device as we can't snapshot it so as it states you will need to exclude it.
VCP-DCV
Veeam Certified Engineer
http://foonet.be
vmniels
Veeam Software
 
Posts: 1503
Liked: 325 times
Joined: Mon Jul 15, 2013 11:09 am
Full Name: Niels Engelen

Re: VAL unable to see Multipath Device

Veeam Logoby togenshi » Thu Jun 22, 2017 8:45 am

This process was working fine with Ubuntu 14.04 LTS though. See veeam-agent-for-linux-f41/handling-multipath-devices-t39631.html

Do note the UUID is exactly the same.

Should I try using /dev/mapper/3600a09800059dbb9000002a955c35df0-part1 in /etc/fstab?
togenshi
Influencer
 
Posts: 22
Liked: 4 times
Joined: Mon Jul 27, 2015 1:16 am

Re: VAL unable to see Multipath Device

Veeam Logoby vmniels » Thu Jun 22, 2017 8:49 am

Somehow we now see it as a NFS share so maybe the behaviour on 16.04 is different. You can contact support for insight to see if it can be resolved.
VCP-DCV
Veeam Certified Engineer
http://foonet.be
vmniels
Veeam Software
 
Posts: 1503
Liked: 325 times
Joined: Mon Jul 15, 2013 11:09 am
Full Name: Niels Engelen

Re: VAL unable to see Multipath Device

Veeam Logoby togenshi » Thu Jun 22, 2017 8:54 am

Case #02197219
togenshi
Influencer
 
Posts: 22
Liked: 4 times
Joined: Mon Jul 27, 2015 1:16 am

Re: VAL unable to see Multipath Device

Veeam Logoby PTide » Thu Jun 22, 2017 11:44 am

Hi,

Could you try adding to the backup job by its mount point? Instead of this:

veeamconfig job edit --objects /dev/sda,/dev/mapper/3600a09800059dbb9000002a955c35df0-part1 for --name sloth

do this:

veeamconfig job edit --objects /dev/sda,/export/san for --name sloth

Thank you
PTide
Veeam Software
 
Posts: 3017
Liked: 245 times
Joined: Tue May 19, 2015 1:46 pm

Re: VAL unable to see Multipath Device

Veeam Logoby togenshi » Fri Jun 23, 2017 2:51 am

Case [ID# 02197219] sorted it out. Got a patch and was able to backup and restore. Awesome work by the team. Had the patch within 2hrs of submitting the ticket even at lowest priority.
togenshi
Influencer
 
Posts: 22
Liked: 4 times
Joined: Mon Jul 27, 2015 1:16 am


Return to Veeam Agent for Linux



Who is online

Users browsing this forum: No registered users and 4 guests