Backup agent for Linux servers and workstations on-premises or in the public cloud
b1o
Enthusiast
Posts: 27
Liked: 1 time
Joined: Dec 09, 2016 10:49 am
Contact:

Re: Veeam Agent Linux: Error: Failed to connect to the port

Post by b1o » Dec 16, 2016 12:54 pm

case open...
will send a feedback soon

PTide
Veeam Software
Posts: 4550
Liked: 374 times
Joined: May 19, 2015 1:46 pm
Contact:

Re: Veeam Agent Linux: Error: Failed to connect to the port

Post by PTide » Dec 16, 2016 2:06 pm

Can I have your case ID please?

b1o
Enthusiast
Posts: 27
Liked: 1 time
Joined: Dec 09, 2016 10:49 am
Contact:

Re: Veeam Agent Linux: Error: Failed to connect to the port

Post by b1o » Dec 16, 2016 2:48 pm

Case # 02012181

Seems to be the wrong version
I have Centos 6 and try to install a 7 !!!!!
:oops:

just trying the 6 one

b1o
Enthusiast
Posts: 27
Liked: 1 time
Joined: Dec 09, 2016 10:49 am
Contact:

Re: Veeam Agent Linux: Error: Failed to connect to the port

Post by b1o » Dec 16, 2016 2:53 pm 1 person likes this post

That Works....

Thanks for your help.

artravis77
Lurker
Posts: 1
Liked: never
Joined: Jul 20, 2016 11:49 pm
Full Name: Travis Adkins
Contact:

Re: Veeam Agent Linux: Error: Failed to connect to the port

Post by artravis77 » Dec 29, 2016 3:15 am

Centos 6.7 and 6.8 but I'm facing a new error after installing the product veeam-release-el7-1.0-1.x86_64.rpm

the rpm that you are installing is for CentOS 7,identified by the el7 of the rpm, if I am wrong some let me know.

vmniels
Veeam Software
Posts: 2064
Liked: 458 times
Joined: Jul 15, 2013 11:09 am
Full Name: Niels Engelen
Contact:

Re: Veeam Agent Linux: Error: Failed to connect to the port

Post by vmniels » Dec 29, 2016 9:34 am

Which error are you facing now?
VCP-DCV
Veeam Certified Architect (VMCA)
http://foonet.be

CatSpirent
Enthusiast
Posts: 45
Liked: 2 times
Joined: Dec 30, 2016 4:10 pm
Full Name: Caterine Kieffer
Contact:

Re: Veeam Agent Linux: Error: Failed to connect to the port

Post by CatSpirent » Dec 30, 2016 4:14 pm

It isn't mentioned here though you may have already addressed it, but your first comment mentions you are installing an EL7 rpm on an EL6 OS. Will that make a difference, or was that just a typo?

PTide
Veeam Software
Posts: 4550
Liked: 374 times
Joined: May 19, 2015 1:46 pm
Contact:

Re: Veeam Agent Linux: Error: Failed to connect to the port

Post by PTide » Dec 30, 2016 8:25 pm

There is el6 package for CentOS 6 and a separate el7 package for CentOS 7, those two cannot substitute each other.

Thanks

cladmonitor
Novice
Posts: 3
Liked: never
Joined: Dec 21, 2012 6:47 pm
Contact:

[MERGED] Ubuntu issue

Post by cladmonitor » Feb 15, 2017 11:57 pm

Install goes fine but using commands $ veeam or $ veeamconfig ends in a time out after about 45 seconds, error is " Error: Failed to connect to the port [127.0.0.1:3500]. "

Troubleshooting details:
- Ubuntu 14.04.5 LTS
- reinstalled vaeeam/veeamsnap
- veeamservice is running
- I can verify that it is accepting requests at 127.0.0.1:3500
- here is veeamconfig.log

Code: Select all

[15.02.2017 15:40:32] <139867313477568> cli    | Initializing new log filter.
[15.02.2017 15:40:32] <139867313477568>        | ====================================================================================
[15.02.2017 15:40:32] <139867313477568> lpb    | {
[15.02.2017 15:40:32] <139867313477568> lpb    |   Veeam Agent for Linux: veeam.
[15.02.2017 15:40:32] <139867313477568> lpb    |   Version: 1.0.0.944
[15.02.2017 15:40:32] <139867313477568> lpb    |   PID: 1473
[15.02.2017 15:40:32] <139867313477568> lpb    |   uname
[15.02.2017 15:40:32] <139867313477568> lpb    |     sysname : Linux
[15.02.2017 15:40:32] <139867313477568> lpb    |     release : 2.6.32-042stab113.21
[15.02.2017 15:40:32] <139867313477568> lpb    |     version : #1 SMP Wed Mar 23 11:05:25 MSK 2016
[15.02.2017 15:40:32] <139867313477568> lpb    |     machine : x86_64
[15.02.2017 15:40:32] <139867313477568> lpb    | }
[15.02.2017 15:40:32] <139867313477568> lpbcore| Connecting to veeam service...
[15.02.2017 15:40:32] <139867313477568>        |   Trying to connect to the endpoint [127.0.0.1:3500]
[15.02.2017 15:46:31] <140680899602368> cli    | Initializing new log filter.
[15.02.2017 15:46:31] <140680899602368>        | ====================================================================================
[15.02.2017 15:46:31] <140680899602368> lpb    | {
[15.02.2017 15:46:31] <140680899602368> lpb    |   Veeam Agent for Linux: veeam.
[15.02.2017 15:46:31] <140680899602368> lpb    |   Version: 1.0.0.944
[15.02.2017 15:46:31] <140680899602368> lpb    |   PID: 1538
[15.02.2017 15:46:31] <140680899602368> lpb    |   uname
[15.02.2017 15:46:31] <140680899602368> lpb    |     sysname : Linux
[15.02.2017 15:46:31] <140680899602368> lpb    |     release : 2.6.32-042stab113.21
[15.02.2017 15:46:31] <140680899602368> lpb    |     version : #1 SMP Wed Mar 23 11:05:25 MSK 2016
[15.02.2017 15:46:31] <140680899602368> lpb    |     machine : x86_64
[15.02.2017 15:46:31] <140680899602368> lpb    | }
[15.02.2017 15:46:31] <140680899602368> lpbcore| Connecting to veeam service...
[15.02.2017 15:46:31] <140680899602368>        |   Trying to connect to the endpoint [127.0.0.1:3500]
[15.02.2017 15:47:34] <140680899602368>        |   Connection status: system:110 ( Connection timed out ).
[15.02.2017 15:47:34] <140680899602368> lpbcore| Connecting to veeam service... Failed.
[15.02.2017 15:47:34] <140680899602368> lpbconf| ERR |Main thread has failed.
[15.02.2017 15:47:34] <140680899602368> lpbconf| >>  |Failed to connect to the port [127.0.0.1:3500].
[15.02.2017 15:47:34] <140680899602368> lpbconf| >>  |--tr:Failed to connect to target endpoint.
[15.02.2017 15:47:34] <140680899602368> lpbconf| >>  |An exception was thrown from thread [140680899602368].
- here is the veeamsvc.log

Code: Select all

[15.02.2017 15:55:02] <140573103462336> cli    | Initializing new log filter.
[15.02.2017 15:55:02] <140573103462336>        | ====================================================================================
[15.02.2017 15:55:02] <140573103462336> lpb    | {
[15.02.2017 15:55:02] <140573103462336> lpb    |   Veeam Agent for Linux: veeamservice.
[15.02.2017 15:55:02] <140573103462336> lpb    |   Version: 1.0.0.944
[15.02.2017 15:55:02] <140573103462336> lpb    |   PID: 1650
[15.02.2017 15:55:02] <140573103462336> lpb    |   uname
[15.02.2017 15:55:02] <140573103462336> lpb    |     sysname : Linux
[15.02.2017 15:55:02] <140573103462336> lpb    |     release : 2.6.32-042stab113.21
[15.02.2017 15:55:02] <140573103462336> lpb    |     version : #1 SMP Wed Mar 23 11:05:25 MSK 2016
[15.02.2017 15:55:02] <140573103462336> lpb    |     machine : x86_64
[15.02.2017 15:55:02] <140573103462336> lpb    |   cpuinfo
[15.02.2017 15:55:02] <140573103462336> lpb    |     processor  : 0
[15.02.2017 15:55:02] <140573103462336> lpb    |     vendor_id  : GenuineIntel
[15.02.2017 15:55:02] <140573103462336> lpb    |     cpu family : 6
[15.02.2017 15:55:02] <140573103462336> lpb    |     model              : 60
[15.02.2017 15:55:02] <140573103462336> lpb    |     model name : Intel(R) Xeon(R) CPU E3-1270 v3 @ 3.50GHz
[15.02.2017 15:55:02] <140573103462336> lpb    |     stepping   : 3
[15.02.2017 15:55:02] <140573103462336> lpb    |     microcode  : 9
[15.02.2017 15:55:02] <140573103462336> lpb    |     cpu MHz            : 2187.713
[15.02.2017 15:55:02] <140573103462336> lpb    |     cache size : 8192 KB
[15.02.2017 15:55:02] <140573103462336> lpb    |     physical id        : 0
[15.02.2017 15:55:02] <140573103462336> lpb    |     siblings   : 8
[15.02.2017 15:55:02] <140573103462336> lpb    |     core id            : 0
[15.02.2017 15:55:02] <140573103462336> lpb    |     cpu cores  : 4
[15.02.2017 15:55:02] <140573103462336> lpb    |     apicid             : 0
[15.02.2017 15:55:02] <140573103462336> lpb    |     initial apicid     : 0
[15.02.2017 15:55:02] <140573103462336> lpb    |     fpu                : yes
[15.02.2017 15:55:02] <140573103462336> lpb    |     fpu_exception      : yes
[15.02.2017 15:55:02] <140573103462336> lpb    |     cpuid level        : 13
[15.02.2017 15:55:02] <140573103462336> lpb    |     wp         : yes
[15.02.2017 15:55:02] <140573103462336> lpb    |     flags              : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc arch_perfmon pebs bts rep_good xtopology nonstop_tsc aperfmperf cpuid_faulting pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 fma cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic movbe popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm abm arat epb pln pts dtherm tpr_shadow vnmi flexpriority ept vpid fsgsbase bmi1 hle avx2 smep bmi2 erms invpcid rtm xsaveopt
[15.02.2017 15:55:02] <140573103462336> lpb    |     bogomips   : 7000.68
[15.02.2017 15:55:02] <140573103462336> lpb    |     clflush size       : 64
[15.02.2017 15:55:02] <140573103462336> lpb    |     cache_alignment    : 64
[15.02.2017 15:55:02] <140573103462336> lpb    |     address sizes      : 39 bits physical, 48 bits virtual
[15.02.2017 15:55:02] <140573103462336> lpb    |     power management:
[15.02.2017 15:55:02] <140573103462336> lpb    |     processor  : 1
[15.02.2017 15:55:02] <140573103462336> lpb    |     vendor_id  : GenuineIntel
[15.02.2017 15:55:02] <140573103462336> lpb    |     cpu family : 6
[15.02.2017 15:55:02] <140573103462336> lpb    |     model              : 60
[15.02.2017 15:55:02] <140573103462336> lpb    |     model name : Intel(R) Xeon(R) CPU E3-1270 v3 @ 3.50GHz
[15.02.2017 15:55:02] <140573103462336> lpb    |     stepping   : 3
[15.02.2017 15:55:02] <140573103462336> lpb    |     microcode  : 9
[15.02.2017 15:55:02] <140573103462336> lpb    |     cpu MHz            : 2187.713
[15.02.2017 15:55:02] <140573103462336> lpb    |     cache size : 8192 KB
[15.02.2017 15:55:02] <140573103462336> lpb    |     physical id        : 0
[15.02.2017 15:55:02] <140573103462336> lpb    |     siblings   : 8
[15.02.2017 15:55:02] <140573103462336> lpb    |     core id            : 1
[15.02.2017 15:55:02] <140573103462336> lpb    |     cpu cores  : 4
[15.02.2017 15:55:02] <140573103462336> lpb    |     apicid             : 2
[15.02.2017 15:55:02] <140573103462336> lpb    |     initial apicid     : 2
[15.02.2017 15:55:02] <140573103462336> lpb    |     fpu                : yes
[15.02.2017 15:55:02] <140573103462336> lpb    |     fpu_exception      : yes
[15.02.2017 15:55:02] <140573103462336> lpb    |     cpuid level        : 13
[15.02.2017 15:55:02] <140573103462336> lpb    |     wp         : yes
[15.02.2017 15:55:02] <140573103462336> lpb    |     flags              : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc arch_perfmon pebs bts rep_good xtopology nonstop_tsc aperfmperf cpuid_faulting pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 fma cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic movbe popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm abm arat epb pln pts dtherm tpr_shadow vnmi flexpriority ept vpid fsgsbase bmi1 hle avx2 smep bmi2 erms invpcid rtm xsaveopt
[15.02.2017 15:55:02] <140573103462336> lpb    |     bogomips   : 7000.68
[15.02.2017 15:55:02] <140573103462336> lpb    |     clflush size       : 64
[15.02.2017 15:55:02] <140573103462336> lpb    |     cache_alignment    : 64
[15.02.2017 15:55:02] <140573103462336> lpb    |     address sizes      : 39 bits physical, 48 bits virtual
[15.02.2017 15:55:02] <140573103462336> lpb    |     power management:
[15.02.2017 15:55:02] <140573103462336> lpb    |   meminfo
[15.02.2017 15:55:02] <140573103462336> lpb    |     MemTotal:        4194304 kB
[15.02.2017 15:55:02] <140573103462336> lpb    |     MemFree:         3312392 kB
[15.02.2017 15:55:02] <140573103462336> lpb    |     Cached:           344420 kB
[15.02.2017 15:55:02] <140573103462336> lpb    |     Buffers:               0 kB
[15.02.2017 15:55:02] <140573103462336> lpb    |     Active:           394096 kB
[15.02.2017 15:55:02] <140573103462336> lpb    |     Inactive:         460864 kB
[15.02.2017 15:55:02] <140573103462336> lpb    |     Active(anon):     339100 kB
[15.02.2017 15:55:02] <140573103462336> lpb    |     Inactive(anon):   242304 kB
[15.02.2017 15:55:02] <140573103462336> lpb    |     Active(file):      54996 kB
[15.02.2017 15:55:02] <140573103462336> lpb    |     Inactive(file):   218560 kB
[15.02.2017 15:55:02] <140573103462336> lpb    |     Unevictable:           0 kB
[15.02.2017 15:55:02] <140573103462336> lpb    |     Mlocked:               0 kB
[15.02.2017 15:55:02] <140573103462336> lpb    |     SwapTotal:       4194304 kB
[15.02.2017 15:55:02] <140573103462336> lpb    |     SwapFree:        4194304 kB
[15.02.2017 15:55:02] <140573103462336> lpb    |     Dirty:                28 kB
[15.02.2017 15:55:02] <140573103462336> lpb    |     Writeback:             0 kB
[15.02.2017 15:55:02] <140573103462336> lpb    |     AnonPages:        581404 kB
[15.02.2017 15:55:02] <140573103462336> lpb    |     Shmem:             70864 kB
[15.02.2017 15:55:02] <140573103462336> lpb    |     Slab:              26940 kB
[15.02.2017 15:55:02] <140573103462336> lpb    |     SReclaimable:      10544 kB
[15.02.2017 15:55:02] <140573103462336> lpb    |     SUnreclaim:        16396 kB
[15.02.2017 15:55:02] <140573103462336> lpb    | }
[15.02.2017 15:55:02] <140573103462336> lpbsvc | Main thread has started.
[15.02.2017 15:55:02] <140573103462336> lpbsvc | Starting server.
[15.02.2017 15:55:02] <140573103462336>        |   Loading upgrade script '/usr/share/veeam/lpb_upgrade_scheme.sql'.
[15.02.2017 15:55:02] <140573103462336> lpbcore|   SQL user version: 5.
[15.02.2017 15:55:02] <140573103462336> lpbcore|   Cleaning orphaned sessions.
[15.02.2017 15:55:02] <140573067028224>        | Thread started. Thread id: 140573067028224, parent id: 140573103462336, role: VRPC server thread
[15.02.2017 15:55:02] <140573067028224> net    | Veeam RPC server started.
[15.02.2017 15:55:02] <140573067028224> net    | Selected vRPC port: '3500'.
[15.02.2017 15:55:02] <140573067028224> net    | Listening vRPC port '3500'.
[15.02.2017 15:55:02] <140573103462336> lpbsvc | Server started on port [3500].
Any help is appreciated.

-Eric

vmniels
Veeam Software
Posts: 2064
Liked: 458 times
Joined: Jul 15, 2013 11:09 am
Full Name: Niels Engelen
Contact:

[MERGED] Re: Ubuntu issue

Post by vmniels » Feb 16, 2017 12:59 am

Can you post the output of dmesg -T?
VCP-DCV
Veeam Certified Architect (VMCA)
http://foonet.be

PTide
Veeam Software
Posts: 4550
Liked: 374 times
Joined: May 19, 2015 1:46 pm
Contact:

[MERGED] Re: Ubuntu issue

Post by PTide » Feb 16, 2017 11:47 am

Hi,

Please contact our support team so they can take a closer look at your setup and find the root cause of the faliure. Once you do please post your case ID.

Thank you

tcimunn
Novice
Posts: 4
Liked: 1 time
Joined: Oct 01, 2016 4:10 pm
Full Name: Tim Munn
Contact:

[MERGED] Failed to connect to the port [127.0.0.1:3500]

Post by tcimunn » Feb 25, 2017 11:45 pm

I am running into repeated problems trying to install the agent on CentOS 6.8. I get in installed without issue but can't seem to get beyond the install.

If I run veeamconfig ui or anything I run into
Error: Failed to connect to the port [127.0.0.1:3500]

If veeamagent is supposed to be started, it isn't and a reboot doesn't do anything good.

I've done uninstalls, cleanup and reinstalls and same result.

What am I missing? Have reviewed docs and forum and I don't think I've got anything odd in the mix.

Any help would be greatly appreciated.

vmniels
Veeam Software
Posts: 2064
Liked: 458 times
Joined: Jul 15, 2013 11:09 am
Full Name: Niels Engelen
Contact:

[MERGED] Failed to connect to the port [127.0.0.1:3500]

Post by vmniels » Feb 25, 2017 11:54 pm

Can you see if you can start the service manually via /etc/init.d/veeamservice start ?

There is also more advice in post221298.html however if nothing works please feel free to contact our support and leave the ID here for future references.
VCP-DCV
Veeam Certified Architect (VMCA)
http://foonet.be

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest