2 bugs in VAW

Backup agent for Microsoft Windows servers and workstations (formerly Veeam Endpoint Backup FREE)

2 bugs in VAW

Veeam Logoby NickViz1 » Fri Apr 21, 2017 1:56 pm

First of all - I was not able to create a support case, I was blocked at entering email. There is no verification email received, so no way to make ticket.

OK, that's bug №0 - to Anton Gostev attention - you explicitly require us to make a support case when reporting bugs - fine for me, but bloody hell, make sure that we are able to make that support case! I'm receiving almost daily marketing spam from Veeam, but verification email did reach me. And yes, my email is correct - I got a test email from yandex mail immediately. Veeam looks pretty stupid in this case.

Bug №1: when I do a file backup for on a BitLocker encrypted volume - it fails on encrypted files:
21/04/2017 9:22:34 :: Error: Access is denied. Failed to open source FS item '\\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy59\Nikolai.Vorontsov\Documents\Private\nikolai.vorontsov.ppk' Agent failed to process method {FileBackup.SyncDirs}. Exception from server: Shared memory connection was closed.

Visually it looks like VeeamAgent.exe process consumes all memory:
Image
Image
and after a while backup fails. After I removed encryption from that file - backup succeed. Note that Veeam Endpoint backup in that configuration worked.

Bug №2: as you see the VeeamAgent.exe can eat all memory on machine in case of problem. It would be nice if you detect such issue and backup reader stops to blow up memory in case of problems.

regards.
NickViz1
Enthusiast
 
Posts: 31
Liked: 5 times
Joined: Wed Jan 27, 2016 8:50 am
Full Name: Nikolai Vorontsov

Re: 2 bugs in VAW

Veeam Logoby NickViz1 » Fri Apr 21, 2017 2:00 pm

Ah, yea - Windows 7 x64 Enterprise on Intel CPU, Sophos Endpoint Security and Control version 10.6, NTFS, domain, all volumes encrypted with BitLocker. If you need some more info about my configuration - don't hesitate to ask me.
NickViz1
Enthusiast
 
Posts: 31
Liked: 5 times
Joined: Wed Jan 27, 2016 8:50 am
Full Name: Nikolai Vorontsov

Re: 2 bugs in VAW

Veeam Logoby CarlMcDade » Fri Apr 21, 2017 4:03 pm

Hello again,

Just and FYI

I am running Windows 10 x64 enterprise, Bitlocker is configured with local TPM module. My VAW works fine using both file level and block level backups

Cheers
mail@carlmcdade.com
http://twitter.com/CarlMcDade
http://www.carlmcdade.com
CarlMcDade
Service Provider
 
Posts: 56
Liked: 20 times
Joined: Mon Jul 08, 2013 1:47 pm
Location: Leeds, UK
Full Name: Carl McDade

Re: 2 bugs in VAW

Veeam Logoby NickViz1 » Mon Apr 24, 2017 7:31 am

Hello Carl,

do you have _encrypted_ files in your backup set? RMC/Properties/Advanced/Encrypt contents to secure data.
NickViz1
Enthusiast
 
Posts: 31
Liked: 5 times
Joined: Wed Jan 27, 2016 8:50 am
Full Name: Nikolai Vorontsov

Re: 2 bugs in VAW

Veeam Logoby Mike Resseler » Mon Apr 24, 2017 4:59 pm

@nikolai,

My apologies for the late reply. For some reason I missed your thread. Mea culpa

Can you PM me your email address so I can inform our team to create a support call and contact you? Not only figuring out the bug is needed, but please tell them also about the support email issue. This works rather fine but from time to time we get into some strange issues and we try to solve those as much as we can

Thanks
Mike
Mike Resseler
Veeam Software
 
Posts: 3089
Liked: 359 times
Joined: Fri Feb 08, 2013 3:08 pm
Location: Belgium, the land of the fries, the beer, the chocolate and the diamonds...
Full Name: Mike Resseler

Re: 2 bugs in VAW

Veeam Logoby Dima P. » Mon Apr 24, 2017 9:37 pm

Hi Nikolai,

verification email did reach me. And yes, my email is correct - I got a test email from yandex mail immediately.

There might be a delay in verification email generation. Can you please clarify was this email delivered? If not, please send Mike or me your email address via PM.

Regarding issues, I asked QA folks to check but we need your application debug logs, so support case is required. You can also share the logs from C:\ProgramData\Veeam with me via PM.
Dima P.
Veeam Software
 
Posts: 6074
Liked: 433 times
Joined: Mon Feb 04, 2013 2:07 pm
Location: SPb
Full Name: Dmitry Popov

Re: 2 bugs in VAW

Veeam Logoby NickViz1 » Tue Apr 25, 2017 9:18 am

PM sent to Dima & Mike.
thanks guys!
NickViz1
Enthusiast
 
Posts: 31
Liked: 5 times
Joined: Wed Jan 27, 2016 8:50 am
Full Name: Nikolai Vorontsov

Re: 2 bugs in VAW

Veeam Logoby Dima P. » Tue Apr 25, 2017 12:03 pm

Nikolai,

Thanks a lot. Working with QA team, stay tuned.
Dima P.
Veeam Software
 
Posts: 6074
Liked: 433 times
Joined: Mon Feb 04, 2013 2:07 pm
Location: SPb
Full Name: Dmitry Popov

Re: 2 bugs in VAW

Veeam Logoby Dima P. » Sat Apr 29, 2017 9:36 pm

Nikolai,

The issue should be resolved in RTM code. If possible, please test the RTM code in your environment and let us know the results. Thank you.
Dima P.
Veeam Software
 
Posts: 6074
Liked: 433 times
Joined: Mon Feb 04, 2013 2:07 pm
Location: SPb
Full Name: Dmitry Popov


Return to Veeam Agent for Windows



Who is online

Users browsing this forum: No registered users and 6 guests