Standalone backup agent for Microsoft Windows servers and workstations (formerly Veeam Endpoint Backup FREE)
Post Reply
solarys
Lurker
Posts: 2
Liked: never
Joined: Oct 16, 2020 7:41 pm
Full Name: Florin Brenner
Contact:

Case id: #04445930 restoring from backup password problem

Post by solarys »

Hello there everyone! Today i made a full computer backup using an old version of veeam agent for windows free version 3.0.72...

After that i reinstalled operating system on that computer. Later i installed again veeam agent for windows free exactly the same version as before. I tried to restore individual files to get back some files and it asked me for a password for encrypted backup.

The thing is I DID NOT SETUP ANY PASSWORD for backup. I just Installed veeam agent for windows free as i done many times in the back, just clicked next, next, next with standard options and apply and run job.

So right now i have 176 GB of my client (real estates databases) in a backup aparently encrypted.
I did not backed up any encryption keys since i did not choose a password nor an encrypted backup.

I talked via chat with a representative and they told me that in paid version you can setup a password for backup which will open old backups. To me this doesnt make any sense since i did not use a paid version nor setting up an encrypted backup or a password.

After i reminded her that i used free version to made backup she asked me to call phone support which i did.

I called UK phone support and the guy told me that free agent for windows is not qualify for phone support and to wait for an expert engineer to look to my case or i can expedite things paying for a paid version. I ask how can i be convinced to buy a product when i saw what problems is giving me free version?!!

Leaving all support answers away, is there anybody with an ideea?
How that coupd happen?
How to recover my data back?

Any tip or advice will be highly appreciated.

Egor Yakovlev
Veeam Software
Posts: 1587
Liked: 366 times
Joined: Jun 14, 2013 9:30 am
Full Name: Egor Yakovlev
Contact:

Re: Case id: #04445930 restoring from backup password problem

Post by Egor Yakovlev »

Hi Florin.

Just to make it clear:
- source-side encryption in Veeam Agent for Windows is available for free edition as well as paid.
- encryption is enabled in the job advanced settings by ticking a checkbox and entering a passphrase. It has very low change of enabling it by mistake.

Having that said, let's try to find a root cause.
- Does anyone else have access to your computer. Another admin could have logon and change job settings.
- What is the target storage for backups? Are you sure wizard asks about backup chain password, nor backup storage authentication?
- There is nothing left from an old system? Product logs would show when encryption was ticked...

/Thanks!

solarys
Lurker
Posts: 2
Liked: never
Joined: Oct 16, 2020 7:41 pm
Full Name: Florin Brenner
Contact:

Re: Case id: #04445930 restoring from backup password problem

Post by solarys »

Hello Egor!
Case id: #04445930

Exactly my point! It is very unlikely to enable encryption by mistake. It has to go to advance mode and setup a passphrase, repeated to confirm and choose a hint. I did not do that.
The owner of the computer doesn't know how to do stuff like this. for this kind of things he's calling me. I've done backups with veeam agent for windows free and i never encounter a problem like this.
And i repeat is a matter of 15-20 minutes max from the moment when i made the backup till the moment i tried to restore individual files.

Now that being said let me try to answer to your questions:

1. No no one else have access to this computer. I'm data protection officer and the laptop was well protected. I mean it has windows password authentication trigerred at 15 minutes of inactivity, and the hard drive which is a samsung SSD which has builtin hadrware encryption was encrypted via HDD password. And i was from the moment when i made the backup till the moment when i've tried to restore only me in front of the computer. I've tried anyway the hard disk encryption password and windows password as password for backup encryption cause i imagined that somehow it used one of the passwords enabled on computer. But no luck. Nor the windows password or hard drive encryption password are the right one for encrypted backup.
2. The target storage for backup was an external drive (1 TB Adata USB 3.0 harddrive) connected via usb directly to the laptop.
3. Yes i am sure that is asking for encrypted backup password, because the external usb drive where backup was stored does not have any kind of password protection.
4. No there is nothing left from old system because the hard drive from laptop as i said up is a samsung ssd of 250 gb which has TRIM enabled. I specifically chosen a ssd with TRIM because of data protection protocols in place. As you may be aware if TRIM is enabled anything deleted or formatted is lost for good. I anyway have tried to do some recovery with recuva and easeus data recovery but no luck, nothing is there to be recovered.

I cannot imagine how is possible to activate itself the encryption and what chances i have to get my client data back.

What i have tried so far:

1. opened a case on support with the hope of getting some help

2. i have tried as a backup password all password which was enabled on that laptop as hard drive encryption password or as a windows password but i repeat no luck.

3. I have installed the same windows 10 pro version operating system on that laptop and installed the same version of veeam agent for windows free (version 3.0.0.740) because i imagined that somehow if is the same computer and i use the same software version encryption key will be recreated identically, and i have tried to create a media recovery usb drive where i chose to insert the encryption key with the hope that if i boot from the recovery media and the keys are created identically, no matter how backup was encrypted, it will be automatically decrypted when i boot from recovery media.
BUT here is the strange thing happening 5 times (i have tried 5 times to create recovery media), it said that recovery media was created succesfully, but every time when i boot from it is just appear a cmd window on a green background and NOT appear as normally the green background with that 3 options, Bare metal, image recovery and tools.
I repeated this process 5 times with differed usb drives as media recovery, i even format and reinstall and install windows 10 pro and veeam agent for free version 3.0.0.740 again but no luck, media recovery drive is booting but it opening just a cmd windows on green background and says and do nothing.

Please help

All i have and i can upload here is the .vbm job file and the .vbk file which have 176 GB.

here are links with screenshot of asking for password and .vbm job file:

1. asking for password screenshot link: https://ibb.co/ZJRD0Jn

2. link for .vbm job file: https://we.tl/t-JdITifcowD

Egor Yakovlev
Veeam Software
Posts: 1587
Liked: 366 times
Joined: Jun 14, 2013 9:30 am
Full Name: Egor Yakovlev
Contact:

Re: Case id: #04445930 restoring from backup password problem

Post by Egor Yakovlev »

Thanks for update.
The case is on track(I see a senior T2 engineer has picked it up, so you are in good hands), however keep your expectations low - if backup is encrypted(reason to be found), there will be no chance of recovery without encryption password.
Please keep working with support engineer on case resolution.

Post Reply

Who is online

Users browsing this forum: No registered users and 16 guests