Exchange 2016 DAG - Application-Restores

Backup agent for Microsoft Windows servers and workstations (formerly Veeam Endpoint Backup FREE)

Exchange 2016 DAG - Application-Restores

Veeam Logoby Driehl » Thu Apr 20, 2017 6:22 pm

Hi I'm testing using EndPoint Backup 1.5 to backup an Exchange 2016 DAG to B&R 9.5. I've run the backup with the Copy only registry setting and it backed up successfully. However, when I try to use Veeam Explorer for Exchange to do an application level restore of an Exchange item no mailboxes are shown under the EDBs?

Any ideas why Application level restore is not working?
Driehl
Novice
 
Posts: 7
Liked: never
Joined: Thu Apr 20, 2017 6:03 pm
Full Name: Dave Riehl

Re: Exchange 2016 DAG - Application-Restores

Veeam Logoby Mike Resseler » Fri Apr 21, 2017 4:53 am

Hi Dave,

Can you check this page: https://helpcenter.veeam.com/docs/backu ... tml?ver=95 and have a look that the initial configuration has been done?

Thanks
Mike
Mike Resseler
Veeam Software
 
Posts: 3290
Liked: 366 times
Joined: Fri Feb 08, 2013 3:08 pm
Location: Belgium, the land of the fries, the beer, the chocolate and the diamonds...
Full Name: Mike Resseler

Re: Exchange 2016 DAG - Application-Restores

Veeam Logoby Driehl » Fri Apr 21, 2017 1:26 pm

Thanks for your reply, it is marked as configured with a green check. I also just tried repointing it to the ESE.dll off the Exchange server in question but that didn't work either.
Driehl
Novice
 
Posts: 7
Liked: never
Joined: Thu Apr 20, 2017 6:03 pm
Full Name: Dave Riehl

Re: Exchange 2016 DAG - Application-Restores

Veeam Logoby Driehl » Fri Apr 21, 2017 1:37 pm

Any chance this is related to Exchange 2016 CU5?

Just found this article: http://www.virtubytes.com/2017/04/17/ve ... cu5-issue/

Surprised this isn't splashed all over Veeams website
Driehl
Novice
 
Posts: 7
Liked: never
Joined: Thu Apr 20, 2017 6:03 pm
Full Name: Dave Riehl

Re: Exchange 2016 DAG - Application-Restores

Veeam Logoby Dima P. » Fri Apr 21, 2017 4:13 pm

Hi Dave,

This was posted in latest community digest :wink:
You may want to hold off upgrading to the recently released Cumulative Update 5 (KB4012106) if mailbox item-level recovery is important for you. A couple of customers who already upgraded reported us restore failures in Veeam Explorer for Exchange, and after researching those we have found the cause being the significant change in one mailbox database structure. We're now updating Veeam Explorer for Exchange to be able to parse the new blob format correctly, and are planning to include the fix in Veeam Backup & Replication 9.5 Update 2 - which we'll be delaying for about a week over this and a few other last minute issues
Dima P.
Veeam Software
 
Posts: 6391
Liked: 449 times
Joined: Mon Feb 04, 2013 2:07 pm
Location: SPb
Full Name: Dmitry Popov

Re: Exchange 2016 DAG - Application-Restores

Veeam Logoby bernd.dausch » Tue Aug 15, 2017 10:09 am

we have the same Problem with Exchange 2016 CU6 and Veeam 9.5 Update 2 Installed.

Is this a known Issue? Is the Problem fixed with Veeam 9.5 Update 2?

Kind Regards,

Bernd
bernd.dausch
Service Provider
 
Posts: 19
Liked: 1 time
Joined: Fri May 27, 2016 7:17 pm
Full Name: Bernd Dausch

Re: Exchange 2016 DAG - Application-Restores

Veeam Logoby Dima P. » Tue Aug 15, 2017 7:41 pm

Hello Bernd,

Mentioned issue was related to Exchange CU5 and corresponding fix was included in U2. Any chance you have a case opened and can share the case ID?
Dima P.
Veeam Software
 
Posts: 6391
Liked: 449 times
Joined: Mon Feb 04, 2013 2:07 pm
Location: SPb
Full Name: Dmitry Popov

Re: Exchange 2016 DAG - Application-Restores

Veeam Logoby bernd.dausch » Sat Aug 19, 2017 10:50 am

hello Dima,

i create the case on Monday an post the Case Id
bernd.dausch
Service Provider
 
Posts: 19
Liked: 1 time
Joined: Fri May 27, 2016 7:17 pm
Full Name: Bernd Dausch

Re: Exchange 2016 DAG - Application-Restores

Veeam Logoby Dima P. » Sun Aug 20, 2017 7:45 pm

Hi Bernd,

We need the actual case number (it may help us for further reference), once you receive it – please post it to this thread. Thank you in advance!
Dima P.
Veeam Software
 
Posts: 6391
Liked: 449 times
Joined: Mon Feb 04, 2013 2:07 pm
Location: SPb
Full Name: Dmitry Popov

Re: Exchange 2016 DAG - Application-Restores

Veeam Logoby bernd.dausch » Mon Aug 21, 2017 7:38 am 1 person likes this post

Hi Dima,

I have opened a case id 02286367.
bernd.dausch
Service Provider
 
Posts: 19
Liked: 1 time
Joined: Fri May 27, 2016 7:17 pm
Full Name: Bernd Dausch

Re: Exchange 2016 DAG - Application-Restores

Veeam Logoby bernd.dausch » Wed Aug 23, 2017 2:26 pm

The Support send me a new DLL for the Exchange Explorer. The Invalid Blob Messages are gone.
At the moment i can export more objects from the database (90%) but have "Invalid Elements"

The Support has collected more logfiles and is reviewing the logfiles.
bernd.dausch
Service Provider
 
Posts: 19
Liked: 1 time
Joined: Fri May 27, 2016 7:17 pm
Full Name: Bernd Dausch

Re: Exchange 2016 DAG - Application-Restores

Veeam Logoby Regnor » Thu Aug 31, 2017 5:46 pm

It has only been a week, but how did your case go?
I'm also seeing invalid blob messages when trying to restore to PST with CU5. I will look closer at this issue tomorrow and see if we need to contact support.
By the way which version shoud the current Exchange Explorer have?
Regnor
Veeam ProPartner
 
Posts: 91
Liked: 21 times
Joined: Mon Jan 31, 2011 11:17 am

Re: Exchange 2016 DAG - Application-Restores

Veeam Logoby Regnor » Fri Sep 01, 2017 8:36 am

So in our case it looks like some objects are causing the "Invalid Blob" errors.
PST-Export in general works, except for some mailboxes.
Regnor
Veeam ProPartner
 
Posts: 91
Liked: 21 times
Joined: Mon Jan 31, 2011 11:17 am

Re: Exchange 2016 DAG - Application-Restores

Veeam Logoby Dima P. » Fri Sep 01, 2017 12:57 pm

Regnor,

According to the case details it is 9.5 U2. If you have this issue please open a case and request a fix. Thanks.
Dima P.
Veeam Software
 
Posts: 6391
Liked: 449 times
Joined: Mon Feb 04, 2013 2:07 pm
Location: SPb
Full Name: Dmitry Popov

Re: Exchange 2016 DAG - Application-Restores

Veeam Logoby Regnor » Fri Sep 01, 2017 1:44 pm

Hi Dima,
I was speaking of the fileversion of Veeam.Exchange.Explorer.exe; it shows 9.5.0.950 although it came with 9.5U2 which is 9.5.0.1338.
Regnor
Veeam ProPartner
 
Posts: 91
Liked: 21 times
Joined: Mon Jan 31, 2011 11:17 am

Next

Return to Veeam Agent for Windows



Who is online

Users browsing this forum: Bing [Bot] and 11 guests