Standalone backup agent for Microsoft Windows servers and workstations (formerly Veeam Endpoint Backup FREE)
Post Reply
perjonsson1960
Enthusiast
Posts: 79
Liked: 5 times
Joined: Jun 06, 2018 5:41 am
Full Name: Per Jonsson
Location: Sweden
Contact:

Failed agent backup

Post by perjonsson1960 » Feb 08, 2019 8:01 am

Folks,

We have recently installed B&R 9.5 Update 4 and Agent for Windows 3.0.0.748 in our 13 physical servers. And during the night we suddenly got this error for one of the servers:

Task failed. Error: Exception from HRESULT: 0xFFFFFFFF

Is this a known issue with Update 4 and Agent 3.0? Is there anything we can try, short of rebooting the affected server? Restart the Veeam services in that server? All our agent backups are managed from the Veeam backup server, if that is relevant in this case.

Sincerely,
Per Jonsson
Sweden

wishr
Veeam Software
Posts: 623
Liked: 60 times
Joined: Aug 07, 2018 3:11 pm
Full Name: Fedor Maslov
Contact:

Re: Failed agent backup

Post by wishr » Feb 08, 2019 8:11 am

Hi Per,

Have you been able to report this issue to our support team? If not, that's the best way to get a solution since we require to take a look at the log files, etc. Please post your case ID here, so we'll be able to understand the details.

Thanks,
Fedor

perjonsson1960
Enthusiast
Posts: 79
Liked: 5 times
Joined: Jun 06, 2018 5:41 am
Full Name: Per Jonsson
Location: Sweden
Contact:

Re: Failed agent backup

Post by perjonsson1960 » Feb 08, 2019 9:04 am

Case ID 03405254

perjonsson1960
Enthusiast
Posts: 79
Liked: 5 times
Joined: Jun 06, 2018 5:41 am
Full Name: Per Jonsson
Location: Sweden
Contact:

Re: Failed agent backup

Post by perjonsson1960 » Feb 11, 2019 8:02 am 1 person likes this post

Folks,

The problem was caused by a failed WMI query. Veeam B&R couldn't get the OS version from the affected server. A restart of the server solved the problem.

PJ

perjonsson1960
Enthusiast
Posts: 79
Liked: 5 times
Joined: Jun 06, 2018 5:41 am
Full Name: Per Jonsson
Location: Sweden
Contact:

Re: Failed agent backup

Post by perjonsson1960 » Feb 12, 2019 2:22 pm

I spoke too soon... The first backup done after the restart went well, but the second backup failed with the same error. So I have opened a new case with ID 03410496, referring to the old case. I hope that they can get some additional info from the logfiles. So no one else has had this problem after installning Update 4 and Agent 3.0? We have 13 physical Windows servers, and only one is acting up like this after the update...

Dima P.
Product Manager
Posts: 9782
Liked: 774 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: Failed agent backup

Post by Dima P. » Feb 12, 2019 2:36 pm

PJ,

Thank you for sharing the update and sorry to hear that you still have this issue. I've asked our QA team to review your case details, meanwhile please keep working with our support team. Cheers!

perjonsson1960
Enthusiast
Posts: 79
Liked: 5 times
Joined: Jun 06, 2018 5:41 am
Full Name: Per Jonsson
Location: Sweden
Contact:

Re: Failed agent backup

Post by perjonsson1960 » Feb 14, 2019 12:35 pm

It seems that the WMI service stops responding at some point during the day. If we restart the WMI service sometime towards the end of the day, then the backup during the night succeeds, but if we don't, then the backup fails. The only things we have done recently is updating the Veeam Agent to v3.0 and run some Windows Updates up through cumulative update 2019.1. We have not yet installed 2019.2. The server version is 2008 R2 SP1.

perjonsson1960
Enthusiast
Posts: 79
Liked: 5 times
Joined: Jun 06, 2018 5:41 am
Full Name: Per Jonsson
Location: Sweden
Contact:

Re: Failed agent backup

Post by perjonsson1960 » Feb 15, 2019 9:45 am 1 person likes this post

Yesterday evening I restarted the WMI service, and the backup during the night succeeded. Since no one else here seems to have the same problem after installing Update 4 and Agent 3.0, it seems that this is a WMI problem locally in our server.

PJ

Dima P.
Product Manager
Posts: 9782
Liked: 774 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: Failed agent backup

Post by Dima P. » Feb 15, 2019 6:11 pm

Hi PJ,

Thanks for sharing the updates. Indeed, we do not control WMI, but it must be well functioning for the agent management proper work. Let us know how it goes!

Post Reply

Who is online

Users browsing this forum: No registered users and 14 guests