Standalone backup agent for Microsoft Windows servers and workstations (formerly Veeam Endpoint Backup FREE)
Post Reply
horaceho
Influencer
Posts: 10
Liked: never
Joined: Nov 27, 2017 3:24 am
Full Name: Horace
Contact:

Failed re-install windows Agent

Post by horaceho » Jun 25, 2019 5:10 am

Hi all,
I had a windows agent need to migrate the agent from Veeam Server to another new Veeam Server,
after I uninstall the Veeam agent and re-install that it's failed to install with error "Failed to acquire agent managed by (the old VBR Server)" -
and
“Veeam Agent for Microsoft Windows cannot be configured, because it is managed by your system administrator." -

HannesK
Veeam Software
Posts: 3696
Liked: 440 times
Joined: Sep 01, 2014 11:46 am
Location: Austria
Contact:

Re: Failed re-install windows Agent

Post by HannesK » Jun 25, 2019 6:05 am

Hello,
are you using the central deployment option from VBR or are you installing locally on the machine and then manually connect to a Veeam repository?

Did you also uninstall the Veeam installer service?

Best regards,
Hannes

horaceho
Influencer
Posts: 10
Liked: never
Joined: Nov 27, 2017 3:24 am
Full Name: Horace
Contact:

Re: Failed re-install windows Agent

Post by horaceho » Jun 25, 2019 7:14 am

Hi ,

2 of this I had tried , the first error message was show while I using deploy option and the 2nd message is from install locally .

Also I had uninstall the installer services and restarted the server.

HannesK
Veeam Software
Posts: 3696
Liked: 440 times
Joined: Sep 01, 2014 11:46 am
Location: Austria
Contact:

Re: Failed re-install windows Agent

Post by HannesK » Jun 25, 2019 7:45 am

Hello,
I cannot reproduce it. It works fine for me.

I suggest to contact support. Please post the case number here for reference.

I did the following:
- VBR1: "uninstall all components" from one of the servers in one of my protection groups
- VBR2: create new job with individual computer & run backup job
- VBR2: "uninstall all components"
- VBR1: install agent again

no issues

I also tested to add the agent on VBR1 while it was managed by VBR2. This was not possible, but this is correct and expected.


Best regards,
Hannes

horaceho
Influencer
Posts: 10
Liked: never
Joined: Nov 27, 2017 3:24 am
Full Name: Horace
Contact:

Re: Failed re-install windows Agent

Post by horaceho » Jun 25, 2019 7:58 am

Hi,

I don’t know , there are a 3 node cluster servers and I had migrate the a and d node was success but it’s failed for the C node.

Support advise me for re install to the old VBR but it’s still failed after tried .

Case # 03628214

HannesK
Veeam Software
Posts: 3696
Liked: 440 times
Joined: Sep 01, 2014 11:46 am
Location: Austria
Contact:

Re: Failed re-install windows Agent

Post by HannesK » Jun 25, 2019 9:41 am

I just reviewed the case and I have nothing to add. There must be some leftovers on the C node for whatever reason (I don't understand which registry was checked already by you / support). Support is the only one who can help in that situation.

horaceho
Influencer
Posts: 10
Liked: never
Joined: Nov 27, 2017 3:24 am
Full Name: Horace
Contact:

Re: Failed re-install windows Agent

Post by horaceho » Jun 25, 2019 3:28 pm

Hi Hannes,

is it any way to fully uninstall Veeam Agent ? thank you.

HannesK
Veeam Software
Posts: 3696
Liked: 440 times
Joined: Sep 01, 2014 11:46 am
Location: Austria
Contact:

Re: Failed re-install windows Agent

Post by HannesK » Jun 25, 2019 3:34 pm

Hello,
yes, by clicking "uninstall" - but that failed obviously. Please escalate the case in the support portal if things are not going forward.

Best regards,
Hannes

horaceho
Influencer
Posts: 10
Liked: never
Joined: Nov 27, 2017 3:24 am
Full Name: Horace
Contact:

Re: Failed re-install windows Agent

Post by horaceho » Jun 25, 2019 10:07 pm

Thanks Hannes

horaceho
Influencer
Posts: 10
Liked: never
Joined: Nov 27, 2017 3:24 am
Full Name: Horace
Contact:

Re: Failed re-install windows Agent

Post by horaceho » Jul 04, 2019 2:24 am

after support troubleshoots, it's solved by install cert to the agent client and re-install to the old VBR server and uninstall.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests