Standalone backup agent for Microsoft Windows servers and workstations (formerly Veeam Endpoint Backup FREE)
Regnor
Service Provider
Posts: 355
Liked: 70 times
Joined: Jan 31, 2011 11:17 am
Full Name: Max
Contact:

Installation fails (SQLLocalDB)

Post by Regnor » Dec 08, 2014 1:16 pm

I've tried to install VEB on a rather old workstation with Windows 7 installed. The setup tries to start the services and fails with a timeout.
It looks like the problem is related to the SQL LocalDB; I've found a program folder for an existing "SQL Server Compact Edition" but because of the age of the workstation I don't really know which software depends on this installation.

SQLLocalDB 11.0 Error 528:
Windows API call WaitForMultipleObjects returned error code: 575. Windows system error message is: {Fehler in Anwendung}
Die Anwendung konnte nicht ordnungsgemäß gestartet werden (0x%lx). Klicken Sie auf "OK", um die Anwendung zu beenden.
Reported at line: 3621.
Followed by Veeam Endpoint Backup Service Error 0:
Der Dienst kann nicht gestartet werden. System.Exception: Error occurred during LocalDB instance startup: SQL Server process failed to start.

bei Veeam.Common.CSqlLocalDb.ThrowLocalDbException(Int32 errorCode, String function)
bei Veeam.Common.CSqlLocalDb.StartInstance(String instanceName)
bei Veeam.Common.CSqlLocalDbInstance.Start()
bei Veeam.EndPoint.CEndPointServiceImpl.PrepareSqlInstance()
bei Veeam.EndPoint.CEndPointServiceImpl..ctor(CVbOptions options, CTerminationMediator terminator, CExternalEventsWatcher externalEventsWatcher)
bei Veeam.EndPoint.EndPointService.OnStart(String[] args)
bei System.ServiceProcess.ServiceBase.ServiceQueuedMainCallback(Object state)

Dima P.
Product Manager
Posts: 11038
Liked: 919 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: Installation fails (SQLLocalDB)

Post by Dima P. » Dec 08, 2014 5:04 pm

QA is investigating this.

Keyser
Enthusiast
Posts: 43
Liked: 5 times
Joined: Feb 13, 2014 10:11 am
Contact:

Re: Installation fails (SQLLocalDB)

Post by Keyser » Dec 09, 2014 2:41 pm 1 person likes this post

Just a qucik note.

If you have a restart pending for other reasons then the installer will install the first SQL part and then ask for a restart. If you elect not to restart the installation will fail with a big error.

If you elect to restart the installer does not continue after restart and you have to start over manually.

Not a big issue, just so you know.

Dima P.
Product Manager
Posts: 11038
Liked: 919 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: Installation fails (SQLLocalDB)

Post by Dima P. » Dec 09, 2014 9:54 pm

Regnor,
Sorry for the delay QA is still drilling the logs.

Regnor
Service Provider
Posts: 355
Liked: 70 times
Joined: Jan 31, 2011 11:17 am
Full Name: Max
Contact:

Re: Installation fails (SQLLocalDB)

Post by Regnor » Dec 10, 2014 11:07 am

No problem; it's a beta :)

Dima P.
Product Manager
Posts: 11038
Liked: 919 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: Installation fails (SQLLocalDB)

Post by Dima P. » Dec 11, 2014 11:06 am

Sorry for taking this so long.

Here is what we found – the existing local db components where locked during the installation by other application (or possibly SQL itself), so setup requested a restart and then was timed out it could not get access to these components in time. It may happen that you asked to restart during the Endpoint set due the SQL requirements, issues or updates. We actually received several cases with the same issue when existing SQL was updating itself and the PC was not restarted in proper period of time.

Did you try to run a new install after restart? Was it successful?

Regnor
Service Provider
Posts: 355
Liked: 70 times
Joined: Jan 31, 2011 11:17 am
Full Name: Max
Contact:

Re: Installation fails (SQLLocalDB)

Post by Regnor » Dec 11, 2014 11:26 am

When you say new install after restart, do you mean just run the install over the existing installation(which was aborted) or first completely uninstall VEB und run a fresh installation?
Setup itself didn't tell me that it needed a restart but I did try that and also logged on with a different user. Everytime I first uninstalled the VEB components and then tried to install it again --> same problem.

EDIT: In the case of the existing SQL installation; does VEB change/update anything on this SQL instance? If so, we would have to look for any compability issues.

Dima P.
Product Manager
Posts: 11038
Liked: 919 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: Installation fails (SQLLocalDB)

Post by Dima P. » Dec 11, 2014 11:39 am

Yes. Try to:

- uninstall Endpoint completely
- reboot your computer
- run the installation again
- if required, reboot again

Regnor
Service Provider
Posts: 355
Liked: 70 times
Joined: Jan 31, 2011 11:17 am
Full Name: Max
Contact:

Re: Installation fails (SQLLocalDB)

Post by Regnor » Dec 11, 2014 12:00 pm

Ok; I did try that and it didn't work.
But give me an hour or so, I'll clone the client and do some testing at my desk.

Regnor
Service Provider
Posts: 355
Liked: 70 times
Joined: Jan 31, 2011 11:17 am
Full Name: Max
Contact:

Re: Installation fails (SQLLocalDB)

Post by Regnor » Dec 12, 2014 7:17 am

I've tried it again; after a few minutes I'm getting the error that the service couldn't start and then after some time a SQL error is displayed.
If I choose to continue the 'starting services' windows stays and nothing happens after that.

Dima P.
Product Manager
Posts: 11038
Liked: 919 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: Installation fails (SQLLocalDB)

Post by Dima P. » Dec 12, 2014 1:47 pm

Regnor,
QA got the following idea: we would need to find out what application still uses the existing localdb, since its locking the instance and would not allow Endpoint to use it. Possibly, you could send us a list of the installed applications so we could try to investigate the blocker?

Dima P.
Product Manager
Posts: 11038
Liked: 919 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: Installation fails (SQLLocalDB)

Post by Dima P. » Dec 17, 2014 3:03 pm

Hello Max,
I am sorry for taking so long to respond. We reviewed the application list you've sent and it seems none of these could lock the local db. What you can try to do is manually delete the endpoint instance and re install the Veeam Endpoint from scratch. Here is an instruction:

- Before you go ,please, double check you have the Microsoft SQL Server 2012 Express LocalDB
- Check Veeam Endpoint Backup is not listed in the ‘Programs and Features’ If yes – uninstall it
- Download PSTools: http://download.sysinternals.com/files/PSTools.zip
- Install it. (for ease of use it could be unpacked to C:\PSTools\)
- Go to Run > cmd as administrator
- cd C:\PSTools (or the folder you used for during unpacking)
- Run PsExec.exe –i –s cmd.exe (the user agreement message may pop up )
- New command line would appear. Make sure its running under nt authority\system by running whoami
- In the new command prompt type in “C:\Program Files\Microsoft SQL Server\110\Tools\Binn\SqlLocalDB.exe” delete VeeamEndPoint (with quotes)
- If you see the message “LocalBD instance “VeeamEndPoint” deleted” then you can procceed to the new Veeam Endpoint Installation.

Let me know if that works. Thank you.

Regnor
Service Provider
Posts: 355
Liked: 70 times
Joined: Jan 31, 2011 11:17 am
Full Name: Max
Contact:

Re: Installation fails (SQLLocalDB)

Post by Regnor » Dec 17, 2014 3:42 pm

Hello Dima,

I'm out off office for the next two weeks.
Do we have the time to wait till I'm back or shall a call a colleague, so that he can execute your instructions?

Dima P.
Product Manager
Posts: 11038
Liked: 919 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: Installation fails (SQLLocalDB)

Post by Dima P. » Dec 17, 2014 3:59 pm

Max,
No rush - so it’s up to you.

ender
Novice
Posts: 8
Liked: 3 times
Joined: Dec 23, 2014 10:50 am
Contact:

Re: Installation fails (SQLLocalDB)

Post by ender » Dec 23, 2014 4:25 pm

I have a very similar same problem on my workstation, running Windows 8.1 Pro x64 (Slovenian language version). The installer gets to "Starting services", then hangs there for a few minutes and complains that it failed to start service ‘Veeam EndPoint Backup Service'. If I click Cancel, I then get an SQL error a few minutes later:

Code: Select all

See the end of this message for details on invoking 
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
Veeam.Backup.Common.CSqlException: Microsoft SQL server hosting the configuration database is currently unavailable. Possible reasons are heavy load, networking issue, server reboot, or hot backup.
Please wait, and try again later.

Error information:
SQL server is not available
   at Veeam.Backup.Common.CExceptionUtil.ThrowSqlException(Exception innerException)
   at Veeam.Backup.DBManager.CDbAccessor.ExecDataReader(String spName, CommandBehavior commandBehavior, Int32 timeoutSeconds, SqlParameter[] spParams)
   at Veeam.Backup.DBManager.CBackupJobsDbScope.GetBackupJobs()
   at Veeam.Backup.Core.CBackupJob.GetAll()
   at Veeam.EndPoint.Backup.CEpBackupJobHelper.FindJob()


************** Loaded Assemblies **************
mscorlib
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.34014 built by: FX45W81RTMGDR
    CodeBase: file:///W:/Windows/Microsoft.NET/Framework64/v4.0.30319/mscorlib.dll
----------------------------------------
Veeam.Setup.Wizard
    Assembly Version: 2.0.0.3
    Win32 Version: 2.0.0.3
    CodeBase: file:///W:/Users/ender/AppData/Local/Temp/RarSFX1/EndPoint/Suite/Veeam.Setup.Wizard.dat
----------------------------------------
Veeam.Setup.Common
    Assembly Version: 1.0.0.10
    Win32 Version: 1.0.0.10
    CodeBase: file:///W:/Users/ender/AppData/Local/Temp/RarSFX1/EndPoint/Suite/Veeam.Setup.Common.DLL
----------------------------------------
Veeam.Setup.MsiLibrary
    Assembly Version: 1.0.0.3
    Win32 Version: 1.0.0.3
    CodeBase: file:///W:/Users/ender/AppData/Local/Temp/RarSFX1/EndPoint/Suite/Veeam.Setup.MsiLibrary.DLL
----------------------------------------
System.Windows.Forms
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.33440 built by: FX45W81RTMREL
    CodeBase: file:///W:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System.Drawing
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.33440 built by: FX45W81RTMREL
    CodeBase: file:///W:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.34239 built by: FX452RTMGDR
    CodeBase: file:///W:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Xml.Linq
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.33440 built by: FX45W81RTMREL
    CodeBase: file:///W:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Xml.Linq/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.Linq.dll
----------------------------------------
System.Core
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.33440 built by: FX45W81RTMREL
    CodeBase: file:///W:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
----------------------------------------
System.Xml
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.34230 built by: FX452RTMGDR
    CodeBase: file:///W:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
System.Configuration
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.33440 built by: FX45W81RTMREL
    CodeBase: file:///W:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
Veeam.Setup.EndPointSetup
    Assembly Version: 8.0.0.1822
    Win32 Version: 8.0.0.1822
    CodeBase: file:///W:/Users/ender/AppData/Local/Temp/RarSFX1/EndPoint/Suite/Veeam.Setup.EndPointSetup.DLL
----------------------------------------
Veeam.Setup.PrereqEngine
    Assembly Version: 2.0.0.1
    Win32 Version: 2.0.0.1
    CodeBase: file:///W:/Users/ender/AppData/Local/Temp/RarSFX1/EndPoint/Suite/Veeam.Setup.PrereqEngine.DLL
----------------------------------------
Accessibility
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.33440 built by: FX45W81RTMREL
    CodeBase: file:///W:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/Accessibility/v4.0_4.0.0.0__b03f5f7f11d50a3a/Accessibility.dll
----------------------------------------
System.ServiceProcess
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.33440 built by: FX45W81RTMREL
    CodeBase: file:///W:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.ServiceProcess/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.ServiceProcess.dll
----------------------------------------
Veeam.EndPoint.Core
    Assembly Version: 8.0.0.0
    Win32 Version: 8.0.0.1822
    CodeBase: file:///W:/Program%20Files/Veeam/EndPoint%20Backup/Veeam.EndPoint.Core.dll
----------------------------------------
Veeam.EndPoint.Common
    Assembly Version: 1.0.0.0
    Win32 Version: 8.0.0.1822
    CodeBase: file:///W:/Program%20Files/Veeam/EndPoint%20Backup/Veeam.EndPoint.Common.dll
----------------------------------------
Veeam.Backup.Common
    Assembly Version: 8.0.0.0
    Win32 Version: 8.0.0.1822
    CodeBase: file:///W:/Program%20Files/Veeam/EndPoint%20Backup/Veeam.Backup.Common.dll
----------------------------------------
Veeam.Backup.Configuration
    Assembly Version: 8.0.0.0
    Win32 Version: 8.0.0.1822
    CodeBase: file:///W:/Program%20Files/Veeam/EndPoint%20Backup/Veeam.Backup.Configuration.DLL
----------------------------------------
Veeam.Backup.Core.Common
    Assembly Version: 8.0.0.0
    Win32 Version: 8.0.0.1822
    CodeBase: file:///W:/Program%20Files/Veeam/EndPoint%20Backup/Veeam.Backup.Core.Common.DLL
----------------------------------------
Veeam.Backup.Model
    Assembly Version: 8.0.0.0
    Win32 Version: 8.0.0.1822
    CodeBase: file:///W:/Program%20Files/Veeam/EndPoint%20Backup/Veeam.Backup.Model.DLL
----------------------------------------
Veeam.Backup.Core
    Assembly Version: 8.0.0.0
    Win32 Version: 8.0.0.1822
    CodeBase: file:///W:/Program%20Files/Veeam/EndPoint%20Backup/Veeam.Backup.Core.DLL
----------------------------------------
Veeam.Backup.DBManager
    Assembly Version: 8.0.0.0
    Win32 Version: 8.0.0.1822
    CodeBase: file:///W:/Program%20Files/Veeam/EndPoint%20Backup/Veeam.Backup.DBManager.DLL
----------------------------------------
System.Security
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.33440 built by: FX45W81RTMREL
    CodeBase: file:///W:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Security/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Security.dll
----------------------------------------
Veeam.Backup.DBAccessor
    Assembly Version: 8.0.0.0
    Win32 Version: 8.0.0.1822
    CodeBase: file:///W:/Program%20Files/Veeam/EndPoint%20Backup/Veeam.Backup.DBAccessor.DLL
----------------------------------------
Veeam.Tape.Database
    Assembly Version: 8.0.0.0
    Win32 Version: 8.0.0.1822
    CodeBase: file:///W:/Program%20Files/Veeam/EndPoint%20Backup/Veeam.Tape.Database.DLL
----------------------------------------
Veeam.Tape.Model
    Assembly Version: 8.0.0.0
    Win32 Version: 8.0.0.1822
    CodeBase: file:///W:/Program%20Files/Veeam/EndPoint%20Backup/Veeam.Tape.Model.DLL
----------------------------------------
System.Data
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.33440 built by: FX45W81RTMREL
    CodeBase: file:///W:/WINDOWS/Microsoft.Net/assembly/GAC_64/System.Data/v4.0_4.0.0.0__b77a5c561934e089/System.Data.dll
----------------------------------------
System.Transactions
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.33440 built by: FX45W81RTMREL
    CodeBase: file:///W:/WINDOWS/Microsoft.Net/assembly/GAC_64/System.Transactions/v4.0_4.0.0.0__b77a5c561934e089/System.Transactions.dll
----------------------------------------
System.EnterpriseServices
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.33440 built by: FX45W81RTMREL
    CodeBase: file:///W:/WINDOWS/Microsoft.Net/assembly/GAC_64/System.EnterpriseServices/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.EnterpriseServices.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
    <system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.
I tried the suggestions from this thread, but they don't work (the end result is the same).

Since this is the computer I use daily, it already has a bunch of stuff installed, including several versions of Visual Studio and the included SQL Servers.

Dima P.
Product Manager
Posts: 11038
Liked: 919 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: Installation fails (SQLLocalDB)

Post by Dima P. » Dec 23, 2014 5:03 pm

ender,
Just to clarify, you tried to remove the Endpoint loacldb instance via PSTools, right?

ender
Novice
Posts: 8
Liked: 3 times
Joined: Dec 23, 2014 10:50 am
Contact:

Re: Installation fails (SQLLocalDB)

Post by ender » Dec 23, 2014 6:10 pm

Yes. It was removed successfully, but after restart the install failed in the same way (if I tried reinstalling without restarting first, the installer failed sooner, and did a rollback).

Dima P.
Product Manager
Posts: 11038
Liked: 919 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: Installation fails (SQLLocalDB)

Post by Dima P. » Dec 23, 2014 9:22 pm

Got it, thanks for the heads up - forwarding back to QA. Let you know the results as soon as possible.

Dima P.
Product Manager
Posts: 11038
Liked: 919 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: Installation fails (SQLLocalDB)

Post by Dima P. » Dec 24, 2014 11:35 am

Hello ender,
According to QA the issue you faced is related to the installation of the .NET Framework and it’s not similar to the OP problem. Could you please provide us the full setup logs (C:\ProgramData\Veeam) and Windows Event logs (Custom View > Administrative events)? You can upload it to dropbox or onedrive and send me PM with the download link. Thank you in advance.

Regnor
Service Provider
Posts: 355
Liked: 70 times
Joined: Jan 31, 2011 11:17 am
Full Name: Max
Contact:

Re: Installation fails (SQLLocalDB)

Post by Regnor » Jan 05, 2015 9:41 am 1 person likes this post

d.popov wrote:Hello Max,
I am sorry for taking so long to respond. We reviewed the application list you've sent and it seems none of these could lock the local db. What you can try to do is manually delete the endpoint instance and re install the Veeam Endpoint from scratch. Here is an instruction:

- Before you go ,please, double check you have the Microsoft SQL Server 2012 Express LocalDB
- Check Veeam Endpoint Backup is not listed in the ‘Programs and Features’ If yes – uninstall it
- Download PSTools: http://download.sysinternals.com/files/PSTools.zip
- Install it. (for ease of use it could be unpacked to C:\PSTools\)
- Go to Run > cmd as administrator
- cd C:\PSTools (or the folder you used for during unpacking)
- Run PsExec.exe –i –s cmd.exe (the user agreement message may pop up )
- New command line would appear. Make sure its running under nt authority\system by running whoami
- In the new command prompt type in “C:\Program Files\Microsoft SQL Server\110\Tools\Binn\SqlLocalDB.exe” delete VeeamEndPoint (with quotes)
- If you see the message “LocalBD instance “VeeamEndPoint” deleted” then you can procceed to the new Veeam Endpoint Installation.

Let me know if that works. Thank you.
Hello Dima,

it worked :)
I have deleted the LocalDB and after that could successfully install VEB.
I also already created a backup and restored it baremetal without any problems :)

Mike Resseler
Product Manager
Posts: 5891
Liked: 650 times
Joined: Feb 08, 2013 3:08 pm
Full Name: Mike Resseler
Location: Belgium
Contact:

Re: Installation fails (SQLLocalDB)

Post by Mike Resseler » Jan 05, 2015 9:55 am

Regnor,

Thanks a lot for letting us know! Enjoy "playing" ;-) with VEB and keep us informed

cheers

Mike

Dima P.
Product Manager
Posts: 11038
Liked: 919 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: Installation fails (SQLLocalDB)

Post by Dima P. » Jan 05, 2015 1:57 pm

Hi Max,
Thanks for the heads up – now we have a confirmed resolution. Kudos to our QA team and again big thanks to your for testing.

Regnor
Service Provider
Posts: 355
Liked: 70 times
Joined: Jan 31, 2011 11:17 am
Full Name: Max
Contact:

Re: Installation fails (SQLLocalDB)

Post by Regnor » Jan 05, 2015 5:59 pm

d.popov wrote:Hi Max,
Thanks for the heads up – now we have a confirmed resolution. Kudos to our QA team and again big thanks to your for testing.
Also give the QA team a big thank you from me

tallpr24
Influencer
Posts: 11
Liked: never
Joined: Dec 11, 2014 7:23 pm
Full Name: kenneth santiago
Contact:

Re: Installation fails (SQLLocalDB)

Post by tallpr24 » Jan 19, 2015 4:40 pm

Hi, im having the same issue, except that when i run the command to remove db, its sayd db not found (probably removed when i did the veeam endpoint uninstall). i have uninstalled everything including ms sql applications, but yet , when i try to re installe veeam endpoint backup its still gets stuck on starting services.

any help would be greatly appreciate it.
"Life would be so much easier if we only had the source code."

Dima P.
Product Manager
Posts: 11038
Liked: 919 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: Installation fails (SQLLocalDB)

Post by Dima P. » Jan 19, 2015 8:40 pm

Kenneth,
Just to clarify – you used the described solution via PS tools? In addition, we received several cases with antivirus blocking the setup – so any scanner installed in your environment?

Please, share the full setup logs C:\ProgramData\Veeam and Windows Event logs Custom View > Administrative events via any suitable cloud storage (Dropbox/OneDrive/Google Drive)? Thank you

Dima P.
Product Manager
Posts: 11038
Liked: 919 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: Installation fails (SQLLocalDB)

Post by Dima P. » Jan 20, 2015 5:08 pm

Guys,
We have prepared the following instructions for anyone who faced the installation issues. It’s kinda massive’ so we’ve spliced it into two cases.

Dima P.
Product Manager
Posts: 11038
Liked: 919 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: Installation fails (SQLLocalDB)

Post by Dima P. » Jan 20, 2015 5:10 pm 1 person likes this post

Please note: this solution is considered to be obsolete

Errors:

Code: Select all

Error occurred during LocalDB instance startup: SQL Server process failed to start 

Veeam.Backup.Common.CSqlException: Microsoft SQL server hosting the configuration database is currently unavailable. Possible reasons are heavy load, networking issue, server reboot, or hot backup.
Please wait, and try again later. 
Preparation:

1. Before you go, check:
- Your antivirus is not blocking the installation process.
- Microsoft SQL Server 2012 Express LocalDB is installed. If you have any installation issues - the best option is to install the version included in the setup
- SYSTEM accout has full access permissions to systemprofile folder C:\Windows\System32\config\systemprofile

2. Download, install and open PS Tools:
- Download PSTools: http://download.sysinternals.com/files/PSTools.zip
- Install it, for ease of use it could be unpacked to C:\PSTools\
- Go to Run > cmd as administrator
- cd C:\PSTools (or the folder you used for during unpacking)
- Run PsExec.exe –i –s cmd.exe (accept the user agreement message may pop up )
3. Uninstall Veeam Endpoint Backup BETA via Control Panel > Programs and Features


Resolutions:

Case A: Instance was corrupted during setup and must be deleted:

1. Download, install and open PS Tools like described in preparation step 2
2. Delete corrupted instance by typing the following commands in PS Tools command prompt:

Code: Select all

whoami 
//Response nt authority\system
 “C:\Program Files\Microsoft SQL Server\110\Tools\Binn\SqlLocalDB.exe” delete VeeamEndPoint 
//Response: “LocalBD instance “VeeamEndPoint” deleted”
3. Reboot and to install Veeam Endpoint Backup.

Case B: The Case A solution did not help. Instance creation continues to fail during Endpoint setup.

1. Install the following components (reboot if required for each component):
- Microsoft System CLR Types for SQL Server 2012 (is included in Endpoint setup)
- Microsoft SQL Server 2012 Management Objects (is included in Endpoint setup)
- Microsoft SQL Server 2012 Express LocalBD (is included in Endpoint setup)
- Microsoft SQL Server 2012 Native Client
- Microsoft SQL Server 2012 Command Line Utilities

2. Add the following string values for SQL instance login/password in the registry via regedit.exe

Code: Select all

 HKEY_LOCAL_MACHINE\SOFTWARE\Veeam\Veeam Endpoint Backup
//the following string values generated by QA
"SqlLogin"="VeeamLogin"
"SqlPassword"="75f00cdb-d8db-45ab-8024-8cc576df15b1"
3. Download, install and open PS Tools like described in preparation step 2
4. Re create the instance by typing the following commands in PS Tools command prompt:

Code: Select all

 whoami 
//Response nt authority\system
 “C:\Program Files\Microsoft SQL Server\110\Tools\Binn\SqlLocalDB.exe” delete VeeamEndPoint 
//Response: “LocalBD instance “VeeamEndPoint” deleted”
SqlLocalDB create VeeamEndPoint 
//Response: “LocalBD instance “VeeamEndPoint” created with version 11.0.”
SqlLocalDB start VeeamEndPoint 
//Response: “LocalBD instance “VeeamEndPoint” started”
SqlLocalDB info VeeamEndPoint 
//Response example (12345678 is an example – you will have other output): “Instance pipe name: np:\\.\pipe\LOCALDB#12345678\tsql\query”
//Copy np:\\.\pipe\LOCALDB#12345678\tsql\query from the previous query
sqlcmd -S np:\\.\pipe\LOCALDB#12345678\tsql\query 
// Command prompt cursor will change to 1>
// Type in each line and hit enter one by one
USE [master]
GO
CREATE LOGIN [VeeamLogin] WITH PASSWORD=N'75f00cdb-d8db-45ab-8024-8cc576df15b1', DEFAULT_DATABASE=[master], CHECK_EXPIRATION=OFF, CHECK_POLICY=OFF
GO
EXEC master..sp_addsrvrolemember @loginame = N'VeeamLogin', @rolename = N'sysadmin'
GO
EXIT
// Command prompt cursor revert back to normal 
SqlLocalDB stop VeeamEndPoint 
// Response “LocalBD instance “VeeamEndPoint” stopped”
Additionally:
- Microsoft SQL Server 2012 Native Client and Microsoft SQL Server 2012 Command Line Utilities can be found here: http://www.microsoft.com/en-US/download ... x?id=29065

If the LocalDB and sqlcmd fail:
During LocalDB and sqlcmd installation path variables are automatically pushed into the system. If SqlLocalDB or sqlcmd commands fail, you may need to type a full path instead:
- SqlLocalDB should be replaced by “%Program Files%\Microsoft SQL Server\110\Tools\Binn\SqlLocalDB.exe” (with quotes)
- sqlcmd should be replaced by “%Program Files%\Microsoft SQL Server\110\Tools\Binn\SqlCmd.exe” (with quotes)

Still having installation issues?
Collect and share:
- The full setup logs from C:\ProgramData\Veeam
- Windows Event logs from windows event viewer (Custom View > Administrative events)
- LocalDB error log from %systemroot%\system32\config\systemprofile\AppData\Local\Microsoft\Microsoft SQL Server Local DB\Instances\VeeamEndPoint\ (it should look like error.log, error1.log, error2.log etc)
- Pack and send it via any available cloud storage (Dropbox/Google Drive/OneDrive etc)
- Ping me via PM or posting to this thread

john_miee
Lurker
Posts: 1
Liked: never
Joined: Feb 07, 2015 8:49 am
Full Name: John
Contact:

Re: Installation fails (SQLLocalDB)

Post by john_miee » Feb 07, 2015 9:00 am

Hi!
I have a similar problem.
All that described above - did not help me. Can you help me?
My system: Windows 7 -x64 (RUS)
Version of Veeam endpoint beta:8.0.0.1822

jkpete
Novice
Posts: 4
Liked: 1 time
Joined: Feb 08, 2015 4:43 am
Full Name: Jeff
Contact:

Veeam EndPoint install fails on Windows 8.1 Laptop

Post by jkpete » Feb 08, 2015 6:15 pm

I recently installed and setup Veeam EndPoint on my Windows 7 PC with no problems. But we have a new Windows 8.1 Laptop that the install fails. The only Antivirus that was running was Windows Defender but I disabled that.

I am running the install from an account with Administrator permissions.
The Install seems to install the DB just fine but fails at the point when it tries to start the EndPoint Service. "Veeam.Setup.Wizard has stopped". If I continue beyond this point and try to start the "Veeam EndPoint Backup" and start the gui/Control Panel I get an error "Veeam.EndPoint.Tray has stopped working". I can't get the gui to stay up.

The "Create Recovery Media" seems to start fine
The "Volume restore" gui seems to start fine
The FLR gui doesn't start
The "Configure Backup"gui doesn't start

If I go into services I can see the The EndPoint Backup service is running. If I manually stop it I can actually start the gui but if it says that the service has failed....once I start the service again the Gui fails and reports the error "Veeam.EndPoint.Tray has stopped working"


Any help would be greatly appreciated.

Thanks

Dima P.
Product Manager
Posts: 11038
Liked: 919 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: Installation fails (SQLLocalDB)

Post by Dima P. » Feb 09, 2015 8:48 pm

John,
Awaiting for the logs from you via PM.

Jeff,
Have you tried the solution described above? If you sill have the installation issues please follow the Still having installation issues? procedure and send me a log package via PM.

Post Reply

Who is online

Users browsing this forum: Insane and 15 guests